Author Topic: Agilent 53132A no display  (Read 1415 times)

0 Members and 1 Guest are viewing this topic.

Offline bobg607

  • Newbie
  • Posts: 2
  • Country: us
Agilent 53132A no display
« on: September 27, 2017, 01:12:25 pm »
Hi,

I've got an Agilent 53132A that doesn't show anything on the display.  When the power button is pressed, the channel 1 and channel 2 trigger led's flash. 

When the owner of it first show it to me he said the display would not show anything but when he pressed the button to show me, a message displayed for about 2 seconds before the display went dark.  The message said something to the effect of 'self-test failure: rom fail'.  I don't know that this was the exact message.  The display brightness was fairly good, as far as I could tell.

The power supply voltages all look good under load.  The VFD has a couple of black marks on the right, kind of like what you see on a well used fluorescent bulb.  I attached a picture.

I'm not sure where to go next with the troubleshooting.  Is it a bad VFD or bad driver for it?  Any help would be much appreciated.

Thanks,
Bob Gonzales
Binghamton University

 
 

Offline ElektroQuark

  • Supporter
  • ****
  • Posts: 1238
  • Country: es
    • ElektroQuark
Re: Agilent 53132A no display
« Reply #1 on: September 27, 2017, 01:16:46 pm »
Those marks are something normal in a VFD tube.
If the display worked when the button was pressed and then turned of, it could be a cracked solder point.

The ROM error for the next step.

Offline PTR_1275

  • Frequent Contributor
  • **
  • Posts: 560
  • Country: au
Re: Agilent 53132A no display
« Reply #2 on: September 27, 2017, 02:34:40 pm »
I can't help you on the display problem, only with a link of what the marks are

https://en.m.wikipedia.org/wiki/Getter
 

Offline bobg607

  • Newbie
  • Posts: 2
  • Country: us
Re: Agilent 53132A no display
« Reply #3 on: September 27, 2017, 04:01:05 pm »
EdoNork,

I did check the switch and then went on to re-flow the solder on all of the thru-hole pins on the display board.  This didn't help.

Regarding you comment about the ROM's, do you mean to say that if there is a ROM problem then there would not be anything displayed, it would be blank?

 

Offline ElektroQuark

  • Supporter
  • ****
  • Posts: 1238
  • Country: es
    • ElektroQuark
Re: Agilent 53132A no display
« Reply #4 on: September 27, 2017, 04:48:47 pm »
No. I wanted to say that if the error message was displayed, the ROM error can't be the cause because of the display isn't working.
Try poking around the front panel when switching on to see if the display works again. It looks like a connection error to my.

Offline Gyro

  • Super Contributor
  • ***
  • Posts: 6168
  • Country: gb
Re: Agilent 53132A no display
« Reply #5 on: September 27, 2017, 06:28:01 pm »
The VFD has a couple of black marks on the right, kind of like what you see on a well used fluorescent bulb.  I attached a picture.

Just to set your mind at rest...

As EdoNork says, the black marks are normal... and good. They are the getters for mopping up stray gasses, just like the ones in the top of valves, they were there from new. If they went white, it would be an immediate indication of seal failure (be careful of that glass pip sticking out). The filaments are also all clearly in tension so no problem there either.

Your problem is definitely electronic... driver, PSU, comms etc. which at least that should be cheaper to fix.
« Last Edit: September 27, 2017, 06:34:25 pm by Gyro »
Chris

"Victor Meldrew, the Crimson Avenger!"
 

Offline texaspyro

  • Super Contributor
  • ***
  • Posts: 1405
Re: Agilent 53132A no display
« Reply #6 on: September 27, 2017, 07:36:49 pm »
It could well be (and probably is) a ROM failure.  The ROM images are somewhere on this forum and I think on ko4bb.com   There are four ROMs.  You can program them into flash memory chips and install them in the ROM sockets.  I just upgraded my 53132A firmware using the images.  You will probably need to re-calibrate the counter after changing the ROMs.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf