Electronics > Repair

Agilent E3648A power supply puzzle


I have a E3648A power supply that had multiple problems.  I believe I’ve repaired the major ones on the analog board but one difficulty remains and has me stumped.

The power supply operates in 1 of 3 modes.

(A)  Normal
(B)  Operating correctly except the readback on both channels unsteady and down approx. 0.5V and 50mA.
(C)  Random MPU stuff (front panel blank, keys unrepsonsive, random stuff displayed like “E3648a?”, over-voltage protection kicking on, etc.).

If power supply is cold (days, not hours) it will start in (A) and stay there for 20-90 minutes.  It then switches to (B) or (C).

If I switch off and back on it continues to misbehave.

If I hit the MPU on the digital board with cold spray and restart, it returns to mode (A) for 5 minutes or so.

So, I assumed the MPU was bad on the digital board and installed a socket and new (from ebay and maybe used) MPU.  Unfortunately, it has the same behavior.  Unless I got really unlucky with the replacement, the problem in not the MPU.

I’ve repaired half a dozen of this family of power supplies.  The voltages appears correct and stable.  I’ve checked for pressure sensitivity on the digital board and touched up a few suspect solder points.  Nothing has helped.  MPU reset appears okay.

So any suggestions for what to look for next?  Broken traces?  Bad sram?  Bad eprom?  ASIC? Something I’m just not thinking of.  As I said, this one has me stumped.

I had similar bad behaviour from a couple of units I did videos about and fixed, I resorted to resoldering the large ICs, voltage regulator on the digital board, That seemed to solve the problem.

Have a look at one or more of my Agilent PSU repairs, including this one for a quite different reason these PSUs can go bad.

Other than that, as well as bad joints, faulty SRAM can be a prime candidate.

Dig out the freezer spray, heatgun, tap the Pcb etc and you may be able to narrow a bad joint or so.

Let us know how you get on......I have quite a soft spot for seeing these PSUs repaired!


I might have solved this one.

As I previously described the MCU came under suspicion and I removed it, installed a socket, and a new (possible used) MCU but the symptoms remained. 

So I ordered a bunch of silicon (MCU, eprom, LDO, SRAM, ASIC) and waited for a slow boat.

It arrived but before installing anything I thought I'd take one more look.  I noticed that one of the eprom/mcu address lines looked a little off.  By pressing nearby I was sometimes able to clear the problems without the use of cold-spray. 

I pulled the MCU and examined my solder for that socket.  The solder for the line I suspected looked okay but the one next to it was was funky so I resoldered all the pads on the socket.  I cleaned the MCU (again) and reinstalled.  It worked for 20 minutes.  I put the cover back on and load tested it for another 40 minutes and it is still working.

I still need to reinstalled the crowbar SCRs and calibrate it.  I also will not really believe it is okay until load testing it for a few more hours but so far it is working better than it ever has.

I'm still somewhat surprised that both symptoms were caused by one issue and that that issue persisted after I soldered in a new MCU socket. 

plcc sockets are crap... if they are not the thick brown ones made from the hard plastic.
i've seen many go bad. the stress on the pins is so high the sidewall bends over time and some pins don;t make contact anymore.
They also grow whiskers like the pest...

i've had several 36xx series supplies where just lifting the rom out of the socket and blasting the socket with air (to blow out the whiskers) fixed it.
i hate those stinkers


[0] Message Index

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod