Electronics > Repair

[solved] Agilent infiniium 54855A calibration problem

(1/2) > >>

Aiy:
Hello everyone,

I am having problems calibrating my Agilent oscilloscope, the failure I get is
Trigger for all four channels.

The output of the calibration routine is
Chan 1 Trigger errors
Interp.Gain
AnalogPath Skew
TrigPath Skew
Pred Delay
LTrig Delay

Does anybody know where to start troubleshooting this?

I am using the correct calibration cable and GHz BNC-to-SMA connectors

Best regards

Aiy:
I noticed today that if I connect the Aux Out to Channel 1 and put Aux Out into Probe Comp mode the signal captured is -1V to 0V. This does not make sense to me, I would have thought it would be a 1kHz 1V peak-to-peak signal for probe compensation.

Can anybody confirm?

I believe that the Aux Out port is connected to a mux with GND, DC-component, 1kHz/1V/p2p and 456MHz-isch demo clock. Maybe one of the supplies for the Probe Comp is bad?

Does anybody know where on the acquisition board the calibration signals are located?

Best regards

Aiy:
I checked another Infiniium scope, it appears that the probe cal signal is a square wave -0.5V to 0V with ~718Hz frequency, so my gut feeling was wrong this time.
Gonna probe the clocks on the acquisition board to see if there's anything fishy

Aiy:
I picked up this project again

The scope triggers funny with external and low frequency signals.
It seems the oscilloscope can sample its own internal 1GHz clock just fine without showing any jitter, I put my probe on the VCO output and it works.
This points to a VCO jitter problem. I have traced the Acquisition board VCO to the synthesizer, an old national semiconductor LMX chip.
The synthesizer is programmed when the scope-app is launched.

I looked in the datasheet for the synthesizer and the setup is Fpd = 1MHz, Fref = 10MHz => R=10, Fin = 1GHz => N=1000.

The synthesizer is programmed so that MUXOUT/LD pin puts N counter on it. I have not yet found where it goes.

Best regards

Aiy:
Hello Everyone,

I tried a disassembler searching for strings in the agscope.exe file (My scope runs version 5.0 after factory reset) and found out that the .exe accepts some interesting flags from the commandline:

--- Code: ---agscope.exe /scope /internal /hpib /service
--- End code ---

gives access to an extra menu under the "Utilities" menu with LOTS of hidden stuff and extra info in the self-test utility.

Flags I found interesting:
factory
service
servicecal
defaultsetup
internal
testflash
hwdebug
debugknobs

I found some information on the Agilent forum over at groups.io, and apparently the old hp5484x .exe file has similar flags.

I also tried a CW source as input to the scope. It seems that the trigger works fine with frequencies over ~500MHz. I feel that this is a big clue to what is wrong with the scope. Perhaps the trigger IC output drive is somehow defective, but the point is that with high enough triggering frequency it works. Which would point to the circuitry after the trigger circuit (U21 Is the trigger IC I believe).

Gotta try to trace the trigger circuit output to the ADC/ASICs next.

Best regards

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version