EEVblog Electronics Community Forum

Electronics => Repair => Topic started by: Mike112 on May 24, 2019, 01:42:34 pm

Title: Agilent Infiniium MSO8104A need help - Solved
Post by: Mike112 on May 24, 2019, 01:42:34 pm
Hi, I was recently given an agilent infiniium MSO8104A scope that is having some issues. When the scope powers up all of the front leds and fans come on and that is about it. The screen stays off and the unit constantly beeps about every 3 seconds. I think its getting stuck passing POST? I have checked the power supply and everything seems to be normal except the post labeled +/- 12.5 have +/-12.1 respectively, I think that is normal? Is this scope worth spending some time on or is it gone?

Thank you!

Fixed: After reseating RAM and CPU scope turned on but gave errors, see below. Updated the drivers, IVI shared components and IO library. One of them failed to install but upon trying to install a second time worked just fine. Restarted scope and still had the same errors. Updated to the newest version of Infiniium, also failed to install the first time, worked the second time trying to install. Newest version of Infiniium took away both errors, scope is up and working great now.
Title: Re: Agilent Infiniium MSO8104A need help
Post by: dzseki on May 24, 2019, 03:20:31 pm
The beeps you noted are often the sign for problem with the RAM on the motherboard, try to reseat them.
Title: Re: Agilent Infiniium MSO8104A need help
Post by: Mike112 on May 30, 2019, 02:59:13 pm

Thanks! I pulled the ram and reseated them, seems to do the trick. The scope started up with out a problem after that but is giving two new errors once in windows.

"The scope vxd is not registered or is out of date" and "Can't register application with acquisition interface board" given by the Infiniium app.

I am thinking this is driver related and could just need an update of the software? Maybe something got unplugged? I also noticed that some of the LEDs are not lit on the front of the panel, others stay lit constantly while the scope is on and wont turn off. The scope would immediately fail a self test and crash infiniium. From what I could tell every knob was working. Could this just be software related?