EEVblog Electronics Community Forum

Electronics => Repair => Topic started by: Tharkun on January 13, 2019, 12:31:19 pm

Title: Agilent U1252A multimeter
Post by: Tharkun on January 13, 2019, 12:31:19 pm
I have an Agilent U1252A multimeter.  All functions seem to work as expected except DC volts which shows 0.0000V no matter what the applied voltage is.  Ac volts is fine, as is dc millivolts, and the frequency counter, ohmmeter etc.

I tried the obvious stuff like fuses, they all checkout fine, can’t see anything obviously wrong like dry joints, bridged or disconnected tracks, bulging or leaking caps, or burnt stuff.

I can’t seem to get hold of the circuit diagram, which makes going further difficult. 

Where do I go from here, maybe someone has had this kind of fault before.  Maybe someone can give me a rough indication of the path I should check, I’m guessing, most multimeters, have input protection, followed by scaling and ranging, then a to d conversion and comparison against an accurate reference, and display.

Any hints anyone? 

Tim
Title: Re: Agilent U1252A multimeter
Post by: nsrmagazin on January 13, 2019, 06:42:04 pm
You have done a lot of work and your guesses are right.

You can try this:
0. Give as pictures of the device and board.
1. If the DC voltage is the only thing thats not working then the supplied voltage to the measuring IC is "0VDC", its not possible to receive "0VDC", it should be something like "0.001VDC". Can you check with a second multimeter the line for the "VDC" voltage measuring from the display to the input. The display should be supplied with the number from some IC, which is directly measuring or is connected to the measuring one.( I don't mean to offend you but it would be good to see how you measure and what is your "VDC" voltage source).