Electronics > Repair

An oldie but a goodie(?)....Tektronix 7L12 SA repair

(1/2) > >>

RedShoeRider:
Good Evening, All:

Though I realize this is a shot in the dark, but perhaps someone else has run into this one!

I recently acquired a Tek 7L12 spectrum analyzer plugin for cheap in an unknown condition. Besides looking like it was run though a dirt machine, it's in ok condition. Gave it a good cleaning; it looks not-halfway-bad now! Inserting it into the 7903 mainframe I have, it rapidly (1sec on - 1sec off - 1 sec on) cycles. After a few seconds, I shut it off, not wanting to hurt the mainframe or the module.

Starting to dig though it, I found that if I removed the connector P872, located on the rear of the unit, it worked! Well, mostly. It powers up, communicates properly with the mainframe, changes modes, etc. It does not display a spectrum though, as I believe that that connector is the power that runs the IF section.

Being that there is a ton of work to go though to troubleshoot out that whole board, has anyone run into this particular problem before, and do you recall how it was fixed? I know it's an old module, well past it's "normal" lifespan, but if someone has seen this before and can point me in the right direction......terrific!

Thanks a lot :)
-Red

tautech:
Not that I have had experience with that module or board, you might like to check for any tag tantalums that have shorted. Have seen it in scopes in the past.

N2IXK:
Have never worked on a 7L12, but the single biggest problem that I have seen with 7000 series plugins are shorted tantalum caps on power rails. For whatever reason (probably cost), Tek allowed very little margin on some of these caps (16V caps on 15V rails, 6V caps on 5V rails, etc.).

Tantalums are a bit cheaper nowadays, so you should uprate your replacements a bit for reliability.

RedShoeRider:
I am so glad that I asked here first!

Thank you both for the input on the matter. I was starting my hunt with the electrolytics and largely ignoring the tantalums, as I haven't really dealt much with them in the limited amount of repair work that I've done in the past. I've mostly stuck to stereo equipment repair; this is one of my first forays into test equipment repair. From the error mode, I largely suspected a power cap issue, but now....now I know where to start my hunt, and that makes life so much easier.

I'll let you know who it is when I find the culprit(s).

My thanks!
-Red

mazurov:
Also, check the plugin compatibility to your mainframe. Some newer plugins draw too much power and 79xx (non-A) MF has weak PS. Both of my 7904 won't work with 7S12 plugin if any of the other 2 slots have a plugin in it.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version