Author Topic: Another Fluke 196C scopemeter repair  (Read 5662 times)

0 Members and 1 Guest are viewing this topic.

Offline noidea

  • Supporter
  • ****
  • Posts: 205
  • Country: au
Another Fluke 196C scopemeter repair
« on: June 20, 2016, 03:37:10 pm »
This post is a long time in the making, I originally started last year when Dave posted his scopemeter repair thread and its been sitting in bits since then so its about time to stop procrastinating and get it working again. The problem with mine seems minor nothing wrong the screen or anything like that, it has just stopped charging via the mains plug pack but will operate with what's left of the charge in the battery which was new just before it stopped working.

I've confirmed the plug pack is functioning correctly ~17VDC coming out of the "Evil centre negative" power jack. I won't bore you with too many photos as Daves video shows the inside of the meter better than my photos do but the first thing that struck me as a bit strange was that the cooling fan was unplugged from the main board. :wtf: I thought there is no way it could have come out of the factory like that but it didn't have any obvious signs that it had been apart before so I kept an open mind.

Things went downhill from there when I took the plastic insulation off the Channel input screening cans and took the main board out of the chassis. There's fresh solder on the board at the power input connector location and it looks like someone has tried a bodge wire to repair the centre pin of the power input connector. Actually I think it could be a candidate in that ugly repair thread which is going at the moment...

Free Electron also suggested checking a small switching transistor V4102 if it wasn't charging, I'm pretty sure its the one I've marked in the last photo and a quick check with a DMM on diode mode indicates its still OK. I think I'm 99.999% certain its just the dodgy input connector in the PCB.

The next issue is souring a replacement connector, I'm in Australia and Fluke don't sell spare parts direct you have to buy via the Australian repair agent. The have quoted me $55 including GST plus postage for the connector which seems a bit extreme for a DC power jack (albeit a rather esoteric one at that). On further thought this is probably why the previous owner did the bodge repair instead of just replacing it in the first place.
I'm not sure if Fluke parts are just expensive because they are Fluke or I'm paying a special privilege because I live in Australia and have to buy through a distributor. 
Before I succumb to buying one locally can anyone in the US check what the Fluke price is for this part for me? the details are: X4101 power connector 4022 244 92561

Or even better is anyone wrecking a 190 series Fluke and wants to sell me the power connector?
Thanks for your help if possible.
« Last Edit: June 21, 2016, 08:47:41 am by noidea »
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 22097
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Another Fluke 196C scopemeter repair
« Reply #1 on: June 21, 2016, 10:38:29 am »
What's the diameter of the DC plug?
Will Jaycar PS-0520 work?

RS or Element14 should be able to help with this.
Avid Rabid Hobbyist
 

Offline noidea

  • Supporter
  • ****
  • Posts: 205
  • Country: au
Re: Another Fluke 196C scopemeter repair
« Reply #2 on: June 22, 2016, 05:32:12 pm »
Thanks for the comments Tautech, the power plug is about 5mm dia with a 2mm bore but slightly different from your run of the mill DC power plug as per the attached photo.

Today I decided to remove the connector so I could take some better photos of it for comparison with others that are available. I'm pretty certain that the Fluke part is going to be the only thing that fits properly as its made so that it keys onto the board and also has some pins on it which hold a sealing gasket in place to seal it up to the top casing of the meter as well.

Once I had taken the connector off the board the bodge wire came free straight away and I could see that it was clipped together. So I decided to pull it apart to see if there was a way I could just replace the centre pin of the connector. I found there's a sealing O-ring inside the connector to seal the plug part from the back which in conjunction with the other gasket is to maintain the IP rating of the meter and I guess is part of the reason they want to charge so much money for a new one  :)

I then tried to put a bit of heat onto the end of the pin which has broken with the aim of trying to melt the solder and see if I could get a bit of wire into the back of the pin. However I ended up separating the pin from the plastic end of the connector which is not the end of the world as I pushed it outwards opposite to the way the plug will normally push on it but it means I can hold the pin in a pair of pliers now. I tried heating it and doing the bang on the desk trick but couldn't get the broken bit of wire out but at least I can see that the pin is hollow at that end.

So my latest plan is to get some micro drill bits tomorrow from a hobby shop and try to drill out some of the broken wire in the end of the pin so that I can insert my own bodge wire into the broken pin. Then hopefully I can reassemble the connector (may need a bit of superglue to retain the pin back in the small plastic bit) and just refit the repaired connector.
Finger crossed that's the plan anyway.
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 22097
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Another Fluke 196C scopemeter repair
« Reply #3 on: June 22, 2016, 07:47:46 pm »
If I'm looking at it as you are....may I suggest some copper coated Mig welder wire for the "splint". That stuff is high tensile and as you have close to a 2mm pin you've got 3 possibilities of sizes; 0.8, 1mm and 1.2mm, all common sizes in an engineering shop.

Keep us in the loop.  ;)
Avid Rabid Hobbyist
 

Offline noidea

  • Supporter
  • ****
  • Posts: 205
  • Country: au
Re: Another Fluke 196C scopemeter repair
« Reply #4 on: June 23, 2016, 02:06:19 pm »
If I'm looking at it as you are....may I suggest some copper coated Mig welder wire for the "splint".
Hi Tautech "Splint" that sounds a bit professional for me, but thanks for the inspiration. I don't have a MIG now but I think I've got some small copper coated TIG wire in my shed.
I was just going to rip a bit of conductor out of some 1.0 mm² solid core electrical cable, I don't think I will get a chance to have another play until the weekend so stay tuned.
 

Offline noidea

  • Supporter
  • ****
  • Posts: 205
  • Country: au
Re: Another Fluke 196C scopemeter repair
« Reply #5 on: June 29, 2016, 04:59:45 pm »
Unfortunately family life has got in the way for a few days so progress has been a bit slow but I managed to get out into the shed tonight and had a go at drilling out the pin of the connector.
Luckily I have a drill press as I only had one shot to get this right and I could see that freehand drilling it was probably not going to work. So the next challenge was how do you hold a little bit of brass that's only 1.8 mm diameter and 10mm long? Answer find a square piece of wood, clamp it in the drill vice and use the drill press to drill a 1.8mm hole in that so its in the same plane as the spindle of the drill, I also cut a slot in the wood once the hole was drilled so that it could clamp down on the pin and stop it from spinning.
Then I eyeballed the centre of the back of the pin, clamped the drill vice to the drill press and had a go it came out marginally off centre but I'm sure it will do the job it needs to do. Please excuse my rusty drill press everything goes rusty in my shed, its pretty old but still really accurate I think its running somewhere around 3000RPM in the photo and there is almost no runout on the drill bit.
Unfortunately the copper coated steel wire I had on hand was 1.6 mm and the copper wire I had was 0.6mm or 1.2mm so I couldn't actually try putting the connector back together. So tomorrows project is to scrounge a bit of MIG wire in my lunchbreak.
 


Offline Assafl

  • Frequent Contributor
  • **
  • Posts: 585
Re: Another Fluke 196C scopemeter repair
« Reply #7 on: July 17, 2016, 03:23:33 pm »
That Reichelt unfortunately isn't the socket (jack). The jack has a small T shaped anchor that anchors it to the PCB at the edge. Had the jack fail on me (same center pin failure). Very strange, spent hours looking at images of jacks and have no idea where Fluke sources them. In Israel they wanted 50-60$ as well...

Good job identifying the DIN45323 standard behind these silly plugs. It may help in the future (or if the plug fails one can search for a replacement).

This is the BOM for the jack and 4 hole rubber seal that fits on top of it.


Item     Description                                Location                                   Short PN         Fluke Long PN          Price

1         Power adapter connector             X4101 (on PCA)                        1285578         4022 244 92561       $28.39

2         Sealing ring for power connector  5 (on disassembly diagram)       1286052         4022 244 98331       $6

 

The issue ordering from Fluke USA is they need Short and Long PN one of which is not available in the service manual. You will also need a US address (I use a mailbox forwarding address in the US). It is tiny so shipping won't be bad. Also - note the price was relevant about a year-year and half ago - not sure it hasn't changed...
« Last Edit: July 17, 2016, 03:33:23 pm by Assafl »
 
The following users thanked this post: Per Hansson

Offline noidea

  • Supporter
  • ****
  • Posts: 205
  • Country: au
Re: Another Fluke 196C scopemeter repair
« Reply #8 on: August 10, 2016, 04:11:47 pm »
Finally got round to putting some closure to this, I ended up getting a scrap of 4mm² electrical cable which yielded a strand of 0.85mm diameter copper wire that I soldered into the hole drilled in the pin. That then got pushed back into place in part of the connector and then the connector got reassembled. I then needed to make sure it wasn't going to come apart too easily but still be able to be fixed if it breaks again so hot snot to the rescue!
I then soldered the connector back into place then reassembled the meter making sure the cooling fan was plugged in this time then plugged in the charger, turned it on and success at last.  :-+

Thanks Yodhe and Assafl for the info about the plug I might try and get a switchmode plugpack to replace the heavy old Fluke brick.

 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf