Author Topic: Sencore LC77 Problem.  (Read 1682 times)

0 Members and 1 Guest are viewing this topic.

Offline Argus

  • Newbie
  • Posts: 2
  • Country: us
Sencore LC77 Problem.
« on: March 14, 2018, 04:51:43 am »
I have an LC77 that will not read capacitance values. All other functions work just fine. Any help with this problem would be greatly appreciated. Thanks.
« Last Edit: March 17, 2018, 07:48:07 pm by Argus »
 

Offline bitseeker

  • Super Contributor
  • ***
  • Posts: 8534
  • Country: us
  • Lots of engineer-tweakable parts inside!
Re: Sencore LC77 Problem.
« Reply #1 on: March 17, 2018, 08:34:48 pm »
Hi Argus. Welcome to the forum. Best place to start is search the forum for the manual and schematics. You can then use them to start probing and narrowing down the problem. Post your findings here, with as much detail as you can (what you did, what's the expected outcome, what you got instead, measurements, etc.), and folks will be better able to help you.
I TEA.
 

Offline Chris56000

  • Frequent Contributor
  • **
  • Posts: 549
  • Country: gb
Re: Sencore LC77 Problem.
« Reply #2 on: March 17, 2018, 10:04:27 pm »
Hi!

The Sencore LC-77 is a very sophisticated microprocessor-controlled instrument with very large amounts of circuitry on three/four big PCB assemblies, I believe the LC-102 manual can be used as a guide!

Unfortunately the schematics I could find are a jigsaw-puzzle collection of upside-down, back-to-front and bits chopped off pieces as they were scanned on only a small A4 scanner!

I'll get them printed out and stuck together later this week (I've no printer at home), then when I've had a chance to do that I'll post back with circuit-descriptions and fault-finding suggestions, there is no theory given in the maker's book!

Watch this space - I'll be back later!

Chris Williams
« Last Edit: March 17, 2018, 10:17:58 pm by Chris56000 »
It's an enigma that's what it is!! This thing's not fixed because it doesn't want to be fixed!!
 

Offline scopeman

  • Regular Contributor
  • *
  • Posts: 181
Re: Sencore LC77 Problem.
« Reply #3 on: March 31, 2018, 04:54:34 pm »
Did you find the LC102 manual? It is on BAMA.

http://bama.edebris.com/manuals/sencore/lc102/


The Cal procedure is attached (found that from another EEVBlog poster.



Sam

P.S. You may want to join my Sencore Group below:

https://groups.yahoo.com/neo/groups/Sencore_Owners_Group/info
 

Offline Sencoretech

  • Contributor
  • Posts: 18
  • Country: us
Re: Sencore LC77 Problem.
« Reply #4 on: July 13, 2018, 01:28:31 pm »
I have an LC77 that will not read capacitance values. All other functions work just fine. Any help with this problem would be greatly appreciated. Thanks.


The LC77 has a series of relays that separate the functions,  They are either black or silver depending on the age of the unit.  You can find them on the top board toward the front of the unit.  They are all next to each other.    They each have 6 pins, 3 on three on the front three on the back.  I lost my schematic in a recent move so I can't tell you the which relay is for the cap value function but I can tell you how to trouble shoot them.

First with the unit off check resistance from center pin to center pin.  You should read something like 5k ohms.   If it reads short or open it's a bad relay.  Once you do that turn the unit it on find the cap value relay and while pressing the cap value function measure it again, it should read short. 

These relays were a very common failure point in these.  Again sorry I couldn't give you a specific relay number. 
 

Offline LC53usr

  • Newbie
  • Posts: 3
  • Country: us
Re: Sencore LC77 Problem.
« Reply #5 on: February 14, 2019, 09:43:20 pm »
I have a Sencore LC53 that works on all functions execpt the capacitance check. The input relay checks ok. I have changed IC8, IC13, and IC14 on the digital board. It doesn't have pulses at the output to check capacitors. I also changed TR20 and TR21 they were bad. The Ics didn't help. Does anyone know what to check. I can't seem to find out how the digital board produces the test signal. I have schematics but don't understand how the digital circuits work. The 200 hz signal is there as well as other osc signals. Any help would be appreciated. I'm about to throw it on the junk pile.
Tony
 

Offline LC53usr

  • Newbie
  • Posts: 3
  • Country: us
Re: Sencore LC77 Problem.
« Reply #6 on: April 11, 2019, 09:40:04 pm »
On my LC53 I changed IC106 CD4017AE with a CD4017BE and TR023. This brought the cap function back alive but doesn't check less than 1uf correctly. Any ideas. At least it works again.
« Last Edit: April 11, 2019, 09:41:41 pm by LC53usr »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf