Author Topic: Anritsu ML2438A 10.00dB offset problem, really weird!!!  (Read 447 times)

0 Members and 1 Guest are viewing this topic.

Offline Tracker

  • Regular Contributor
  • *
  • Posts: 115
  • Country: gb
Anritsu ML2438A 10.00dB offset problem, really weird!!!
« on: January 02, 2022, 10:58:34 pm »
Hi Folks,
I have an ML2438A RF power meter & MA2481D sensor head.
The meter reads with an exact -10.00 db offset, even though the offset function is disabled.
The 50 MHz reference output is correct at 0.0dBm (measured with another meter), but the cal routine fails because the meter reads the reference as -10 dBm.
I am left wondering how such an exact offset error can manifest, it is exactly 10.00db,  most unusual don’t you think!!!

I am considering perhaps some internal attenuator is somehow switched in circuit…? Or a precision voltage divider?
Note: I need to mention again, the offset function is disabled… so I am really puzzled. 

Any suggestions welcome.
Thanks
« Last Edit: January 03, 2022, 11:51:27 am by Tracker »
 

Offline Aiy

  • Contributor
  • Posts: 43
  • Country: se
Re: Anritsu ML2438A 10.00dB offset problem, really weird!!!
« Reply #1 on: January 04, 2022, 09:55:55 pm »
Hello,

If your power head is similar to mine then your head contains a main PCB with two op amps and SPST switches with settable amplification.

Note: There is ribbon bonded connection between the RF diode housing and the main PCB in the head. Do not unscrew the RF diode housing from the main PCB or you risk damaging these bonded connections which will be very difficult to repair without the proper equipment.

Please see my attached images of the power head PCB. The screws that hold the RF diode housing are the two phillips screws on the right side in the first attached image.

Top side:
TI 2202AI - Low Noise Dual op amp (first stage)
Maxim MAX410 - Dual op amp (second stage)
Microchip 24AA64 - I2C EEPROM (for cal tables / identification)

Bottom side:
Maxim MAX383 - Quad SPST switch
SC0838 / SMDA05 - ESD protection diodes

The Maxim switch on the bottom side is used to toggle between amplification factor 1x/10x for the op-amps.

From your description I would investigate the MAX383 to see if the switches work.
 

Offline Tracker

  • Regular Contributor
  • *
  • Posts: 115
  • Country: gb
Re: Anritsu ML2438A 10.00dB offset problem, really weird!!!
« Reply #2 on: January 06, 2022, 12:58:52 pm »
Hi Aiy,
Thanks for the information, I took a look over your previous post about the faulty diode you had and was making some measurements on my probe so I have some photos and info to share.

My probe is a little different but very close to yours, see images attached.
It covers -70 to +20 dBm using three three diodes, probably because each has a different square law response.

On top side :
The same TI 2202AI opamp
Maxim MAX412 instead of the MAX410 dual opamp
Microchip 24AA64 same as yours

On the bottom we have:
Large IC with label (GAL16V8Z programable gate array) not on yours, this seems to be for diode switching.
Maxim MAX393 switching device (whereas yours is MAX383)
5 x  diodes (W5D) and 3x ESD protection diodes (SMDA05 & LCDA05)

On the main meter PCB, J1 (the ribbon connecting the probe to Motherboard) I have recorded some interesting voltage readings.
I measured here because it was just easier that opening the probe again (see final image attached, J1 is the left side)
I also fitted a step attenuator between the 0dBm refence and the sensor.

Pin 1 is +5.5v when the sensor input power goes > -10dBm, otherwise it is low.
Pin 11 is +5.5v when the sensor input power goes < -10dBm, otherwise it is low.
This appears to be switch drive logic and depends on the power level detected, there may be a third state which I suspect is triggered at higher powers like +10 dBm etc.
Three states would match the three front end diodes.

Pins 9 and 10 carry the 245 Hz chopped & amplified signal from the sensor diodes, putting a scope on these shows 500mV p-p square wave when the probe is connected to the 50MHz 0dBm reference.
500mv seems quite low for a 0 dBm input signal and is probably why the meter is reading -10 dBm .. don't you think?

I will investigate the switching logic a bit more, I expect a third state will arise.
Then I will see if the logic is actually switching the diodes correctly.

« Last Edit: January 06, 2022, 02:56:22 pm by Tracker »
 

Offline Aiy

  • Contributor
  • Posts: 43
  • Country: se
Re: Anritsu ML2438A 10.00dB offset problem, really weird!!!
« Reply #3 on: January 06, 2022, 07:52:29 pm »
That's very interesting. The three-diode solution I have not seen before, maybe someone can shed some light on why they choose this way to do it.
Back to your problem,
Does the sensor do the same thing on both ports on the power meter?
Do you have another sensor to test with? I can recommend the Anritsu MA2422B Thermal RF Sensor (10MHz to 18GHz, -30dBm to +20dBm) which you can buy pretty cheap from Valuetronics on eBay https://www.ebay.com/itm/174245933088

Best regards
AIY
 

Offline Tracker

  • Regular Contributor
  • *
  • Posts: 115
  • Country: gb
Re: Anritsu ML2438A 10.00dB offset problem, really weird!!!
« Reply #4 on: January 06, 2022, 08:17:20 pm »
Hi Ayi
Yes it's exactly the same behaviour on both ports.
But I'm not 100% convinced it's a problem with the sensor. It is possibly a logic problem on the Meter. The meter generates the control logic. So I'm not quite ready to purchase a new sensor just yet.

If anyone out there has a similar sensor,  they might be so kind as to measure the chopped voltage on the main board when measuring the 0.0dBm reference.
If 500mv is normal, then it's a Meter fault. But if 500mv is incorrect then it's a sensor fault.

Thanks
 

Offline Aiy

  • Contributor
  • Posts: 43
  • Country: se
Re: Anritsu ML2438A 10.00dB offset problem, really weird!!!
« Reply #5 on: January 21, 2022, 03:24:34 pm »
Hi,
Sorry for not coming back sooner. I got some spare time today and opened up my machine.

On my ML2438A with MA2474A head the voltage between pin 9-10 on main PCB J1 is 310mV when connected to the calibration port. The voltage is not switching with 245Hz

Best regards
 

Offline Tracker

  • Regular Contributor
  • *
  • Posts: 115
  • Country: gb
Re: Anritsu ML2438A 10.00dB offset problem, really weird!!!
« Reply #6 on: January 21, 2022, 07:06:10 pm »
Thanks Aiy,
That seems to indicate the fault is on my meter.... much appriciated
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf