Author Topic: Apple A1407 Thunderbolt monitor  (Read 1130 times)

0 Members and 1 Guest are viewing this topic.

Offline BurningTantalum

  • Frequent Contributor
  • **
  • Posts: 297
  • Country: au
Apple A1407 Thunderbolt monitor
« on: April 04, 2018, 09:44:47 am »
I have an Apple A1407 freestanding 27" monitor to repair for a friend. It has what seems to be a common problem with the SMPS in that it makes an irritating noise. I can find many comments on the net about this issue but no technical posts. The monitor will not power up unless connected to a Macbook with the Thunderbolt cable, so I removed the PSU and loaded it up beyond spec on the bench but it remained silent. Hopefully I can borrow a Macbook, but the monitor is a real pain to dismantle and operate with the heavy screen lifted up. The interconnects to the screen are really short so it cannot be moved more than a few centimetres, with the monitor lying on its back.
Has anyone any experience with this issue?
I hope that I can identify which wound component is the cause, and may be tempted to make a 'dam' and pot it in epoxy.
Any comments, or info about jigging it to power up without the Thunderbolt connection?
Regards, BT
 

Offline BradC

  • Super Contributor
  • ***
  • Posts: 1661
  • Country: au
Re: Apple A1407 Thunderbolt monitor
« Reply #1 on: April 04, 2018, 10:39:43 am »
I've had one die twice, but both times it was dead Jim. That is the most common failure mode and is caused by one or more MLCC on the PSU logic rail going short leaving the psu burping trying to repeatedly start.

Try this post https://discussions.apple.com/thread/4820647

I managed to diagnose and fix mine twice on the bench without the panel in place or being connected to a Mac. From memory the PSU will fire up on application of power.

I'm a couple of thousand K's from home at the moment, so I can't dig out any more detail I'm afraid. I do recall last time removing a couple of MLCC and replacing them with leaded components as each time it was the same value on the same rail that died. My Bob Parker ESR meter used as a milliohm meter was handy in helping locate the faulty cap.
 

Offline BurningTantalum

  • Frequent Contributor
  • **
  • Posts: 297
  • Country: au
Re: Apple A1407 Thunderbolt monitor
« Reply #2 on: April 04, 2018, 02:30:15 pm »
Thanks for that, Brad. The monitor was still working fine but emitting an irritating noise after a few minutes on time. Higher brightness increased the noise.
I wanted to fire up the monitor, including display, to load the psu with whatever current waveform caused it to make a noise. I hoped that poking the main transformer and/or the choke would identify which one was making the noise, then I could try to surround it with a Plasticene 'dam' and pour in some very fluid epoxy.
I could only load it with a resistive load on the bench. A new psu was considered too expensive by the owner.
BT
 

Offline BradC

  • Super Contributor
  • ***
  • Posts: 1661
  • Country: au
Re: Apple A1407 Thunderbolt monitor
« Reply #3 on: April 04, 2018, 04:33:23 pm »
Oh sorry. My misunderstanding. I thought it was dead.

If its any consolation my 2011 iMac is starting to get noisy under certain light load conditions. I figure rather than things needing epoxy it's a sign that some of the caps are starting to age in the PSU. I'm torn between pulling it to bits and fixing it, or waiting for it to fail first. I figure they have something in the order of 61K hours on them now, and the iMac tends to run warm by default. So it's getting toward "that time".

My Thunderbolt display is not that much newer, so it's probably similar. In my experience, excepting laminated core transformers, stuff doesn't tend to get noisy without a reason. At the risk of sounding trendy, have you checked the bulk caps for ESR?
 

Offline BurningTantalum

  • Frequent Contributor
  • **
  • Posts: 297
  • Country: au
Re: Apple A1407 Thunderbolt monitor
« Reply #4 on: April 05, 2018, 02:08:35 am »
No I haven't, but am on my way out of the door now to do so!
I will report back later, possibly with a red face, thanks.
BT
 

Offline BurningTantalum

  • Frequent Contributor
  • **
  • Posts: 297
  • Country: au
Re: Apple A1407 Thunderbolt monitor
« Reply #5 on: April 05, 2018, 02:24:52 am »
All three 68uF 450v caps are around 0R5 which seems about right. The other electrolytics are as I would expect.
I have the Macbook arriving Saturday so hope to identify what is making the noise.
BT
 

Offline BradC

  • Super Contributor
  • ***
  • Posts: 1661
  • Country: au
Re: Apple A1407 Thunderbolt monitor
« Reply #6 on: April 05, 2018, 04:33:28 am »
I have the Macbook arriving Saturday so hope to identify what is making the noise.

Keep us posted then.
 

Offline BurningTantalum

  • Frequent Contributor
  • **
  • Posts: 297
  • Country: au
Re: Apple A1407 Thunderbolt monitor
« Reply #7 on: April 07, 2018, 09:04:10 am »
The owner called by with the computer which turned out to be a Mac Pro that looked like the love child of a rice cooker and an electric kettle. Anyway the monitor would not light up. I suspected the panel connector to the main pcb as it is a real Mickey Mouse item that seems to fall out of its socket too easily. The lead, and the lead next to it, that go to the display are so ridiculously short that they pull out of their sockets before there is enough clearance on lifting the display to allow a hand inside to disconnect them. They have no locking tabs.
I sent the owner away whilst I licked my wounds, but then realised that there is an identical connector on the other end of the lead hidden beneath a flap of tape on the display itself. This may have been displaced also, so I await the return of the Mac Pro to have another attempt at firing up the monitor.
I suspect that the frequency of the LED modulated supply is causing the noise in the wound components of the psu.
The choke is mounted through a large hole in the pcb (to reduce the fitted height I suspect), but the main transformer is mounted on the psu board facing the metal case so is not easy to poke to dampen the noise to isolate it. The whole monitor is beautifully made but not intended for dismantling for servicing.
Regards, BT
 

Offline BradC

  • Super Contributor
  • ***
  • Posts: 1661
  • Country: au
Re: Apple A1407 Thunderbolt monitor
« Reply #8 on: April 07, 2018, 02:39:11 pm »
That Sounds peculiar. I had no issues getting mine to bits, testing it bodged together or reassembling it. I certainly had no issues getting connectors out without stressing connectors or cables. I wonder if they revised the design to make it nastier later in the design life. The one I'm using (and have repaired twice) is about. 2012 vintage.

I have a brand new one here in wrapping, as I rely on it and they are now discontinued I decided to buy a spare while they had stock, but I'm not game to pop it open to have a look.
 

Offline BurningTantalum

  • Frequent Contributor
  • **
  • Posts: 297
  • Country: au
Re: Apple A1407 Thunderbolt monitor
« Reply #9 on: April 08, 2018, 10:36:29 am »
Just for info- the cable from the main pcb to the panel is 160mm long, contacts to contacts, and is rigid so even if it was longer it would not accept a Z-bend. When the unit is assembled the two connectors are nearly in the same plane so any movement of the panel away from the metal case strains the connector.
I wish I had never started this but will post back when it is sorted.  The monitor is 3 years old. I am surprised that no-one on the net has posted any info as to which pins of the Thunderbolt cable to bridge or supply to fire up the monitor, which would make life a lot easier.
Give me a standard monitor or TV anytime- remove the back panel and everything is there.
BT
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf