Author Topic: Aron BS-601 Oscilloscope vertical amp issue (FIXED)  (Read 2295 times)

0 Members and 1 Guest are viewing this topic.

Offline The_Todd

  • Regular Contributor
  • *
  • Posts: 71
  • Country: au
Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« on: January 27, 2019, 04:47:33 am »
Hello guys,

im trying to fix a Aron BS-601 scope but the issue im having is the vertial part is not worki ng properly, whatever signal you put in ans whatecer setting you use the trace is always very thin and flat.

the problem is the the vertical amp, its only pumpi g out about 12v to the scope with of couse needs to be much more. ive attached the circuit that im refring to, the circuit has all the corect voltages going ito it and q19 nd q20 also have the 120v sitting behind it.
however about 12v is geting to the outputs

The exact way this circuit works is a bit  beyond my capa bilities but if i coukf get any help it wold be appreciated.


Sent from my iPad using Tapatalk
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #1 on: January 27, 2019, 04:51:48 am »
Could it be a simple severe case of contact tarnished. Have you tried cleaning the contacts?
Watch the video;

 

Offline The_Todd

  • Regular Contributor
  • *
  • Posts: 71
  • Country: au
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #2 on: January 27, 2019, 04:53:25 am »
Yup tried that. And the signal is dull overall. No matter how much i fiddle with the switches


Sent from my iPad using Tapatalk
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 18056
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #3 on: January 27, 2019, 10:39:09 am »
With zero signal and V position centered each plate should see ~60V.
The 120V is supplied to the final output amps via a current limiting resistor so down stream from that check for componentry failed short that might effect both plates.
Things like C38.
Avid Rabid Hobbyist
 

Offline The_Todd

  • Regular Contributor
  • *
  • Posts: 71
  • Country: au
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #4 on: January 27, 2019, 12:45:36 pm »
With zero signal and V position centered each plate should see ~60V.
The 120V is supplied to the final output amps via a current limiting resistor so down stream from that check for componentry failed short that might effect both plates.
Things like C38.

Oh that makes sense il check
 it tkmmorrow


Cheers


Sent from my iPad using Tapatalk
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 18056
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #5 on: January 27, 2019, 09:10:27 pm »
You might also spend a little time studying this, it can be very helpful in pointing you in the right direction:
http://www.sphere.bc.ca/test/tek-parts/troubleshooting-scopes.pdf
Avid Rabid Hobbyist
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #6 on: January 27, 2019, 10:10:58 pm »
Hi, I see that you can probe around powered on, so you know well the safety aspect.

Aside from the multimeter, what other kinds of testing instruments or component testers do you have?
 

Offline The_Todd

  • Regular Contributor
  • *
  • Posts: 71
  • Country: au
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #7 on: January 27, 2019, 11:11:41 pm »
I have all the Main tool, incuding a working scope and microscpe.


Sent from my iPad using Tapatalk
 

Offline The_Todd

  • Regular Contributor
  • *
  • Posts: 71
  • Country: au
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #8 on: January 28, 2019, 12:57:42 am »
Here is a  pic of the signal the best i can get it,  thisis a .5v test signal







Sent from my iPad using Tapatalk
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #9 on: January 28, 2019, 03:14:01 am »
You have a handful of equipment there.  ;D

The test signal, what was the volt/div you used and was the probe set to Divide by 10 setting?

If you set the volt/div to lowest 10mv/div any change?

If you switch your probe to Divide by 1 any change?
 

Offline The_Todd

  • Regular Contributor
  • *
  • Posts: 71
  • Country: au
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #10 on: January 28, 2019, 03:27:55 am »
You have a handful of equipment there.  ;D

The test signal, what was the volt/div you used and was the probe set to Divide by 10 setting?

If you set the volt/div to lowest 10mv/div any change?

If you switch your probe to Divide by 1 any change?

yeah just few thing :)

the probe is on 1x

and no mater what there is little difference. it will go anywhere from a dead straight line to a small signal
about 1cm in hight. and that it. ive tried every setting and different probes and bot sides are the same.
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 18056
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #11 on: January 28, 2019, 03:57:29 am »
By any chance are the red knobs on the V/div not clicked home in the Cal position ?
Avid Rabid Hobbyist
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #12 on: January 28, 2019, 04:19:35 am »
We have tried the easy ones, now the harder part [your choice, up to you if you want to do it, considering the age of this scope];

Please be careful, observe safety.

Use a working scope, set to AC, probe Divide by 10, Volt/Div as appropriate;

The scope under repair, set to 10mv/div, apply test signal into the input.

Probe with respect to GND, [if you are save the traces, please post it up]

Collector Q5, then Collector Q6,
Collector Q9, then Collector Q10
Emitter Q13, then Emitter Q14

Volt meter measure Voltage at Cathode of D10 and then Anode D14 with respect to GND.
[You sure you have checked the 5V, 12V and 20V?]

The above just merely divide the areas of search.

I suspect one of the common biases is OUT.


 

Offline The_Todd

  • Regular Contributor
  • *
  • Posts: 71
  • Country: au
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #13 on: January 28, 2019, 04:27:11 am »
We have tried the easy ones, now the harder part [your choice, up to you if you want to do it, considering the age of this scope];

Please be careful, observe safety.

Use a working scope, set to AC, probe Divide by 10, Volt/Div as appropriate;

The scope under repair, set to 10mv/div, apply test signal into the input.

Probe with respect to GND, [if you are save the traces, please post it up]

Collector Q5, then Collector Q6,
Collector Q9, then Collector Q10
Emitter Q13, then Emitter Q14

Volt meter measure Voltage at Cathode of D10 and then Anode D14 with respect to GND.
[You sure you have checked the 5V, 12V and 20V?]

The above just merely divide the areas of search.

I suspect one of the common biases is OUT.

Oh this is detailed thank you, my other scope is analog too, so ill try and try and get photos.

with the ground isolation, i haven't got an isolation transformer, so should it be ok without it
or should I detach the ground odd the faulty scope of the scope used for testing? (and yes, all equipment
i use is going thought a safety switch designed for testing equipment)

thank you again,for you help. 
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #14 on: January 28, 2019, 04:35:41 am »
Your scope is powered by isolation transformer already.

I only assumed here the isolation transformer is working fine, otherwise use a isolation transformer to be safer.

Just don't, NEVER probe beyond the isolation points like probe the mains....
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #15 on: January 28, 2019, 05:07:41 am »
Don't know if your schematic is updated, the old one has 2 Q4 there;

Anyway, see attached.

You start with mid point pairs. if no signal despite lowest V/div, you forget downstream points, always move upstream.
Conversely if there are signal, then move downstream mid points and repeat same procedure. Divide by 2, Divide by 2.... got the idea.?

That will cut measurement points down a lot.

Hope you understand this short English.
 

Offline The_Todd

  • Regular Contributor
  • *
  • Posts: 71
  • Country: au
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #16 on: January 28, 2019, 05:29:06 am »
We have tried the easy ones, now the harder part [your choice, up to you if you want to do it, considering the age of this scope];

Please be careful, observe safety.

Use a working scope, set to AC, probe Divide by 10, Volt/Div as appropriate;

The scope under repair, set to 10mv/div, apply test signal into the input.

Probe with respect to GND, [if you are save the traces, please post it up]

Collector Q5, then Collector Q6,
Collector Q9, then Collector Q10
Emitter Q13, then Emitter Q14

Volt meter measure Voltage at Cathode of D10 and then Anode D14 with respect to GND.
[You sure you have checked the 5V, 12V and 20V?]

The above just merely divide the areas of search.

I suspect one of the common biases is OUT.


Ok let’s star with Q5 collector




Sent from my iPhone using Tapatalk
 

Offline The_Todd

  • Regular Contributor
  • *
  • Posts: 71
  • Country: au
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #17 on: January 28, 2019, 05:32:48 am »
Q6 collector




Sent from my iPhone using Tapatalk
 

Offline The_Todd

  • Regular Contributor
  • *
  • Posts: 71
  • Country: au
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #18 on: January 28, 2019, 05:34:06 am »
Q9 collector take
Note I had to advise DIV to 50mv
Also q9 looks like it had been replaced recently




Sent from my iPhone using Tapatalk
 

Offline The_Todd

  • Regular Contributor
  • *
  • Posts: 71
  • Country: au
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #19 on: January 28, 2019, 05:37:21 am »
Q10 collector




Sent from my iPhone using Tapatalk
 

Offline The_Todd

  • Regular Contributor
  • *
  • Posts: 71
  • Country: au
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #20 on: January 28, 2019, 05:42:11 am »
Q13 emitter




Sent from my iPhone using Tapatalk
 

Offline The_Todd

  • Regular Contributor
  • *
  • Posts: 71
  • Country: au
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #21 on: January 28, 2019, 05:42:55 am »
Q14 emitter




Sent from my iPhone using Tapatalk
 

Offline The_Todd

  • Regular Contributor
  • *
  • Posts: 71
  • Country: au
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #22 on: January 28, 2019, 05:56:43 am »
Don't know if your schematic is updated, the old one has 2 Q4 there;

Anyway, see attached.

You start with mid point pairs. if no signal despite lowest V/div, you forget downstream points, always move upstream.
Conversely if there are signal, then move downstream mid points and repeat same procedure. Divide by 2, Divide by 2.... got the idea.?

That will cut measurement points down a lot.

Hope you understand this short English.

Hmmmm im a bit confused. im sure the signals getting through to the end but its just not strong enough, seeing as both outputs are the same could it be assumed there is a mutal fault thats dragging down both sides?


Sent from my iPad using Tapatalk
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #23 on: January 28, 2019, 06:02:39 am »
Let's persist on until we conclude to the deflection plates;

Volt meter measure all the Base Collector Emitter Voltages of the followings Transistors with respect to GND;

Q15 Base =     V
       Collector =    V
       Emiter =       V

Until Transistor Q24.
 

Offline The_Todd

  • Regular Contributor
  • *
  • Posts: 71
  • Country: au
Re: Aron BS-601 Oscilloscope vertical amp issue (FIXED)
« Reply #24 on: January 28, 2019, 06:03:34 am »
Also seing the jump in voltage from the first and second pair of transistors , One would assume  the signal is amplifying  correctly ?


Sent from my iPad using Tapatalk
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf