Author Topic: Faulty Fujitsu P50XHA58E 50 inch plasma display  (Read 867 times)

0 Members and 1 Guest are viewing this topic.

Offline deephaven

  • Frequent Contributor
  • **
  • Posts: 783
  • Country: gb
  • Civilization is just one big bootstrap
    • Deephaven Ltd
Faulty Fujitsu P50XHA58E 50 inch plasma display
« on: March 09, 2015, 09:39:28 am »
My Fujitsu 50 inch plasma has suddenly developed a fault. It was worked flawlessly for several years and has never been moved. It now has a thin vertical line of faulty pixels which is about the centre of the screen horizontally and extends from the top of the picture till about halfway down vertically. The line is picture dependent and is not visible at all on a black scene. Please see attached picture.

Is this likely to be the plasma panel itself or a driver? What are the possibilities of repairing this?

 

Offline tom66

  • Super Contributor
  • ***
  • Posts: 4144
  • Country: gb
  • Electron Fiddler, FPGA Hacker, Embedded Systems EE
Re: Faulty Fujitsu P50XHA58E 50 inch plasma display
« Reply #1 on: March 09, 2015, 11:56:47 am »
Unfortunately looks like a defective PDP to me. You could try reseating the connector for that part of the screen - in itself this might not fix the issue, but if it's a bonding failure when the ribbon meets the panel it might help.
 

Offline deephaven

  • Frequent Contributor
  • **
  • Posts: 783
  • Country: gb
  • Civilization is just one big bootstrap
    • Deephaven Ltd
Re: Faulty Fujitsu P50XHA58E 50 inch plasma display
« Reply #2 on: March 09, 2015, 07:59:02 pm »
Unfortunately looks like a defective PDP to me. You could try reseating the connector for that part of the screen - in itself this might not fix the issue, but if it's a bonding failure when the ribbon meets the panel it might help.

Thanks. I'll open it up and see if anything is loose.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf