Electronics > Repair

CH341A Programs Correctly but BIOS Still Won't Work

(1/1)

shuten:
hi all, so i have an acer XC-605 desktop which i believe had a bad bios flash.
i setup an ssd for it and it didnt get recognized in the bios so i attempted a bios update with the provided gui from acers website (going from P11.A2 to P11.B4). i rebooted and it seemed the bios update was successful but when i turned off the pc, it would no longer turn on properly and gave me one long beep (fan goes on, maintains power but no display etc, seems to fail post).

i tried a bunch of stuff like reseating ram etc and tried to reflash from usb but since nothing worked i eventually just bought a ch341a and tried to manually flash it.

so when i connect the clips and run the ch341a software, everything looks fine, i can read the chip (MX25L6473E) and write to it, and the software verifies and shows me successful prompts, however the PC still does not start up. i no longer get the beep at startup so i know something definitely changed, but i still get nothing on display.

i tried multiple programmer software and various bios versions but get the same results.
ive used, asProgrammer, NeoProgrammer, CH341A programmer by Shichang Zhou, but no difference.
even tried changing the chip size in the software to 4MB since the bios file is 4MB.
mobo model is MS-7869 v1.0 for reference

im sure it must just be something im missing but i have no idea, anyone have any ideas or suggestions?

thank you!

Navigation

[0] Message Index

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod