Author Topic: Chinese Attiny85 - doesn't upload  (Read 871 times)

0 Members and 1 Guest are viewing this topic.

Offline kalel

  • Frequent Contributor
  • **
  • Posts: 880
  • Country: 00
Chinese Attiny85 - doesn't upload
« on: October 16, 2017, 05:09:28 pm »
One of those attiny boards with flashed bootloader isn't working. I have two, and one does work and does upload when USB is plugged in.



I have installed the Digispark drivers.

Since one works, and the other doesn't, I assume a possible hardware issue. I have checked voltages of the not working one.

5V - GND 4.7v
VIN - GND 4v
P5 - GND 4.4v
P3 - GND 2.9v
(those are the only two with significant voltage)


Power LED is on.

I don't have a scope, logic analyzer, or external programmer. Any ideas of what else to check?
« Last Edit: October 16, 2017, 05:42:40 pm by kalel »
 

Online edavid

  • Super Contributor
  • ***
  • Posts: 2816
  • Country: us
Re: Chinese Attiny85 - doesn't upload
« Reply #1 on: October 16, 2017, 05:16:26 pm »
Are you sure it has the bootloader?  I have bought some of these that arrived blank.  Others from the same seller were fine.
 
The following users thanked this post: kalel

Offline kalel

  • Frequent Contributor
  • **
  • Posts: 880
  • Country: 00
Re: Chinese Attiny85 - doesn't upload
« Reply #2 on: October 16, 2017, 05:37:11 pm »
Both of the units (working and not working) are from the same seller.
Is it possible that some come with the bootloader and some not?

I can't be sure if it has the bootloader, since I don't know a way to verify.
Maybe the bootloader has a specific start up procedure that could be seen or measured? Well, with a multimeter.
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Chinese Attiny85 - doesn't upload
« Reply #3 on: October 16, 2017, 05:37:47 pm »
Reinstall the bootloader.

http://digistump.com/wiki/digispark/tutorials/connecting

Edit: Read the troubleshooting inside.
« Last Edit: October 16, 2017, 05:46:16 pm by Armadillo »
 
The following users thanked this post: kalel

Offline kalel

  • Frequent Contributor
  • **
  • Posts: 880
  • Country: 00
Re: Chinese Attiny85 - doesn't upload
« Reply #4 on: October 16, 2017, 05:52:01 pm »
Reinstall the bootloader.

http://digistump.com/wiki/digispark/tutorials/connecting

Edit: Read the troubleshooting inside.

Does it mention somewhere how the bootloader is reinstalled (that's after taking a look)? Is this possible without an external programmer? Unfortunately I don't have one.
 

Online edavid

  • Super Contributor
  • ***
  • Posts: 2816
  • Country: us
Re: Chinese Attiny85 - doesn't upload
« Reply #5 on: October 16, 2017, 05:53:34 pm »
Is this possible without an external programmer? Unfortunately I don't have one.

You can use an Arduino, but if you don't have one, or don't want to bother, just ask for a refund.
 
The following users thanked this post: kalel

Offline kalel

  • Frequent Contributor
  • **
  • Posts: 880
  • Country: 00
Re: Chinese Attiny85 - doesn't upload
« Reply #6 on: October 16, 2017, 06:05:30 pm »
Is this possible without an external programmer? Unfortunately I don't have one.

You can use an Arduino, but if you don't have one, or don't want to bother, just ask for a refund.

Too late for a refund. It's probably not worth buying a programmer for this.
I have an Arduino UNO clone, but I am a novice.

With the very limited information, is there some confidence that the likely cause is the bootloader missing or not being flashed properly, and not a hardware issue?

In any case at least it's very affordable.

 

Offline ebclr

  • Super Contributor
  • ***
  • Posts: 1838
  • Country: 00
Re: Chinese Attiny85 - doesn't upload
« Reply #7 on: October 16, 2017, 07:30:00 pm »
Just plug USB without any HUB, This product isn't Hub friendly, try a port on the computer without a HUb
 
The following users thanked this post: kalel

Offline kalel

  • Frequent Contributor
  • **
  • Posts: 880
  • Country: 00
Re: Chinese Attiny85 - doesn't upload
« Reply #8 on: October 16, 2017, 07:44:59 pm »
Just plug USB without any HUB, This product isn't Hub friendly, try a port on the computer without a HUb

I'm not using a hub, but it is on front panel. I could try motherboard directly, but the other unit works (1 out of 2).
 

Offline stj

  • Super Contributor
  • ***
  • Posts: 2156
  • Country: gb
Re: Chinese Attiny85 - doesn't upload
« Reply #9 on: October 17, 2017, 10:04:46 am »
look very closely at the soldering,
i have read that some people have had poor soldering on similar boards using STM controllers.
to be specific, your looking at the soldering on the usb socket.
 
The following users thanked this post: kalel

Offline kalel

  • Frequent Contributor
  • **
  • Posts: 880
  • Country: 00
Re: Chinese Attiny85 - doesn't upload
« Reply #10 on: October 17, 2017, 10:31:20 am »
look very closely at the soldering,
i have read that some people have had poor soldering on similar boards using STM controllers.
to be specific, your looking at the soldering on the usb socket.

It's kind of hard to see or even picture the MicroUSB joints properly. Right next to other tiny components too.

Some images:

 
Another note is that I do get "A request for the USB device descriptor failed." in device manager. But, from what I've read somewhere, this can happen with healthy units too depending on what code they are executing.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf