Electronics > Repair

Cisco/Linksys WVC-210 PTZ camera

(1/1)

SL4P:
If anyone has one of these, it's worth pulling it apart BEFORE it fails...

Mine stopped working wirelessly - but any number of problems were hiding under the plastic covers.  Wired operation was still ok.

Four philips screws on the rear - and you can pop the clamshell apart -
You don''t need t undo the WiFi antenna connector - it can stay where it is.
The problem I needed to fix was a 1000uF 6V3 electrolytic which was bulging slightly. (replaced with 10V - circled in photo)

To get him out - you need to disconnect the camera gymbal and motor assembly - which revealed problem #2 - broken shock mounts.   The camera had never to my knowledge been dropped etc - but three of the four rubber mountings were totalled.

Depending on your circumstances - you can reconstruct the plastic lugs as needed around the rubber grommets and screws,  (Photo shows how I 'ballsed it up' neatly).

Massaging the main PCBs out of the case is straightforward - but you need to wriggle sideways a bit around the antenna connector.

The WiFi module is socketed (DIMM - under camera assembly) onto the main board and is easy to release.  I just unplugged and reconnected it to 'clean' the edge connectors.

Jumpered everything back together - and all working as it should... except the main clamshell assembly screws were also toasted (one of four was holding, but plastic split).

A bit of 2-part epoxy and some heatshrink sleeve (photo) around the 'plastic posts' will hold them together for a few more years.

Good luck!

Navigation

[0] Message Index

There was an error while thanking
Thanking...
Go to full version