Author Topic: CMU200 Rohde & Schwarz hangs during BaseDiscoverOptionsBegin  (Read 5000 times)

0 Members and 1 Guest are viewing this topic.

Offline Ice-Tea

  • Super Contributor
  • ***
  • Posts: 1476
  • Country: be
    • Freelance Hardware Engineer
Re: CMU200 Rohde & Schwarz hangs during BaseDiscoverOptionsBegin
« Reply #25 on: April 23, 2019, 04:13:16 pm »
I wonder how long it took to develop the CMU200, considering its complexity and engineering...

Think the better question is "how big was the team" ;-)
eBay shop with all the gear you need!
FS: Agilent 54825A, R&S CMU200, CRTU, SMIQ06L, Marconi 6201B, Lecroy WP 950, 9354TM, 9354M, 9374L LC584A, Tek THS720P, TDS7154B, Anritsu MG3671A 2.75G I/Q RF gen, Keithley 238 SMU, HP 8642B, 8903A, 8110A, 8156A
 

Offline Bicurico

  • Frequent Contributor
  • **
  • Posts: 931
  • Country: pt
    • VMA's Satellite Blog
Re: CMU200 Rohde & Schwarz hangs during BaseDiscoverOptionsBegin
« Reply #26 on: April 23, 2019, 04:31:02 pm »
Yes, of course. I meant "how long" in "man years"...

Still, it is impressive when you are messing inside a CMU200: so many modules, each with several boards, custom IC's, FPGA, software, etc.

Then all the PCB layout, circuit design, materials (silver plated modules, etc.).

I can't begin to imagine how much work, research, development went into such a device.

No wonder they were sold new at around 100.000 Euro (?).

Regards,
Vitor

Offline Ice-Tea

  • Super Contributor
  • ***
  • Posts: 1476
  • Country: be
    • Freelance Hardware Engineer
Re: CMU200 Rohde & Schwarz hangs during BaseDiscoverOptionsBegin
« Reply #27 on: April 23, 2019, 06:00:31 pm »
Pretty sure for 100k you got a base unit and not much else...
eBay shop with all the gear you need!
FS: Agilent 54825A, R&S CMU200, CRTU, SMIQ06L, Marconi 6201B, Lecroy WP 950, 9354TM, 9354M, 9374L LC584A, Tek THS720P, TDS7154B, Anritsu MG3671A 2.75G I/Q RF gen, Keithley 238 SMU, HP 8642B, 8903A, 8110A, 8156A
 

Offline Bicurico

  • Frequent Contributor
  • **
  • Posts: 931
  • Country: pt
    • VMA's Satellite Blog
Re: CMU200 Rohde & Schwarz hangs during BaseDiscoverOptionsBegin
« Reply #28 on: August 21, 2019, 08:31:03 am »
Yesterday one of my CRTU units booted first fine. Then I switched it off but remembered I needed to measure something else, so I turned it on again. Unfortunately the serial number recognition during BaseDiscoveryOptions took much longer than usual and the dreaded error message appeared.

Strange, though, it said "error# 1095 overlay.c system error" instead of the usual "dsp.c" error.

I restarted and then the CRTU booted OK, but on successive boots, even after one night off, it now always produces this "overlay.c" error.

I don't have the time and nerve right now to start swapping HDD and DIGITAL board, though I am pretty sure this will be DIGITAL board related.

Any idea what this could be?

It disturbs me that these fine units are starting to fail due to the DIGITAL board and the small PCB's attached inside, which are basically impossible to repair.

Regards,
Vitor
« Last Edit: August 21, 2019, 08:43:52 am by Bicurico »
 

Offline Ice-Tea

  • Super Contributor
  • ***
  • Posts: 1476
  • Country: be
    • Freelance Hardware Engineer
Re: CMU200 Rohde & Schwarz hangs during BaseDiscoverOptionsBegin
« Reply #29 on: August 21, 2019, 09:17:18 am »
If you figure out which board crapped out, contact me. I can probably offer a spare.
eBay shop with all the gear you need!
FS: Agilent 54825A, R&S CMU200, CRTU, SMIQ06L, Marconi 6201B, Lecroy WP 950, 9354TM, 9354M, 9374L LC584A, Tek THS720P, TDS7154B, Anritsu MG3671A 2.75G I/Q RF gen, Keithley 238 SMU, HP 8642B, 8903A, 8110A, 8156A
 

Offline Bicurico

  • Frequent Contributor
  • **
  • Posts: 931
  • Country: pt
    • VMA's Satellite Blog
Re: CMU200 Rohde & Schwarz hangs during BaseDiscoverOptionsBegin
« Reply #30 on: August 22, 2019, 08:38:16 am »
Update:

Swapped DIGITAL board with a known good unit --> same error message! This is NOT related to the DIGITAL board...
Run scandisk and defrag from Service Menu --> No issues found
Swapped HDD with one of another CRTU --> device booted OK, but with fW 3.x instead of FW 5.x (which was active on that HDD -> because of compatibility with Windows 2000 partition)
Went inside Service Menu and installed "Another FW", selecting an alternative FW5.x version (less options installed) --> device boots OK on the original HDD

Conclusion: I think some file/data got corrupted and reinstalling the FW fixed it?

Strange...

Regards,
Vitor


Offline Bicurico

  • Frequent Contributor
  • **
  • Posts: 931
  • Country: pt
    • VMA's Satellite Blog
Re: CMU200 Rohde & Schwarz hangs during BaseDiscoverOptionsBegin
« Reply #31 on: August 22, 2019, 09:01:39 am »
Another update:

It is not the HDD or some file corruption.

Activated the original FW5.x with many options and the error comes up again!

So now I come to the conclusion that this error is related to some hardware option that got broken. If the FW does not have support for said option, the unit powers up ok.

Back to FW 5.x with just the GSM option, the device works ok.

Since I swapped the DIGITAL board, it must be some other board/module.

This is a 83 unit. The other broken unit I have is a 82 unit, so I cannot swap all boards, as they are different. I don't want mess with the other working units (CMU200 and CRTU 82).

I don't suspect the RXTX board at this moment.

However, I would be grateful for any idea regarding which board/module might be malfunctioning.

As I really only use this CRTU for spectrum and signal generator, I will leave it as is for now until new ideas come up.

Regards,
Vitor


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf