Author Topic: Component failure troubleshooting guidance needed  (Read 132 times)

0 Members and 1 Guest are viewing this topic.

Offline Crambone

  • Contributor
  • Posts: 38
  • Country: us
Component failure troubleshooting guidance needed
« on: November 20, 2019, 05:12:44 am »
Hello all and thank you for taking the time to read this.
I have a transceiver (solid state) that I lost partial power to a TP (test point).
The test point calls for 4.3Vdc and I’m seeing 2.2Vdc. The power to the test point is fed from component Q66 (2SB754Y). Emitter and Base are showing proper voltage of 13.8Vdc but Collector only shows 2.2Vdc. I suspected a bad Q66 but when tested showed good. So I left the Collector off and I see the 13.4 volts but when soldered back in place goes back to 2.2Vdc.
I checked continuity from TP7 to ground and showed a short but it only lasted 3 seconds then went away. After disconnecting test probe from TP7 for 2 seconds and touching again I see the short again for 3 second, it will do this all day. I’m assuming something is shorted from Q66 to TP7.

Now the question is what component in a circuit would give that type of on off continuity to ground?
I’ve included a link to the schematic I that’s allowed?
Any guidance were to look would be much welcomed. Being new to this all it’s hard for me to follow the schematic considering it’s a double sided board and lots of surface mount components.
The Service Manual page 55 shows the component layout.
http://www.cbtricks.com/radios/rci/rci_2985dx/graphics/rci_2985dx_95dx_sm.pdf
http://www.cbtricks.com/radios/rci/rci_2995dx/graphics/rci_2995_dx_sch.pdf
 

Offline floobydust

  • Super Contributor
  • ***
  • Posts: 3161
  • Country: ca
Re: Component failure troubleshooting guidance needed
« Reply #1 on: November 20, 2019, 05:48:30 am »
I believe Q66/Q67 form the TX switch for the RF power amp driver Q60 and Q62.

What usually goes wrong is a driver shorts (i.e. Q60 or maybe Q62) and that overloads/cooks the TX switch Q66 and the voltage just collapses, as you are seeing. So that section likely works fine, it's just being overloaded.

If you are measuring continuity from the switched power bus TP7,8,9 to GND, a multimeter will charge all capacitors on that which can take several seconds. D94, C260 etc. will interfere with that measurement so you must isolate the part you are testing.

You could just pull Q60 out or lift one of its leads and then diode-test it. I would do that, and for Q62 as wild guess one or both have failed.

The purpose behind three testpoints TP7, TP8, TP9 is for open-circuiting them and then measuring current flow at each one.
When setting bias current, say for Q62 when adjusting VR13, it's 10mA with no modulation, across  TP8-9. For Q60 when adjusting VR11+VR12, it's 50mA each with no modulation, so 100mA total across TP7-9.

If it's easy to open-circuit a TP7-TP9 bridge, then that's another method to check continuity to GND on Q60 without the rest of the circuitry in the way. I don't know what the PCB looks like, if these are solder-jumpers or what. The service manual has some special board "short pcb" though.

edit: Q66 is a 2SB754? That's fairly huge 7A transistor but not powering the final power amp?
« Last Edit: November 20, 2019, 05:58:03 am by floobydust »
 

Offline Crambone

  • Contributor
  • Posts: 38
  • Country: us
Re: Component failure troubleshooting guidance needed
« Reply #2 on: November 20, 2019, 06:35:40 am »
Ya TP7, 8 & 9 are connected with a silver board that can be easily be pulled out. I pulled it out to check voltages on each. TP7 was the only one with the 2.4v on it so I’m guessing TP7 supplies voltage to TP8 & 9.
With that silver board out I don’t show any continuity to ground on TP8 or 9 just 7 and it only last for a few seconds. It’s going to be a task as it’s mostly surface mount 
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf