Electronics > Repair

Dead LeCroy 9414

(1/3) > >>

davorin:
Just wanted to install my 9414 to measure noise from different fans in my 9354AL....worked before like a charm...
and now suddenly dead as a mouse...

When powering on...no lights on, also fan is not running....when switching off I hear some relay clicking...

Don't they have some primary switched power supply to generate all voltages?

Running now the service manual through Acrobat pro to make a searchable PDF (o;

davorin:
Got the manual searchable now...

Interesting....only thing I can found regarding "removal of power supply" is just this small text:


--- Quote ---The power supply support (33) and the card retainer ( 34) hold the
F9450-2 (15), F9410-6 (29), F9410-3 (28) F9420-4 (27), and the F9451-1
or 94XX-1701 (18) power supply in place and mus t be removed if any of
these boards is to be removed . They are fixed with screws and washers
see figure 4 . 1 and 4. 2.
--- End quote ---

Removing the card retianer makes no sense to me....and removing the power supply support makes it somehow loose...but power supply can't be removed....
And a very nice design that is so damned close to the CRT neck to kill it by accident...

ANyone a suggestion how to safely remove the pwoer supply without killing the CRT neck?

grumpydoc:

--- Quote ---ANyone a suggestion how to safely remove the pwoer supply without killing the CRT neck?
--- End quote ---
Remove the whole front panel including the CRT, then you can put it aside while you get the PSU out - it all pulls off as a single unit and there are just two ribbon cables connecting it to the CPU card - one for video and CRT power and another from the front panel rotary encoders and switches.

davorin:
Ah thanks...will try that tomorrow carefully...

My desk is still occupied with my 9354AL and me busy doing different fan testing/measurements (o;

Wondering if the power supply is repairable at all...or someone ran into the same problem...but when I look at the schematic and block diagram...all it does is +/-5V and +/-15V....and RefZ..

davorin:
Got the power supply out now....without removing the front panel...besides..the description in the 9410 manual isn't that helpful like in the 935x manual...

See nothing suspicious on the power supply module..nor does it smell like burned resistor, capacitor and the like...high voltage transistor is also okay...
and from the clicking noise when powering off I suspect some rail DC rail is shortened to ground and protection circuit kicks in...

Think I have some 5V 10A switcher supply somewhere on stock..and the +/-15V rails I can feed from my 6632Bs.


Okay...got the pin numbers from board 9424_1:


--- Code: --- 1: Line Sync
 2: GND
 3: VCC
 4: GND
 5: VCC
 6: GND
 7: VEE
 8: VEE
 9: +15V
10: -15V
--- End code ---

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version