Author Topic: Delta Elektronika SM3540-D  (Read 1148 times)

0 Members and 1 Guest are viewing this topic.

Offline K3RT

  • Newbie
  • Posts: 3
  • Country: fi
Delta Elektronika SM3540-D
« on: July 04, 2016, 09:41:49 pm »
Hello, I am new here. :)

I got myself a Delta Elektronika SM3540-D 35V/40A power supply.  8)
I am very happy with it overall (never had so powerful power supply), but have one tiny problem with it.
The output voltage won't go down to 0V.
Even if I turn the V-pot all the way to "0", I get 0,56V on output.
Only way to get 0V is when I turn the current limit also to 0A.

I have found that there are trim-pots inside to adjust the diplay readings, but they don't affect the actual output.
There are some trim-pots also without any markings, but I won't dare to touch them unless I am 100% sure what I am doing.
Can anyone please tell me, is there a way to adjust the output to zero?
Here is link to a PDF file containing the manuals and schematics:
https://ia600208.us.archive.org/32/items/delta_elektronika_delta_elektronika_sm3540-d_power_supply_sm/delta_elektronika_sm3540-d_power_supply_sm.pdf
« Last Edit: July 04, 2016, 10:18:07 pm by K3RT »
 

Offline janoc

  • Super Contributor
  • ***
  • Posts: 2949
  • Country: fr
Re: Delta Elektronika SM3540-D
« Reply #1 on: July 04, 2016, 10:03:46 pm »
That is a pretty heavy duty PSU!

I think it may not be actually able to reach true 0V (what do you need that for, actually?) because the control loop would stop working if it didn't sense any output voltage. I would expect that to be mentioned in the manual, though.

If you really need small voltage from it, I think the simplest solution would be to add a post regulator
 

Offline K3RT

  • Newbie
  • Posts: 3
  • Country: fi
Re: Delta Elektronika SM3540-D
« Reply #2 on: July 04, 2016, 10:16:26 pm »
Well, I actually don't need it.
When I got it, the diplay readings were bit off, so I calibrated them with my DMM. And then I noticed that the output won't go down to 0V. So I was wondering, if it would just need some fine tuning, or is it a "feature"?
It would be nice to have it 100% working as new.
« Last Edit: July 04, 2016, 10:22:02 pm by K3RT »
 

Offline RobK_NL

  • Frequent Contributor
  • **
  • Posts: 250
  • Country: nl
Re: Delta Elektronika SM3540-D
« Reply #3 on: July 06, 2016, 06:34:19 pm »
You can always shoot an e-mail to support[at]delta-elektronika.nl

They are *very* supportive!
Tell us what problem you want to solve, not what solution you're having problems with
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf