Author Topic: Dyson V10 wont give power to brush motor  (Read 12176 times)

0 Members and 1 Guest are viewing this topic.

Offline anartioTopic starter

  • Newbie
  • Posts: 3
  • Country: lv
Dyson V10 wont give power to brush motor
« on: April 08, 2024, 12:06:46 pm »
Hope for your help.
I have got problem "not spinning any brush" with Dyson V10 Animal.
Everything works fine, except brushes.
I found in internet a self-made schema of similar VC (not sure it fully correct). I also got V17 from a friend of mine for testing.
What I have done before this topic:
With an oscilloscope I checked what was going on when V10/V17 starts without connected brush.
And I got a same graph pattern on both VCs.
On good V17 pcb starts PWM output voltage on terminals (16 volts).
On broken V10 with connected brush : tries to start for short amount of time and instantly stops (by graph on oscilloscope same as like it not connected)
And I swapped U24, and U13 (ICs on schema) from V17 to V10 . And this ICs is absolutely OK.
At this point I can assume that V10 can't see a connected accessory brush.

 Unfortunately, lack of knowledge can't lead me to solution. I cant't understand how V10 get OK signal when brush connected.
 Hope that somebody helps me find a solution.
 Regards, Andy
« Last Edit: April 08, 2024, 12:40:38 pm by anartio »
 

Offline m k

  • Super Contributor
  • ***
  • Posts: 2162
  • Country: fi
Re: Dyson V10 wont give power to brush motor
« Reply #1 on: April 10, 2024, 07:52:45 pm »
Rotation feedback is a normal thing.
So without feedback the motor is stuck, despite what actually happens.
Advance-Aneng-Appa-AVO-Beckman-Danbridge-Data Tech-Fluke-General Radio-H. W. Sullivan-Heathkit-HP-Kaise-Kyoritsu-Leeds & Northrup-Mastech-REO-Simpson-Sinclair-Tektronix-Tokyo Rikosha-Topward-Triplett-YFE
(plus lesser brands from the work shop of the world)
 

Offline anartioTopic starter

  • Newbie
  • Posts: 3
  • Country: lv
Re: Dyson V10 wont give power to brush motor
« Reply #2 on: April 11, 2024, 05:38:34 am »
Thanks for your reply.
I know that mainboard sens connected motor and checks rotation while it spinning.
Issue that VC mainboard cant detect connected brush motor or thinks that it stuck.
Brush motor absolutely ok. I've got two of them and they works fine with another VC.
 

Offline m k

  • Super Contributor
  • ***
  • Posts: 2162
  • Country: fi
Re: Dyson V10 wont give power to brush motor
« Reply #3 on: April 11, 2024, 05:01:43 pm »
Maybe it's the other end of the trace, or the trace it self.

There can also be a load check.
Usually it's for over current, but can be for under current, at least in theory.
Advance-Aneng-Appa-AVO-Beckman-Danbridge-Data Tech-Fluke-General Radio-H. W. Sullivan-Heathkit-HP-Kaise-Kyoritsu-Leeds & Northrup-Mastech-REO-Simpson-Sinclair-Tektronix-Tokyo Rikosha-Topward-Triplett-YFE
(plus lesser brands from the work shop of the world)
 

Offline turenabo

  • Newbie
  • Posts: 4
  • Country: sg
Re: Dyson V10 wont give power to brush motor
« Reply #4 on: April 15, 2024, 05:02:03 am »
my v10 doesn't work now, it makes a "boing" then stop, how can I figure it out?
 

Offline m k

  • Super Contributor
  • ***
  • Posts: 2162
  • Country: fi
Re: Dyson V10 wont give power to brush motor
« Reply #5 on: April 15, 2024, 09:54:05 am »
Is "boing" an information sounded by a controller or something that happens because of mechanical something?
Advance-Aneng-Appa-AVO-Beckman-Danbridge-Data Tech-Fluke-General Radio-H. W. Sullivan-Heathkit-HP-Kaise-Kyoritsu-Leeds & Northrup-Mastech-REO-Simpson-Sinclair-Tektronix-Tokyo Rikosha-Topward-Triplett-YFE
(plus lesser brands from the work shop of the world)
 

Offline voltsandjolts

  • Supporter
  • ****
  • Posts: 2330
  • Country: gb
Re: Dyson V10 wont give power to brush motor
« Reply #6 on: April 15, 2024, 09:58:31 am »
Is the battery pack failing? I mean, does the battery voltage drop when the brush head motor starts, so much so that the electronics decide to switch it off again because there isn't enough power?
 

Offline anartioTopic starter

  • Newbie
  • Posts: 3
  • Country: lv
Re: Dyson V10 wont give power to brush motor
« Reply #7 on: April 16, 2024, 09:53:17 am »
Thanks for your reply.
No...Battery  is absolutely ok. Even on "Turbo mode" voltage drop is insignificant.
Like I said before...Its looks like Mainboard cant detect connected accessory to provide voltage.
And I can't determine what exact component  is responsible for this.
Regards.
 

Offline fzabkar

  • Super Contributor
  • ***
  • Posts: 2346
  • Country: au
Re: Dyson V10 wont give power to brush motor
« Reply #8 on: April 16, 2024, 07:25:21 pm »
I can't see how your circuit is able to detect the brush motor's rotation. The best it could do is to detect the motor current via R33, but there is no electronics at this point.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf