Electronics > Repair

EG&G 5209 lock-in amplifier repair

(1/5) > >>

MichaelPI:
Hello all,

I bought an used LIA a couple of month ago - unfortunately, the LIA has some problems.

The lock-in had unresponsive buttons and not plausible (not changing) signs on the LC display. After heating up (certainly more than 20 minutes) the error slowly disappeared. It took me a while to figure out, what the root-cause actually was. All supply voltage rails (there are plenty of them in this instruments) had a resonable value - at least measured with the multimeter. Only by checking the supply voltage of the digital part with the scope I could find out, that the +5V rail had repetitive dips. Finally, I could track it down to a partially shorted electrolytic capacitor directly after the full-bridge rectifier.
I replaced all of those caps and the instruments is at least operable.

Two things are still not ok, one is the PLL and the other the calibration.

The first issue is, that at higher frequencies of more than approx. 7 kHz I get always an "PLL unlock" condition. This is also the case, if I use an external function generator.
I have currently difficulties to find the failure, as I only know the rough location of the PLL. Even worse I do not have a service manual and it seems as if someone has already done some "modifications" to the board. I don't really think those "bug fixes" have been installed by the manufacturer - it just looks to bad.  :palm:

Maybe someone has the service manual or a similar unit and could support fixing the remaining issues.

Thanks.

Michael





Kleinstein:
The bodge wires don't look very nice, but they could very well be original. If not a leakage sensitive part, some flux residue is not a problem, if it is no clean flux. Such a change would be odd if done later as a mod - It more like looks a layout error to correct.

It is some 23 years since I used one such LI.  Not directly related to the PLL issue, but I remember a small bug (could be fixed in later versions): the auxiliary DAC outputs uses OPs (TL074 AFAIR) to directly drive the outputs and these don't like capacitive load from a cable.

AFAIR the manual included schematics. At least a know that I looked at the schematics and I don't think we had an extra service manual. I would not be surprised to find an 4046 PLL chip. I would expect the PLL also to be used for the phase shift - so I would first check if the fine phase shift works OK at lower frequency.

MichaelPI:
This is not the worst modification in the instruments - there is one with removed traces, added diodes and resistors and a couple of bodge wires. Maybe all of this has been fixed in later revisions of the board.

Mine is from 1987 and made in the US. I have seen a couple of these instruments marked as Made in Ireland - which suprises me quiet a bit.
I checked the user manual, but there is no schematic included.

Actually the phase shifting is working fine at lower frequencies. As soon as I increase the frequency, the LIA goes nuts and displays an incorrect signal, before it goes into unlock condition.

The 4046 does not seem to be used, I recognized a MC4044 next to the magic black box. I will do some more tests tomorrow. Today I removed the filter board, which is on top of the main circuit board and the connector to the input amplifier - otherwise the demodulator and oscillator is not accessible.


Kleinstein:
The 4044 can make sense as part of the PLL. There may actually be more than one PLL, e.g. one for the generator and one for the Lockin part to "generate" the ref. signal and do the phase shift.
However as far as I remember the internal generator frequency is not locked to the main clock used the measure the frequency and than adjust the filter setting accordingly. I remember that the automatic mode for the filter was not that stable: if the frequency drifted, the filter setting could change and this effects the response a little. So it is better to set the filter frequency manually.

For the phase shift I would expect to find some kind of DAC (maybe R2R) and OP in combination with the PLL.
AFAIK the coarse phase shift (90 deg, maby 45 deg. steps is done digitally, starting from 2 or 4 times the frequency. The fine phase shift should be together with the PLL, by adding some analog signal to the output of the phase - frequency converter and than have an integrating filter.

If the PLL does not work at higher frequencies, I see 3 main modes of failure:
1) Excessive noise (reaching the nonlinear range at higher frequency)
    This could be something like power supply ripple.
2) trouble with the VCO that does not work well to higher frequency (e.g. extra offset)
3) if the loop filter is switched depending on the frequency, this could go wrong.

Giving wrong data before the unlock may indicate a noise problem (or an unlock detection that does not work well).

For the large frequency range I would expect to have the actual VCO to run at a relatively high frequency and than have a switchable divider for the lower frequency ranges. The loop filter may also need switching to get faster response at higher frequency.

LCR:
Hi, I do not know if a service manual for 5209 exists somewhere. There is an old document “MODEL 5209 LOCK-IN AMPLIFIER INSTRUCTION MANUAL 219567-A-MNL-C” with schematics. Do you have it?

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version