Author Topic: Fixing Behringer Xenyx302 USB (PCM2902) Intermittent noise/distrortion issue  (Read 2672 times)

0 Members and 1 Guest are viewing this topic.

Offline cte7ds

  • Contributor
  • Posts: 47
  • Country: fi
  • hello world
    • my github
Ever since I purchased the Xenyx302 back in August 2015, I had this really strange issue where the left audio channel would suddenly be overlaid with some kind of continuous distortion noise.
What made the issue so strange was how randomly it presented itself, sometimes I could go weeks without having the issue but sometimes I couldn't even go a day without having to deal with it (switching the card off and back on again).



Here's a short capture of the noise while I was watching EEVblog:
https://soundcloud.com/user-425960372/pcm2902-intermittent-distortion-issue/s-OHjUS

For the longest time I thought it was either a Pulseaudio or ALSA bug, until one of the Pulseaudio developers pointed out to me the errata for the PCM2902:
http://www.ti.com/lit/pdf/slaz036
http://www.ti.com/lit/pdf/slel057


Based on the USB Product ID, I was able to determine that the chip inside my Xenyx302 was indeed this badly behaving PCM2902E revision.
Initially I had disregarded this errata because I thought a device sold in 2015 (date coded: 1412) wouldn't have a silicon bug that was fixed in 2008 according to the docs...
But I guess Behringer didn't bother to renew their stock or something..?

So I ordered a pin-compatible PCM2902C (http://www.ti.com/product/pcm2902c/description) from TI Store to replace the old erroneous chip.

The rework job I did with a 2mm chisel tip soldering iron, a piece of ~0.3mm magnet wire and some Chemtronics flux coated solder wick.
I didn't use enough flux and the magnet wire was a tad too thick, so I ended up breaking one of the pads but that wasn't a big deal.
So if you intend to ever try this, remember to use a lot of flux!  Low melting point solder would also work wonders I imagine.

It's been a couple of months now and the issue is finally completely gone!   ^-^

I'll attach some pictures of the operation below.
Perhaps someone will find this useful some day :-//


Now, of course the mandatory: "While I was in there, I also"-part:  :-/O
- Added a linear taper 50K stereo pot in-series with the 2-Track input for volume control
- Replaced the 100uF headphone output DC blocking capacitors with 330uF ones (I got 16 ohm headphones..)
- Halved the headphone outputs 47-ohm series resistors (Lower values made the background hiss too loud for my headphones)
- Replaced the AD8602D with a supposedly better suited AD8397 (motivated by: https://nwavguy.blogspot.fi/2011/03/behringer-uca202-frankendac.html)

The audiophoolery mods I did in the hopes of finding a way to reduce the background hiss (The Behringer-hiss  :P) at higher volume levels.
Reducing the output impedance via lower resistor values makes the output louder but also makes the hiss louder...
Changing the headphone op-amp didn't have any effect that I could perceive.
Changing the output caps did make a noticeable difference in the low end bass. (a slight improvement imho.)
 
The following users thanked this post: WattSekunde, edavid, fixy88

Offline depretux

  • Newbie
  • Posts: 1
  • Country: ar
Hey!

I'm resurrecting this old thread to thank you for the information. It encouraged me to open my unit up and search for a way to stop the headphone out from monitoring (I removed resistors R79 and R58).

I wonder if you could help me with another issue, though.
How did you wire your potentiometer to the 2-track input?

Did you cut the trace on the PCB and placed the pot in series with the inputs? It's not completely clear on the pictures, and I'm absolutely ignorant about electronics.

Thanks a lot!
 
The following users thanked this post: cte7ds

Offline cte7ds

  • Contributor
  • Posts: 47
  • Country: fi
  • hello world
    • my github
Hey!

I'm resurrecting this old thread to thank you for the information. It encouraged me to open my unit up and search for a way to stop the headphone out from monitoring (I removed resistors R79 and R58).

Oh wow, super cool that someone found motivation from my post!  :-+
When you say "stop from monitoring", do you mean you found a way to mute "Main Mix" from headphone out?
Because that is one of the items on my Hacking TODO list for this device  :-/O




I wonder if you could help me with another issue, though.
How did you wire your potentiometer to the 2-track input?

Did you cut the trace on the PCB and placed the pot in series with the inputs? It's not completely clear on the pictures, and I'm absolutely ignorant about electronics.

Yeah, I cut the bottom PCB trace next to the 2-track RCA connector and wired the pot like this:



Thanks a lot!
No problem!  ^-^
« Last Edit: October 23, 2017, 12:33:17 pm by cte7ds »
 
The following users thanked this post: WattSekunde

Offline Finestre

  • Newbie
  • Posts: 1
  • Country: au
Has anyone found a solution to mute "Main Mix"(MIC) from headphone out?

Sorry old post.
 

Offline WattSekunde

  • Regular Contributor
  • *
  • Posts: 81
  • Country: de
Is the 2020 version different? On my unit all input signals are always on the headphone output.
 

Offline cte7ds

  • Contributor
  • Posts: 47
  • Country: fi
  • hello world
    • my github
Is the 2020 version different? On my unit all input signals are always on the headphone output.
Could you upload a closeup picture of the PCB?
 
The following users thanked this post: WattSekunde

Offline WattSekunde

  • Regular Contributor
  • *
  • Posts: 81
  • Country: de
Sure, but I am now on vacation for the next two weeks. If I am back at home I will unscrew it and take high res photos

It is very confusing, and I would definitely change it. Maybe it‘s a fault. Thank‘s for your quick response.  :-+

PS: I found my signal flow diagram of the Xenix302USB. [attach=1]

And that‘s what I would prefer: [attach=2]
« Last Edit: July 22, 2020, 12:17:59 pm by WattSekunde »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf