Author Topic: Fluke 8600A battery powered multimeter - convert to line only  (Read 2817 times)

0 Members and 1 Guest are viewing this topic.

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Fluke 8600A battery powered multimeter - convert to line only
« on: November 18, 2018, 08:50:44 pm »
Got this very clean 8600a for $10 at a hamfest yesterday, and rather than clutter the TEA thread I'm making a separate one to track the repair/conversion. 

I have an 8600A already, and it's possibly my most used bench meter; all the features I need, and plenty accurate for audio work.  So adding another at such a great price was a no-brainer.  But the battery operation is frankly of no interest to me; I have plenty of portable DMMs and having to disassemble a meter just to periodically replace fussy old NiCd batteries would be a distraction, particularly when I have to extract it from a stack of other gear on the TE shelf to do so.   Of course I checked the forum for existing threads on the subject:

https://www.eevblog.com/forum/testgear/fluke-8600a-battery-power-supply-conversion/

and learned that I shouldn't power it up without the batteries installed.  One of the batteries is kaput, and the 5VDC is only about 4.3V even when powered off the AC line.  In spite of this, DCV is fairly accurate; but ACV is way off and Ω is very flaky.  Some of this may be dirty switch contacts but until I get solid power to the unit I really don't want to do more than clean the switches and inspect for obviously damaged components.  The cal sticker was still in place from 1974, so it's likely that the meter was retired without ever being opened or tweaked.

It looks very clean inside; even the battery leak was contained by the plastic holder and nothing got onto the board.  So there's nothing shouting "replace me".  OK, maybe the tantalums are whispering a little, but again until I get power to the board, I'm not listening.   ;)

The big question (addressed in the link above) is how to go about supplanting the battery power.  Xrunner did a nice total replacement of the supply, and others have suggested I just drop in replacement batteries and be done with it.  I'm favoring replacing the batteries with a cap and some form of LDO regulator, to minimize power dissipation and give the inverter a stable input.  The transformer is a different model, not designed to run the same regulator setup that the line powered unit has, so I'll either have to do this or replace the whole PSU.

Right now, the first step will be to disconnect the PSU from the rest of the meter so I can see how much voltage I have to work with and not fry anything in the process.  Then I'll see what my options are for a rugged 5V regulator and proceed from there.
 
The following users thanked this post: elecdonia

Offline bd139

  • Super Contributor
  • ***
  • Posts: 13659
  • Country: gb
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #1 on: November 18, 2018, 10:01:35 pm »
Subscribed :D
 

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #2 on: November 19, 2018, 12:26:10 am »
OK, just a brief update, but one which might be critical to someone trying to work on an Option 01 8600A.

First of all, on some versions of the PCB drawing in the manual, CR22 is mis-labeled as CR21, meaning there are (2) CR21 diodes on the sketch.  CR22 is adjacent to CR23 over by the transformer.  CR21 is next to CR20.

Second, after all the head scratching about the regulator parts CR27 and Q43 I went to look for them - and they do not exist!  They are shown on the board layout and the schematic but are absent on my board.  Looks like on the early revs of the 8600A, Fluke didn't feel that the regulation was necessary and omitted these parts.  My manual is apparently a later rev.

This is doubly interesting because the PCB actually has traces and markings for both types of unit: line-powered and battery.  The difference is in the transformer part number and whether some of the components are populated or not.  It looks like I'll be able to put a filter cap and a regulator right on the board, maybe route the 5VDC to the inverter board without too much effort.  The main difference is that the regulator will have to source a little more current because it's powering the inverter board as well as the logic.
 
The following users thanked this post: fzabkar

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #3 on: November 19, 2018, 10:15:41 pm »
After locating all the bits of the power supply, I decided it was more profitable to press on with troubleshooting rather than wait till the internal supply was redesigned.  I had to disconnect the AC part from the DC part anyway for testing, so I fed my HP bench supply +5VDC into the common DC section and brought up the meter.  All of the supply voltages are good, so I can cross off the DC-DC supply board from my list of concerns.

DCV is spot on from a few tens of mV up to 500V in both manual and auto ranging modes; if I read the manual correctly that means the input divider and ADC are functioning properly.  It behaves just like my other 8600A when ranging, which increases my confidence that the core of the meter is working.

ACV works OK up to about 2.5V and then the display never goes any higher.  Autoranging can't find its happy spot and keeps looping if I put anything more than a couple of volts in.  The test procedure shows a low output from the board but doesn't pinpoint a likely source.  There are some tantalum caps which probably should be examined.

Ω also works up from a dead short up to a few tens of ohms and then won't go higher.  Autoranging won't even try, and leaving the leads disconnected gives some odd value of a few ohms in both modes.

Someone blew the Amps fuse (it was the proper value) and I didn't spot any signs of damage but maybe one of the input rectifiers is fried because injecting a current doesn't give any display. 

I can't shake the notion that there's something in common with the ACV and Ω misbehavior - they share relay K4 but none of the others, so that's worth looking into - though K4 seems to be working fine on DCV.
 

Offline med6753

  • Super Contributor
  • ***
  • Posts: 5401
  • Country: us
  • Tek nut
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #4 on: November 20, 2018, 05:05:07 pm »
You also have a fully functional 8600A, correct? Put them side by side with the same input and have at it comparing one to the other. It will save a lot of time troubleshooting.  :-+
An old gray beard with an attitude.
 

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #5 on: November 20, 2018, 05:55:57 pm »
Yes, and that's absolutely next on the list.  My latest tests indicate that the problem seems to be the reed relays; the ones which route the signal for ACV and Ω do not sound like they're activating on ranges above the "2" scale and that seems to line up with the ranging errors.  I was hoping it would be something else, but everything points to bad relays.  I need to do a few checks to find the best way to measure the coil voltage and contact status inside the box, and if that turns out to be it I won't need to compare meters just yet.  I know I could just shotgun replace them, but I'm trying to understand the circuit a little better while doing this - which slows the process down.    :P

I remember your issues with the 8800A and whether or not this is the entire problem I'll bet it's still causing errors.  Did you come up with replacement part #s for all the Fluke relays?  I have listed the HE3300 series you bought for the 600Ω and 125Ω replacements, but I seem to recall there was another reed relay for which a replacement hasn't been identified yet?

Edit: Both the Fluke/Coto 40069 and 40070 have 600Ω coils - not sure what the difference is?  And the U6P is the 150Ω (nominal 125?) coil.
« Last Edit: November 20, 2018, 06:27:23 pm by GregDunn »
 
The following users thanked this post: elecdonia

Offline elecdonia

  • Contributor
  • Posts: 38
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #6 on: November 20, 2018, 09:50:20 pm »
Quote
My latest tests indicate that the problem seems to be the reed relays; the ones which route the signal for ACV and Ω do not sound like they're activating on ranges above the "2" scale and that seems to line up with the ranging errors.  I was hoping it would be something else, but everything points to bad relays.

The relays are driven by the programmable FPGA chip. It has open collector outputs. I caused more than one of these chips to fail by operating the 8600A with one or more of the daughter cards unplugged. I believe that generated overvoltage spikes at selected FPGA output pins, causing either a permanent short to ground or a permanent open. I had enough parts donor units on hand to obtain working FPGA chips from other units.
I also do recall having one or two faulty reed relays. Again I used donor relays from other 8600A units.
 

Offline elecdonia

  • Contributor
  • Posts: 38
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #7 on: November 20, 2018, 10:05:59 pm »
Quote
This is doubly interesting because the PCB actually has traces and markings for both types of unit: line-powered and battery.  The difference is in the transformer part number and whether some of the components are populated or not.  It looks like I'll be able to put a filter cap and a regulator right on the board, maybe route the 5VDC to the inverter board without too much effort.  The main difference is that the regulator will have to source a little more current because it's powering the inverter board as well as the logic.

Yes, same main PC board for both line and battery powered 8600A. The power transformer IS different for each.

Also:

Line powered unit generates its +5, +12, and -12 rails with rectifier diodes and filter capacitors followed by linear regulators.

Battery unit gets its +5 from the "raw" output of 4x NiCd cells. No voltage regulation. The 4 NiCd cells must be present and working because they form the "filter" for the +5 rail. Then there is a tiny DC-DC converter on the power supply daughter board which converts from +5 to both +12 and -12. I never had any issues with the power daughter board. The large polyester capacitor on the power daughter board is in series with AC mains input to power transformer. It limits current so that the batteries don't overcharge severely.

When replacing batteries I always use actual NiCd cells, not NiMH. The 8600A battery charging circuit is crude. It has no control logic. NiMH cells don't handle overcharging very well. But traditional NiCd tolerate it pretty well. That said, I don't keep my battery 8600A units connected to AC mains all the time because the battery is always charging, whether AC pushbutton on front of 8600A is on or off. I've thought about designing a charging control circuit for the battery 8600A but I haven't had time to do that yet.
 

Offline bd139

  • Super Contributor
  • ***
  • Posts: 13659
  • Country: gb
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #8 on: November 20, 2018, 10:30:25 pm »
I reckon a big zener diode with a small resistor in series is a good enough model to replace a stack of NiCd's as far as the source and load are considered.
 

Offline med6753

  • Super Contributor
  • ***
  • Posts: 5401
  • Country: us
  • Tek nut
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #9 on: November 21, 2018, 01:21:53 am »
Yes, and that's absolutely next on the list.  My latest tests indicate that the problem seems to be the reed relays; the ones which route the signal for ACV and Ω do not sound like they're activating on ranges above the "2" scale and that seems to line up with the ranging errors.  I was hoping it would be something else, but everything points to bad relays.  I need to do a few checks to find the best way to measure the coil voltage and contact status inside the box, and if that turns out to be it I won't need to compare meters just yet.  I know I could just shotgun replace them, but I'm trying to understand the circuit a little better while doing this - which slows the process down.    :P

I remember your issues with the 8800A and whether or not this is the entire problem I'll bet it's still causing errors.  Did you come up with replacement part #s for all the Fluke relays?  I have listed the HE3300 series you bought for the 600Ω and 125Ω replacements, but I seem to recall there was another reed relay for which a replacement hasn't been identified yet?

Edit: Both the Fluke/Coto 40069 and 40070 have 600Ω coils - not sure what the difference is?  And the U6P is the 150Ω (nominal 125?) coil.

OK, on the 8600A I replaced K2, K3, and K4 on the Input Divider board. I did not replace K5 on the Ohms board (which is same P/N as K2 and K3) and I did not replace K6, K7, and K8 on the AC Converter board and are an "E8182" P/N which are different and I did not investigate.

On the 8800A I replaced K1, K2, K3, K4 on the Ohms Board. They are same P/N as K2, K3 on the 8600A. I did not replace K6, K7, and K8 on the AC Converter board which as the same P/N as K6, K7, and K8 on the 8600A.

So I don't know what those AC Converter reed relays are. But a quick check of their coil resistance will put you in the pall park for finding a suitable replacement.
An old gray beard with an attitude.
 

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #10 on: November 21, 2018, 04:28:09 am »
As far as I can tell, the only real difference between the 40070 and 40069 relays is their contact ratings; the 40069 is rated 100VDC while the 40070 is rated 200VDC. 

Incidentally the analog supply voltage is ±15VDC not ±12. 

I don't think any problems would have been caused by operating the unit without the plug-in cards in this case; the unit does not appear to have been opened since it was last calibrated in 1974.
 

Offline hendorog

  • Super Contributor
  • ***
  • Posts: 1485
  • Country: nz
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #11 on: November 21, 2018, 06:49:29 am »
I recommend replacing the big yellow cap.

The one in mine went bang, spread crap everywhere and burnt long enough to deform the outer case.
 

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #12 on: November 22, 2018, 04:57:14 am »
Well, it looks like my string of luck fixing DMMs without encountering unobtainium has come to an end here.  I started swapping plug-in boards between my working 8600A and the new one; the boards worked fine in the new meter.  Which meant... the range ROM had to be tested.  Figuring I was less likely to screw up the good ROM, I swapped the ROM from the bad meter into my good meter and... it exhibited the weird symptoms that the bad one did.  Put the good ROM back and it was fine.

I know the AC, Ω board, range divider and ADC are fine, so there we are.   |O  Time to start looking for a parts unit, I guess - unless someone has a 7488A spare or is willing to program one (interestingly, the ROM contents are published on the net, but I'll bet the part is near impossible to find).  Oh well, 90% of a good meter for $10, I guess I can't complain too much.
 

Offline med6753

  • Super Contributor
  • ***
  • Posts: 5401
  • Country: us
  • Tek nut
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #13 on: November 22, 2018, 12:22:20 pm »
Long shot possibility: maybe just the data is corrupt but the ROM is still good? If the contents are available try re-writing it and see what happens?  :-//
An old gray beard with an attitude.
 

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #14 on: November 22, 2018, 05:22:58 pm »
Pretty sure a 7488A is a mask-programmed ROM, not an EPROM; it can't be erased or modified programmatically.   :(  I suppose if I could make up an adapter for a modern chip, I could replace it - assuming the chip was capable of driving the relays (40 mA for the 125Ω coils).

Edit: here's the post which triggered this memory.  I'm not sure a standard 2764 will sink enough current to activate the relays, but the poster seems confident it will work...

https://www.eevblog.com/forum/testgear/fluke-8600-a
« Last Edit: November 22, 2018, 06:47:13 pm by GregDunn »
 

Offline SeanB

  • Super Contributor
  • ***
  • Posts: 15348
  • Country: za
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #15 on: November 22, 2018, 08:05:18 pm »
Easiest power supply fix is a 4V7 zener diode to the base of a 2n3773, and the other end of the zener to the collector. connect collector and emitter of the 2N3773 in place of the battery and it will give a nice reasonably stable 5V3 rail for the meter, and will run just warm.

Did the same for a TI calculator, using a 3V3 1W zener diode and some copper plate as a heatsink for it to replace the very, very, very dead and powdery NiCd battery pack, and used an old 3V wall wart to provide the power.
 
The following users thanked this post: jmgallag

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #16 on: November 22, 2018, 08:12:10 pm »
If the battery is removed, it'll need a fair-sized filter cap too, right?  Once I get the ROM sorted, I'll seriously consider that fix - the standard supply runs about 5.1VDC on the ones I've looked at, so close enough.
 

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #17 on: November 25, 2018, 08:48:56 am »
Well, it appears that no one has actually built/tested an adapter using a UVEPROM or EEPROM to replace the 7488.  I've investigated a game console ROM source in the meanwhile, but if they can't help me it will still come down to building a ROM simulator board.

In order to match the device characteristics as closely as possible, I'm thinking about using a relatively cheap, common PROM and then buffering the outputs with an open collector driver like a 7407 to get sufficient current capability to drive the relays (7488 seems to be rated at 12mA).  The original 7488 is a very high speed device, but since this is only controlling reed relays and the switching speed is very slow by computer standards (tenths of a second at best) I doubt any ROM device would have a problem providing a stable output in time for the ADC to begin its conversion.  Some form of cheap MOS device I expect, which is compatible with a modern ROM burner.

Now to find the ROM programmer which will do well enough to get the job done and not break the bank - I'm going to spend a fair bit more than the meter cost as it is...
 

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #18 on: December 03, 2018, 10:39:30 pm »
It wasn't my original intent to start a collection, but sometimes you just can't help yourself...

I set the broken 8600A aside for a bit while working on some other equipment, and while looking for parts I stumbled across another broken 8600A for just $10.  From the description it sounded like a bad power supply, so at worst I'd have another unit for parts and at best, maybe another working unit if it wasn't terminal.  So it arrived today, and was pretty much as described and not missing any internals.  For some unknown reason, a previous owner chopped a piece out of a different unit's front panel and pasted it over this one.  So it would have a serial number?  Very odd.

Unfortunately, when I opened it up it was another option 01 - battery powered unit.   :wtf:  I'm learning to hate these.  A quick look at the board indicated that the batteries hadn't exactly leaked, but the fumes from them had done some damage to the PCB anyway.  Lots of corroded solder joints (fortunately none in the important circuitry) and one power trace completely destroyed (you can see it lying on the bench just to the right of the board).  It also caused damage to one of the AC Converter board's alignment pin guides, which is now hopefully fixed.

I'm not convinced that this one is worth resurrecting; I'm going to power it up and if the display, switches, etc. look OK it may give life to another meter or two. I can't really complain about what I got for the money - other than the hacked up front panel and missing cap on one side of the handle it's not in terrible shape externally.  It just sucks that the inside is so cruddy.  Not sure what I can do about it other than scrub with IPA and replace the missing trace.  I have no idea what that blue gunk is; it doesn't seem to be normal battery leakage and didn't yield to cleaning solvents.
 

Offline bd139

  • Super Contributor
  • ***
  • Posts: 13659
  • Country: gb
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #19 on: December 03, 2018, 10:42:07 pm »
Blue gunk looks like copper oxide. I think that one is a write off :(
 

Offline elecdonia

  • Contributor
  • Posts: 38
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #20 on: December 03, 2018, 11:14:33 pm »
This idea came to me:
Many USB charging units are rated at 5V and 2A
Typically their output voltage is well regulated.
This is enough power for an 8600A

So:
Remove old NiCd cells
Remove old power transformer
Remove old AC mains input receptacle
Attach female USB connector so it can be accessed through the hole formerly used by AC receptacle
Connect GND and +5 from USB connector to internal 5V rail
Recommended: install a large electrolytic capacitor 10,000uF @ 10V across internal 5V rail. The capacitor will provide the low-impedance filtering previously supplied by the NiCd cells

-EB
 

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #21 on: December 04, 2018, 12:05:43 am »
@elecdonia: User xrunner actually did that - only he packaged the USB power supply inside the 8600A and used the existing IEC receptacle for mains power.  Seemed to work OK.  I haven't decided exactly how I'm going to rebuild it, but there are several decent options.

@bd139 - because I'm a completist, I wanted to confirm that before I abandoned it.  A quick check before pulling the batteries confirmed low voltage and there was a buzzing, probably from the DC supply trying to operate on extreme low source voltage.   So I cleaned the board as well as I could with IPA and a toothbrush (it didn't get rid of all the blue, but it looks a lot better after some concerted scrubbing), made sure there were no shorts or other problems with the power path, and hooked up my trusty HP6236B power supply to the former battery pins.  +5 and ±15 looked fine and the display came alive, so I started measuring stuff.  My HP6920B calibrator isn't a voltnut approved unit, but it's within a percent on every mode where I've tested it and very handy for sanity checks.

Would you believe it?  I tested DC and ACV up to 100V, and it looked great.  Switched to Ω and it was spot on up to 100K which is the biggest precision resistor I have; shorting the rather long leads gave a few tenths of an Ω as expected.  Autoranging behaved nicely on all measurements.  So I gritted my teeth and (making sure the fuse was a 2A fb as specified) started feeding current into it.  Current is manual range only, which I remembered after a moment.  I only went up to 100mA, but AC and DCA, again, matched my calibrator's settings all the way.  I'm going to connect one of my DC standards later to keep an eye on drift, but for now I'm pretty pleased.  I will clean the switches first, because I've never seen a DMM where that wasn't a problem.

I find this quite amusing; I expected it to be a basket case if it powered up at all.  I guess maybe I'll give this one an extra thorough clean (anyone have suggestions for getting rid of that blue crud?) and start building a DC supply inside the box.  It may have earned a spot on the shelf after all.   :-DMM
 

Offline bd139

  • Super Contributor
  • ***
  • Posts: 13659
  • Country: gb
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #22 on: December 04, 2018, 07:48:36 am »
That’s a bit of a miracle that one.

To get rid of the blue, much like battery contacts, I’d use a fibreglass pencil. If it works that well then you can probably save it.

Also, just bought an HP6236B here :-+
 

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #23 on: December 04, 2018, 05:59:27 pm »
That's such a nice little power supply; we had a number of them on our benches at work for powering breadboards, but they were so popular we never seemed to have enough.

I'll try the fiberglass brush - the crud will come off the traces with a little effort, but having something which doesn't scratch the board will be nice.
 

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #24 on: December 05, 2018, 10:07:07 pm »
OK, this is weird.  I disconnected the power transformer secondaries so I could see how much voltage it delivered (one plan is to just replace the battery portion of the circuit with a regulator, and I hoped that by using the "red" primary tap instead of the "brown" I might get the secondary voltage low enough that a standard 7805-type might be usable). 

Initially, I pulled the red wire from the board so that power would be applied through the brown/black primary winding only, and removed the ferrite bead so that no power would be passed along to the meter itself, in case something went awry.  This way I was only checking the transformer.  When I applied mains voltage through a variac, I immediately got secondary voltage with S13 (that's the front panel switch) off.  Turning S13 on, the voltage went to 0.   I  unplugged the power cord and disconnected the transformer primaries from the board so I could map the incoming power locations to be sure I was getting AC mains in on the right pins.  What I found is that the schematic doesn't match the board, if you assume the convention that the contacts represent the switch in one position; S13F is actually closed when S13 A/B are open, and vice versa. 

I originally thought that perhaps the wiring was swapped around.  However, the board is labeled "red", brown", and "black" on the solder mask, and the colored wires were originally soldered to them as labeled.  S13 is soldered directly to the board and the wires routed to the power supply section look like original factory solder joints - though I suppose someone could have swapped them.  I can't figure out why they would have wanted S13F wired backward - with the red winding connected as it is shown, this would put a higher voltage on the batteries (brown winding) when power to the meter internals is disconnected, and turning it "on" (red winding) would drop the secondary voltage just when the meter is demanding an additional 500mA of current.  Of course, I had pulled the red winding so instead there was no voltage at all on the secondary in this position during my test.  The rectifiers CR201/204 were open when I initially inspected the unit, so I wonder if someone didn't try an ill-conceived bodge and damage the PSU.  I guess I should be glad the digital/analog circuitry wasn't fried.

I haven't checked my other 8600A opt 01 to see if it's (mis)wired similarly. 
 

Offline Hexley

  • Contributor
  • Posts: 28
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #25 on: December 06, 2018, 05:55:35 pm »
Well, it appears that no one has actually built/tested an adapter using a UVEPROM or EEPROM to replace the 7488. 

I just saw this thread and though you might be interested in my 16F628A-based PIC-to-PROM adapter which fixed an 8600A with a dead 7488 for me a few years back.

The 7488 is removed, and a ribbon cable jumper is run to a separate socket with the PIC in it. Kind of a kludge, but it works. I have attached the assembly code for the PIC, and a diagram of the interconnection.

Good luck.
Hexley

[Edit: removed the incorrect pinout file. See below for the corrected version.]
« Last Edit: December 07, 2018, 01:37:46 am by Hexley »
 
The following users thanked this post: GregDunn

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #26 on: December 06, 2018, 06:39:49 pm »
EXACTLY what I was looking for, thanks!  That meter got pushed down in the queue because of a new arrival which essentially worked out of the box - but it will be back on the work table soon...
 

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #27 on: December 06, 2018, 09:49:16 pm »
OK, so I took a few minutes to look over the PDF file.  I see the adapter on the left, and the pinouts for the PIC and PROM at the top - but what is the diagram in the center?  It only has 4 wires connected, and they are not connected to the same pins as on the adapter.  If it's supposed to show wire routing for the pins which don't line up between the two packages, then there seems to be an error.
 

Offline Hexley

  • Contributor
  • Posts: 28
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #28 on: December 07, 2018, 01:36:21 am »
Good catch, Greg. The list on the left has RA1 and RA5 swapped. The diagram in the middle is actually correct, as you can confirm by checking the pin assignments in the assembly code. I've attached a corrected version.

Some further notes:

The diagram in the middle is supposed to show how closely the 18-pin PIC could be shoe-horned into the 16-pin footprint of the 7488.

Some of the PIC pins line up directly with the corresponding pins of the 7488. That would be true of RA2-DO1, RA3-DO2, and so on. But four of the pins do not line up, as you noted. Those pins need jumpers. So, for example, pin DO4 of the 7488 needs to connect to a pin on the far side of the PIC, RA1. And DO5 connects down to RB2 towards the bottom of the PIC. And so on, for GND and for VDD.

The two bottom-most pins of the PIC are unused and left dangling.

My original plan was to mount the PIC on top of a 16-pin DIP header, connecting the pins from the PIC to the header either directly or via jumpers as shown. IIRC, there was not room in the 8600A to fit such an assembly. So I ended up using a 16-pin flat cable between a header plugged into the 7488 socket and a remote socket for the PIC, which was stashed around the forward edge of the power supply where there was plenty of room.

Hope this clarifies things a bit.
 
The following users thanked this post: GregDunn

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #29 on: December 07, 2018, 02:37:52 am »
Oh, good - I was afraid I was missing something obvious.   ;D

I had already come up with an idea of connecting the thing via a ribbon cable, because it is very tight in there between the AC converter and the input divider...  I'm sure I would have spotted which one was swapped when I actually started to make up the board! 
 

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #30 on: December 19, 2018, 05:31:06 am »
Moving back to this meter - I thought I'd install a line supply on the one which is working, get it out of the queue, and then use it to check out the one with the wonky range behavior, so I know which parts are good and which aren't.  I'd be happy at this point to have 3 working 8600A units while I am doing some other work.

I tested the built-in transformer which is part of the battery-operated unit and no matter which taps I used, I can't get it to provide a rectified, filtered output of less than 20VDC.  That's way too much for any regulator I want to use, and depending on the digital circuitry pulling the supply down to a reasonable value when loaded is not, to me, a good engineering solution.  I figured that if I'm going to replace the transformer, I'll just make my own supply instead of faffing around with the weird Fluke topology.  So I fished around and found a 12VCT transformer exactly the same size as the existing one.  Set up with a standard FWCT secondary filter, it provides a solid 10VDC which is perfect for a standard 7805/LM317 regulator.  I've tested it and it works, so the tough part was installing the transformer. 

As luck would have it, the one I found has standard mounting ears but also a set of flanges which hold the outer frame onto the device.  I bent the ears under so they'd keep the frame snug, and bent the little flanges down.  They almost perfectly matched the ones which the Fluke-supplied transformer had, that allowed it to be soldered to the board and grounded to the mains neutral.  (I'll show the process when I do the second 8600A; it happened so quickly I forgot to take pictures of the first one)  If you look, you can just see the pins disappearing into the original board mounting holes at the corners of the transformer.  So that was a fortuitous discovery and will allow me to fit everything in with no cutting or shaping.  I'm going to put the small filter/regulator board where the secondary parts would go in a standard 8600A and just hook the output into the 5V rail where it would normally connect through the ferrite bead and front panel switch - so it'll work just like the original except no batteries to mess with.
 

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #31 on: December 20, 2018, 07:07:32 am »
New power supply works great!  Mains neutral is grounded to the transformer as on normal line-powered units, and a stable 5.01VDC is supplied to the existing power supply converter board.  It's drawing just under 0.08A at the transformer primary, which is about 9W - well within spec.

The K1 relay has some issues with oxidation on either the contacts or connector pins (readings were a little jittery until I re-seated it), so before I close up the unit I'm going to take it out and do some gentle cleaning of all contact surfaces.  Then a double-check of the calibration against my reference 8800A.  This one is about ready to join its siblings on the test bench.

Edit - fixed typo.
« Last Edit: December 21, 2018, 12:20:52 am by GregDunn »
 

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #32 on: December 21, 2018, 12:20:20 am »
OK, this may be the last post on this particular repair (and there was much rejoicing!) but I had to make note of one particular item of interest.

On another forum I saw some comments about replacing the 5V power supply of a battery-operated 8600A with a linear regulated supply, and there seemed to be a lot of bashing of the whole "replace it with a 7805 regulator" concept, particularly (speculative) increased temperature vs. the original battery-regulated supply with its series line capacitor and zener/SCR regulated secondary.  I wasn't concerned about pushing the current capability of the 7805, because when running the meter from my HP bench supply, it only drew about 450mA; the only thing which might be an issue was the power dissipation.  So the last thing I did before buttoning this one up was to measure the regulator temp vs. an original 8600A's 5V regulator.  Theoretically, mine ought to run warmer, because it's supplying current to the digital section as well as the ±15V converter, right?  I gave each meter an hour or so to warm up, so that it would be a fair comparison.

Max temp of the line-powered 8600A was about 137F on the regulator chip (using a peak-hold IR thermometer).  The modified unit peaked somewhere around 130F.  The transformer and rectifiers were not even warm to the touch.  So, my modified unit actually runs cooler than the original line-powered unit.  Evidently this won't be a concern.
 

Offline GregDunn

  • Frequent Contributor
  • **
  • Posts: 728
  • Country: us
Re: Fluke 8600A battery powered multimeter - convert to line only
« Reply #33 on: December 21, 2018, 06:17:45 pm »
OK, I lied - there were a couple of things I needed to follow up with.

@bd139: the fiberglass pencil was a great idea - it takes a lot of the junk off without damaging the traces or board surface.  I'll never be without one now!

Also, yes - the second 8600A that I bought as parts/broken also has the mains power connections miswired compared to the schematic.  Red and Black (so marked on the board) are the correct traces to use for powering a regular single-primary power transformer.  This is odd, but the fact that two meters from widely different sources have the same issue leads me to believe it's a widespread problem.  It still seems wrong, though, because the schematic is drawn the way I'd expect it to be, and the meter isn't.  Oh well, it'll be fixed when I add the new supply.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf