Author Topic: fluke dsp-2000 and 4x00  (Read 2091 times)

0 Members and 1 Guest are viewing this topic.

Offline dinix

  • Contributor
  • Posts: 14
  • Country: pt
fluke dsp-2000 and 4x00
« on: May 10, 2017, 11:39:45 am »
Hi, this is my fist post  :D

Could some one point me some service manual from the FLUKE DSP-2000 and DSP-4x00.
Alter browsing the internet for may hours found nothing.
I've some units from ebay and they have the fowling issues:

DSP-2000:
Internal fault 232

DSP-2000:
Overvoltage error

DSP-4300:
dead

DSP-4100 smart remote:
error led

Best regards,
Dinis
 

Online PA0PBZ

  • Super Contributor
  • ***
  • Posts: 4260
  • Country: nl
Re: fluke dsp-2000 and 4x00
« Reply #1 on: May 10, 2017, 11:56:22 am »
Keyboard error: Press F1 to continue.
 

Offline dinix

  • Contributor
  • Posts: 14
  • Country: pt
Re: fluke dsp-2000 and 4x00
« Reply #2 on: May 10, 2017, 02:20:18 pm »
 

Offline dinix

  • Contributor
  • Posts: 14
  • Country: pt
Re: fluke dsp-2000 and 4x00
« Reply #3 on: May 17, 2017, 04:28:03 pm »
Hi, this is my fist post  :D

Could some one point me some service manual from the FLUKE DSP-2000 and DSP-4x00.
Alter browsing the internet for may hours found nothing.
I've some units from ebay and they have the fowling issues:

DSP-2000:
Internal fault 232

DSP-2000:
Overvoltage error

DSP-4300:
dead

DSP-4100 smart remote:
error led

Best regards,
Dinis

Any help on this please !
 

Offline dinix

  • Contributor
  • Posts: 14
  • Country: pt
Re: fluke dsp-2000 and 4x00
« Reply #4 on: May 30, 2017, 03:12:22 pm »
Any help on this please !
 

Offline dinix

  • Contributor
  • Posts: 14
  • Country: pt
Re: fluke dsp-2000 and 4x00
« Reply #5 on: September 27, 2017, 11:33:48 am »
Any help on this please !
 

Offline dinix

  • Contributor
  • Posts: 14
  • Country: pt
Re: fluke dsp-2000 and 4x00
« Reply #6 on: November 09, 2017, 08:06:08 pm »
up
 

Offline Zucca

  • Supporter
  • ****
  • Posts: 2479
  • Country: it
  • EE meid in Itali
Re: fluke dsp-2000 and 4x00
« Reply #7 on: November 10, 2017, 09:27:10 am »
After 3 times "Any help on this please !" and now "up", it´s may be time to change strategy.

Plan A: Use your brain, it´s a wonderful machine.
Plan B: Don't give up with Plan A.
Plan C: Don't give up with Plan B.

.....

Plan X: Open the device, do some measurements, post here pictures and results. The more you post the better it is. Do you have a scope and a DMM?
Plan Y: Contact Fluke for the service manual or information regarding those errors.
Plan Z: Buy a working unit, fixing the broken one by taking the good one as reference. After fixing the sutff sell the one you don't like as working device.

« Last Edit: November 10, 2017, 09:44:05 am by zucca »
Can't know what you don't love. St. Augustine
Can't love what you don't know. Zucca
 

Offline pete1zed

  • Contributor
  • Posts: 5
  • Country: nz
Re: fluke dsp-2000 and 4x00
« Reply #8 on: December 11, 2019, 07:50:51 am »
Hi,

I also have a DSP-2000 with the 232 error.  Did anyone make any progress on this?

I have a few units, so will do some part swapping, but any pointers in the right direction would make it easier for me to get back to this post with better information for anyone else with this problem...
 

Offline dinix

  • Contributor
  • Posts: 14
  • Country: pt
Re: fluke dsp-2000 and 4x00
« Reply #9 on: December 11, 2019, 10:05:16 am »
pete1zed: i found this issue is related to a small hover board mounted near the monitor rj45 port.

one of my dsp2000 had that issue and was only a bad contact on the connection of the board. i disconnected, cleaned and connected and got fixed.
when that board is disconnected if you turn it on the error appears also.

Right now i'm trying to figure out other issues in my other units:
-the error: "overvoltage on input, disconnect cable" even with cables disconnected.
-No power up, waiting for an internal battery to try if it resolves.
-Some dsp4x00 units not booting, only shows the screen flashing, waiting to replace the internal battery also
 

Offline pete1zed

  • Contributor
  • Posts: 5
  • Country: nz
Re: fluke dsp-2000 and 4x00
« Reply #10 on: December 14, 2019, 03:55:17 am »
Wow, just like you said:   I bent the connector housing on the floating board back to being straight, and the error went away.
Thanks so much.

I also ordered a USD$30 LCD screen from Aliexpress to replace the one it has, which was suffering from a few dead rows.

Total spend so far for a perfectly working DSP-2000 = $0.99 for the "not working" DSP-2000 on Ebay, + shipping, +  $30 LCD screen

I upgraded the firmware to the latest version too.

With the cover removed, if you turn the rotary switch to a position only available with the cover removed, it becomes a Smart Remote.
The Smart Remote status is displayed on the LCD instead of Smart remote LEDs. 

I have replaced some of the CR2450 batteries, but just soldering onto cheap $6 Energizer batteries from the hardware store means they heat up a lot during the process -- that may make them leak over time perhaps.  I am going to experiment with soldering using a low temperature solder (Chipqick SMD1 kit from element14 melting point 85 deg C but is actually an SMD removal product, so failing that: Chipqick SMDIN100 which an actual solder, Indium with melting point 143C). That is more economical than buying lots of tabbed coin cells.

If you need any spare parts or help let me know.  I have posted all I know here.
https://drive.google.com/open?id=1yVDiAwMg3zo4jIwa44o64lHkammTZvIU

I would really love a copy of the service manual if any has one...


 

Offline dinix

  • Contributor
  • Posts: 14
  • Country: pt
Re: fluke dsp-2000 and 4x00
« Reply #11 on: December 14, 2019, 05:04:59 pm »
pete1zed: thank you, very good and organized data.
I'll see if a can find something to add.

The service manual seems to be unobtainium, maybe someone can help were
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf