Author Topic: HAMEG HM 504  (Read 2731 times)

0 Members and 1 Guest are viewing this topic.

Offline lionelkjh

  • Regular Contributor
  • *
  • Posts: 161
  • Country: fr
HAMEG HM 504
« on: December 22, 2016, 11:42:13 am »
Hello; I am looking for the complete diagram of my oscilloscope HAMEG HM 504 (broken down, can someone help me ?? (I found some diagrams but it is missing) .... Thank you for your kindness ... . :-+
 

Offline Gyro

  • Super Contributor
  • ***
  • Posts: 4561
  • Country: gb
Re: HAMEG HM 504
« Reply #1 on: December 22, 2016, 11:52:07 am »
Hi,
You'll have much better success if you ask the Mods to move your post to either the 'Repair' or Test Equipment' sections rather than 'Metrology'.
Chris

"Victor Meldrew, the Crimson Avenger!"
 

Offline Falkra

  • Regular Contributor
  • *
  • Posts: 174
  • Country: fr
Re: HAMEG HM 504
« Reply #2 on: December 22, 2016, 03:54:38 pm »
 

Offline lionelkjh

  • Regular Contributor
  • *
  • Posts: 161
  • Country: fr
Re: HAMEG HM 504
« Reply #3 on: December 22, 2016, 04:34:16 pm »
Good evening, thank you for having answered. The 2 download links go to the user manual, and the last one only leads to a part of the diagram of the oscilloscope. This is a pity, because it is this part that I miss to repair my oscilloscope ..... Cdt
 

Offline Falkra

  • Regular Contributor
  • *
  • Posts: 174
  • Country: fr
Re: HAMEG HM 504
« Reply #4 on: December 22, 2016, 07:00:16 pm »
Hmmm, maybe here then (I chekced the link, it gives schematics, but quality is between poor and ok) :
http://www.eserviceinfo.com/downloadsm/44348/Hameg_HM-504.html
 

Offline Fisher77

  • Regular Contributor
  • *
  • Posts: 138
  • Country: us
Re: HAMEG HM 504
« Reply #5 on: December 22, 2016, 07:16:43 pm »
Hmmm, maybe here then (I chekced the link, it gives schematics, but quality is between poor and ok) :
http://www.eserviceinfo.com/downloadsm/44348/Hameg_HM-504.html


I was looking at that to. The power supply schematic is labeled 1004-2. Dont know if that is correct or not.

Links to pics on the above website:

https://i.imgsafe.org/c2842b82ac.png
https://i.imgsafe.org/c2846b3ed9.png
https://i.imgsafe.org/c284bbbb82.png
https://i.imgsafe.org/c284f454c4.png



« Last Edit: December 22, 2016, 09:54:10 pm by Fisher77 »
 

Offline lionelkjh

  • Regular Contributor
  • *
  • Posts: 161
  • Country: fr
Re: HAMEG HM 504
« Reply #6 on: December 24, 2016, 02:16:07 pm »
Hello; I was able to have all the diagrams of my oscilloscope with me from Hameg in Germany. Thank you for your help! :-+
 

Offline Falkra

  • Regular Contributor
  • *
  • Posts: 174
  • Country: fr
Re: HAMEG HM 504
« Reply #7 on: December 24, 2016, 04:38:18 pm »
Ok, great.

Feel free to post them so other membres can upload them (if legal, of course).
 

Offline lionelkjh

  • Regular Contributor
  • *
  • Posts: 161
  • Country: fr
Re: HAMEG HM 504
« Reply #8 on: December 27, 2016, 04:02:21 pm »
Good evening, thank you is nice. I encounter the following breakdown on this same oscilloscope: I have two tracks scarcely visible on the screen by fully rising the intensity button. I have checked the supply voltages: they are good. On the other hand the high voltage (measured with a probe) is raised to: -800V instead of: -2000V! . What is the possible cause of the failure ????? Thank you for your help! |O
 

Offline stj

  • Super Contributor
  • ***
  • Posts: 2156
  • Country: gb
Re: HAMEG HM 504
« Reply #9 on: December 27, 2016, 04:19:52 pm »
why ask us, your the one hording the schematics!  >:D
 

Offline oldway

  • Super Contributor
  • ***
  • Banned!
  • Posts: 2174
Re: HAMEG HM 504
« Reply #10 on: December 27, 2016, 08:58:50 pm »
If the 2 transistors of the high voltage oscillator are working very hot, the most likely fault is a defective high voltage transformer.
To troubleshoot this kind of problems, the ideal is to have another osciloscope of the same type as donor for spare parts.
The first thing I would do is to replace this HV transformer by another known as good working and look if this solve the problem.
 

Offline lionelkjh

  • Regular Contributor
  • *
  • Posts: 161
  • Country: fr
Re: HAMEG HM 504
« Reply #11 on: December 28, 2016, 11:40:40 am »
Hello; problem solved. The fault was the capacitor C1061 (33nF / 63V) which was leaking. After replacement, the traces are fine and sharp. Cdt ;)
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf