Author Topic: Hameg HM1507-3 repair  (Read 16362 times)

0 Members and 1 Guest are viewing this topic.

Online tautech

  • Super Contributor
  • ***
  • Posts: 17458
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Hameg HM1507-3 repair
« Reply #25 on: February 02, 2015, 08:39:37 pm »
Looks like you'll have to troubleshoot the CRT circuitry.
Get the first link in this thread: https://www.eevblog.com/forum/repair/repair-documents-and-links-sticky-me-please-mods/msg477909/#msg477909

Then hunt out a Service manual.
Avid Rabid Hobbyist
 

Offline Janw93

  • Newbie
  • Posts: 3
Re: Hameg HM1507-3 repair
« Reply #26 on: February 05, 2015, 03:33:51 pm »
yah, it's impossible to do anything without service manual... Does anyone have it?
Thanks
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 17458
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Hameg HM1507-3 repair
« Reply #27 on: February 05, 2015, 06:52:12 pm »
yah, it's impossible to do anything without service manual... Does anyone have it?
Thanks
Hameg was very helpful, they sent me the service manual by Email at no cost containing all the schematics.

A little word on the repairability of this device: I was not really amused. No silk-screen on the boards, lots of inter-board connections with cables soldered to the boards instead of connectors, heavy shieldings that are soldered to the boards and even worse, soldered to the chassis.

But all in all the repair was an exiting exercise!
paraboloid got one from Hameg.

Edit
PSU schematic in oldway's post on P1 of this thread.
https://www.eevblog.com/forum/repair/hameg-hm1507-3-repair/msg554014/#msg554014

First step in any repair is to check the PSU is to spec.
« Last Edit: February 18, 2015, 06:14:54 pm by tautech »
Avid Rabid Hobbyist
 

Offline gevans

  • Contributor
  • Posts: 5
  • Country: gb
  • I'm not German, I just live there
    • datebogi
Re: Hameg HM1507-3 repair
« Reply #28 on: February 18, 2015, 06:10:05 pm »
looking for this service manual is what brought me to this site in the first place. I eventually asked Hameg to send me a service manual, which they kindly did.

I ran it through OCR to make it searchable (horizontal text only tho) and rotated some circuit diagrams to make it more usable.

It can be downloaded here, it's about 8Mb. Copy and paste the link into your browser, clicking the link doesn't work properly.

https://www.datebogi.com/datasheets/HM 1507-3 searchable rotated G.Ev.pdf
« Last Edit: February 18, 2015, 06:22:16 pm by gevans »
 
The following users thanked this post: Armadillo

Online tautech

  • Super Contributor
  • ***
  • Posts: 17458
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Hameg HM1507-3 repair
« Reply #29 on: February 18, 2015, 06:19:01 pm »
Welcome to the forum.

Thank you for your link.
If you had the time you might also consider uploading it to one of the free manual sites.
The more places it can be found the better.  ;)
Avid Rabid Hobbyist
 

Offline e-doc

  • Contributor
  • Posts: 32
  • Country: de
Re: Hameg HM1507-3 repair
« Reply #30 on: March 28, 2016, 09:25:25 pm »
Can anybody please upload the service manual for HM 1507-3 again?
The link above is dead...
 

Offline psuwisit

  • Newbie
  • Posts: 2
  • Country: th
Re: Hameg HM1507-3 repair
« Reply #31 on: December 08, 2018, 10:31:21 pm »
I'm looking a link of HAMEG HM1507 service manual too, following.
 

Offline psuwisit

  • Newbie
  • Posts: 2
  • Country: th
Re: Hameg HM1507-3 repair
« Reply #32 on: December 21, 2018, 09:10:38 pm »
Special Thanks to Gevans for give me pdf file.
 

Offline Arm9MCU

  • Newbie
  • Posts: 1
  • Country: gb
Re: Hameg HM1507-3 repair
« Reply #33 on: December 22, 2018, 09:43:34 am »
Hello everyone
first excuse me for poor english.
i have a HM1507-3 Scope that has boot problem.
if i turn it on , it beeps 3 times and 6 times after that. if i hold it on for few minutes and then restart it , it boots without problem.
in cold conditions the problem is bigger and takes higher time to boot. after it become warm , it boots normally without problem.
can anyone help me?
does anyone have a repair or service manual?
thanks so much
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf