Author Topic: Help me understand this circuit to repair-PSU EC250-90  (Read 1495 times)

0 Members and 1 Guest are viewing this topic.

Offline tonyh88

  • Contributor
  • Posts: 25
  • Country: ca
Help me understand this circuit to repair-PSU EC250-90
« on: December 16, 2015, 03:44:29 am »
Hi,

I'm trying to repair the following PSU TEC 250-90 (see included schematic).

This PSU is supposed to output 250VDC maximum at 500mA. It is used in electrophoresis for chemistry stuff.

The problem  is that the output is constantly full ON even when the DC output button is turned off. i.e there is always 350VDC on the output.

So first thing I checked is if the IGBT (Q1) was shorted and it was. Now for the stuff I don't understand and some extra infos.

Couple of informations on the PSU:

- The transformer outputs the High Voltage which is then rectified to about 350V. The IGBT then regulate the voltage depending on the    gate drive signal.

-All the voltage rails were checked with the scope and they are ok no riplle or anything.

-All the digital stuff seems to work even the voltage detection and current are displayed correctly( full 250V max voltage with a varying mA depending on the load I put)

- If I replace the IGBT it shorts instantly ( no heating up or big current draw it just shorts itself between every pin after a fraction of seconds)

- I hooked up the scope on the gate and on powerup I see a rising voltage up to 15V that is clamped by the zener diode and then after that it goes back to zero. Unfortunately I don't have a high voltage probe for the scope so I can't probe the high voltage side of the IGBT to see if there is a massive spike or something.

Those IGBT aren't cheap ( 10$ a pop), I bought a couple but I can't try indefinitely if they keep shorting.

Couple of questions:

1) What is the purpose of Q3?
2) What is the purpose of Q2?
3)Why are they ac coupling the gate of the IGBT with the 1uF capacitor C15?
4) Any ideas why the IGBT keep shorting? Those IGBT are massive beast with 900V VCE breakdown voltage and 28A continuous current capability so way overkill for this design.


Thanks, this seems simple but i'm lost with this design.
 

Offline tonyh88

  • Contributor
  • Posts: 25
  • Country: ca
Re: Help me understand this circuit to repair-PSU EC250-90
« Reply #1 on: December 16, 2015, 03:52:13 am »
By the way I already replaced c18 for the IGBT snubber to see if it was not breaking under voltage
 

Offline TLengr

  • Contributor
  • Posts: 12
  • Country: us
Re: Help me understand this circuit to repair-PSU EC250-90
« Reply #2 on: December 23, 2015, 05:57:52 pm »
This is a challenging circuit but some of it looks familiar. The following is my interpretation of the circuit operation, some rhetorical questions and comments on troubleshooting.

Q2 is a triac (bilateral switch) that appears to have two functions when switched on. One, it sends a high current alarm to the processor, and two, it holds down the gate of Q1 to prevent it from switching on. Consider that initially Q2 is off. The MT1 terminal is at +28V via R32 which reverse biases D2 and D3. MT2 is fixed at ground potential. The OVERI line is pulled up to +5V via R18. Q2 gate is biased slightly positive by the +26V supply and the voltage divider made up of R31, R21, R20 and R23. The voltage across R23 depends upon the current through D5 and the Power + circuit. If this current becomes too high, increased voltage across R23 will raise the Q2 gate voltage enough to trigger Q2 on. When Q2 switches on, D2 and D3 are forward biased pulling the “OVERI” line low and holding Q1 gate near ground potential stopping Q1 from switching on. Once triggered, Q2 remains switched on until power is removed - even if the gate voltage drops below the trigger threshold.

I think the purpose of  C15 coupling capacitor is to prevent the +26V via R1 from raising the gate voltage of Q1 and turning it on continuously. I'm curious though. If I understand correctly, you observed Q1 gate voltage rise until it was clamped by the zener (D4) and then it fell off to ground potential. If the gate of Q1 is truly shorted to its collector and emitter how is this possible? I would suggest taking a second look at this. I am not familiar with an insulated gate bipolar transistor, but could the initial gate voltage exceed the gate to emitter breakdown rating? I think the zener should prevent this, but what if it does not? Is C15 shorted?

You stated, “All the digital stuff seems to work even the voltage detection and current are displayed correctly( full 250V max voltage with a varying mA depending on the load I put). “ Is this a typo? If rectified voltage is 350V doesn't 250V output imply that the regulator might be working? What turns on the dc output? Is there a relay or a mechanical switch with bridged contacts? Is there a delayed turn-on circuit for the dc output that isn't working?

If you have not already done so, I would recommend some testing with Q1 removed from the circuit and before powering up. I would check C15, D7, C19, and the output of “Power +”  for shorts or opens. I would then power up without Q1 installed and probe around with a voltmeter looking for abnormalities with terminal voltages. Something might stand out.

The purpose of Q3 is not clear to me, but I hope the other information is helpful and I wish you good luck in your repair project. |O
 

Offline tonyh88

  • Contributor
  • Posts: 25
  • Country: ca
Re: Help me understand this circuit to repair-PSU EC250-90
« Reply #3 on: March 10, 2016, 04:20:35 am »
Hi I just realized I never responded to this thread. I solved the problem shortly after my last post in this thread. Thanks TLengr for the nice explanation for the purpose of the triac.

If anyone is curious the problem was that the trace between the  microcontroller and pin 9 of the lm339 was broken. The trace was broken right under one of the IC so I didn't see it. Only by checking all the traces with my multimeter did I finally found something wrong there.

I'm not 100% sure why this broken trace caused the IGBT to blow but my guess is that the floating pin 9 caused something weird to happen on the output of the op amp (maybe a too low driving voltage for the gate?) and it blew the IGBT.

 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf