Author Topic: Help with large servo please  (Read 233 times)

0 Members and 1 Guest are viewing this topic.

Offline viorel

  • Contributor
  • Posts: 5
  • Country: au
Help with large servo please
« on: November 09, 2019, 05:46:16 am »
Hi everybody, thank you for having me.

I've come here in despair. Here's the problem. I have bought one of these:

https://i.ebayimg.com/images/g/~JMAAOSwPVFcObXr/s-l640.jpg

This is for a little simple project. Worked fine when arrived, now it just moves side to side without stopping as soon as I power it up, even if not connected to a receiver.

How did it happen I hear you ask.

Well, I had to make another casing and in the process I took off the motor wires and reconnected them the wrong way around. I corrected my mistake after I first tried it and that is when the problem appeared. When tested with the wires crossed, the motor moved slowly at first for half a turn (the output shaft, that is) and then stopped dead. Upon inspection I found the mistake.

Some description of the circuit (keep in mind I am at best a dilettante).

Here's a picture of the top side of the board:

https://www.hobbyporter.com/u_file/1812/photo/36c3a9090f.jpg

I had to bridge the VR pads in the bottom left for I am using a digital remote control.

The motor is just a run of the mill DC motor. It has some bidirectional diodes on the terminals to cut EMF spikes and is driven by a bridge with four N channel Hexfets (Infineon LR2705). These seem to test fine (in circuit; I don't really want to pull them out for fear of further trouble, but I did order a bunch of new ones from RS Components). Now the test is not that reliable, I could only test the Drain-Source resistance which seems suitably high and the S-D diode, which shows about .5V. Not sure if I can test anything else in circuit.

The position sensor in this servo seems to be some sort of magnetic sensor (doesn't use a VR). Now if I take the board out and away from the bottom of the output shaft, which has a magnet stuck to it, the motor just keeps going around.

The two adjusting controls/VRs (blue, bottom in the picture) still seem to do their job, in that they adjust the travel and response speed, and I know that because shortening the travel makes the servo move quicker because it gets quicker to the end of travel (again, keep in mind I have no receiver connected so there is no signal) and so does the response speed. Connecting it to a receiver doesn't make any difference.

The only difference is when I have the servo connected to a receiver and I apply a command for the other channel (I use a two channel radio and I have another "normal" servo connected to the other channel) and move it to its max travel and hold it there the big servo stops doing anything, which I take it is a sign the voltage drops (the other servo drains a lot of current).

Also, when I apply power the first time, it takes say one-two seconds before the defected servo starts doing its thing. Could be a capacitor charging?

All these tests are done with a good NiCD at 14.4V (the large servo has a 5V out for the receiver). At 7.2V, the servo doesn't move (needs at least 12V).

Ideas?
« Last Edit: November 09, 2019, 10:13:58 am by viorel »
 

Offline shakalnokturn

  • Frequent Contributor
  • **
  • Posts: 605
  • Country: fr
Re: Help with large servo please
« Reply #1 on: November 09, 2019, 10:43:47 am »
I'd be checking mechanical alignment between output shaft and position sensor, the sensor may have been moved past it's limit.
I don't see why just swapping motor polarity would damage the control PCB in this setup.
 
The following users thanked this post: Psi

Offline viorel

  • Contributor
  • Posts: 5
  • Country: au
Re: Help with large servo please
« Reply #2 on: November 09, 2019, 12:06:17 pm »
I have no idea either, those motors don't really have a + or minus but I thought maybe the controller imposed some such by its design and some component needs to be protected by connecting the wires to the motor this way. That said, the way control bridges work, the motor will definitely see negative potential on its plus and viceversa when travelling either way. Given it's just a simple brushed jobbie.

And you are right, the position of the output shaft must have changed when I took apart the servo, but I don't understand what the "aligned position" would be. The magnet on the back of the output shaft is one of those cheap disc magnets which points one of its poles out towards the sensor at all times, the other pole is, err, up the shaft I suppose? Not sure how it works, but I would guess the magnetic field around the magnet circumference is entirely symmetric? That would definitely make sense from a manufacturing point of view. I mean just imagine on the assembly line churning these things out by the thousands, who has time to align every single one of them?

And by the way, there is no mark on any of the gears, or the magnet itself to suggest some alignment.

Oh, by the way, if I remove the gears altogether the motor just spins.

But the question is, why does it spin with no PWM signal (i.e. when the receiver is not connected)? Is it maybe looking for its "home"/rest position? I will try a normal servo, power it up disconnected from the receiver (Rx) see what it does. In my few decades of R/C I never tried this, come to think of it. You may be right, logic would suggest that in absence of a signal it will just go to its rest position (if it were out).

Well, I'll give it a shot and report back.
 

Offline viorel

  • Contributor
  • Posts: 5
  • Country: au
Re: Help with large servo please
« Reply #3 on: November 09, 2019, 01:33:15 pm »
Well, if there wasn't anything toast before, now there is.

I managed to blow up one (at least) of the mosfets. The power wire negative came into contact with the motor terminals by accident whilst I was testing and let out the smoke in one of the fets. Funny thing is, the servo behaves the same. Which makes me think they are all toast in some inconspicuous way.

Back up a bit.

So I found the servo stops if I find the rest position. By the way, I found the way they probably did it at the factory. just remove one of the gears in the train and with power applied, slowly turn the output shaft/gear. The motor will come to a stop at the neutral position. Turn the shaft further and the motor starts spinning the other way until you bring the shaft in the neutral position by hand.

But. Once connected to the receiver, didn't take any notice of my commands.

I guess this points to a problem with the PWM control of the servo. It doesn't get the pulses from my command. I have checked the receiver even though I knew it was good, I have checked the wires, all good. I guess something is interrupting the chain further down.

One thing I know now is the Rx command doesn't get through.

I'll replace the blown fet or maybe all of them just to be sure. Meanwhile, I will start digging down the signal path see what's goin' on. Out with the scope.

But first I will have to identify the signal path. No real hope anyone might have a schematic for this servo?

I might come back here and ask about the ICs I find after I manage to read their names. They're bloody small things for these old eyes.

And one more thing. Someone was in there before me. They replaced the adjusting VRs for response speed and travel, it is obvious because the soldering is clearly hand made not machine.
 

Offline viorel

  • Contributor
  • Posts: 5
  • Country: au
Re: Help with large servo please
« Reply #4 on: November 10, 2019, 09:50:16 am »
Right.

So I have hopefully identified all the ICs in circuit. On the top (the part seen in the picture above we have

ST 7B495 8S003F3P6 which is the microcontroller

CX1117 5.0 8209T which is he 5V regulator

ST 78M12 CK1CV824 which is the 12V regulator

On the bottom we have

two IR 2104S 709P (fet drivers)

AS5600 (magnetic sensor)

LM358 (high gain dual opamp)

LM3930 (power regulator, not sure what voltage).

One question I have here. The 2104S drivers come as inverting and non inverting and it is not clear how to differentiate the two from labels. Which one do I need, I wonder?

Right now I suspect the fets and the drivers (the internets say the fets take out the drivers with them when they fail and corroborated with the fact that my servo doesn't care about the receiver signal/commands, I would say that's on the money).
 

Online beanflying

  • Super Contributor
  • ***
  • Posts: 3875
  • Country: au
  • Toys so very many Toys.
Re: Help with large servo please
« Reply #5 on: November 10, 2019, 10:50:15 am »
I have one of those or a cousin of yours. I decided to go with an actuator on the job I got it for so it is sitting in a box. My gut says the position sensor is at fault so look at the magnet and where it is compared to the sensor.

Maybe adjust your center and travel pots to a mid point and retest. Also double check your source signal is between 1-2mS/

Happy to pull mine out tomorrow and split the case and take some measurements if it helps.
Coffee, Food, R/C and electronics nerd in no particular order :)
 

Offline viorel

  • Contributor
  • Posts: 5
  • Country: au
Re: Help with large servo please
« Reply #6 on: November 10, 2019, 12:20:32 pm »
Oh, thank you. Hopefully this won't be necessary.

I need to deal with the mosfets first, though I imagine the signal path could be checked before the mosfets arrive.

I am however more and more inclined to believe it is the mosfets and their drivers. This would explain why the servo doesn't listen to the radio. Also, if you read one of my previous posts, I have found the zero position (rest) of the output shaft in relation to the magnetic sensor, so I would say that one works. If it doesn't work properly, we'll deal with it later.

I'll report back after I have the fets and drivers replaced, so it will be a few days. Not sure which drivers to order though so I might order both kinds (see previous post - inverting-non inverting). I'll do some more digging see what the heck that means, I have a suspicion it may mean they drive on the up/down slope of the pulse or something? We'll see. They're not that dear to break the bank.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf