Author Topic: Hitachi trk-w540 boombox repair (bodge repaired)  (Read 1928 times)

0 Members and 1 Guest are viewing this topic.

Offline poot36

  • Frequent Contributor
  • **
  • Posts: 434
  • Country: ca
Hitachi trk-w540 boombox repair (bodge repaired)
« on: October 22, 2015, 02:51:16 pm »
I have this boombox that the TA7784P dual tape head preamplifier has died on and as a result I have no sound in any of the input modes.  This part has a clamed gain of 95db and looking at the block diagram of it there are just 2 op-amps in there along with some switching and tape control logic.  The boombox only has one tape drive and uses the second input on this chip for the radio and aux input.  I do not care about the tape function and am just wondering if I can use a standard op-amp to fix this?  Here is the link to the service manual for the boombox: http://elektrotanya.com/hitachi_trk-w540.pdf/download.html and the one for the chip: http://pdf.datasheetcatalog.com/datasheet/toshiba/1821.pdf.  I tried jumpering around the chip but it was fairly quiet and somewhat distorted.
« Last Edit: October 26, 2015, 08:35:28 am by poot36 »
 

Online Performa01

  • Frequent Contributor
  • **
  • Posts: 790
  • Country: at
Re: Hitachi trk-w540 boombox repair
« Reply #1 on: October 22, 2015, 06:27:26 pm »
The 95dB is the open loop gain of the integrated amplifiers; the actual gain is determined by the feedback networks connected at pins 2, 4, 6 and 12, 14, 16 respectively.
You should be able to use any decent low noise audio opamp, like the NE5532. For the switches, HEF4066 and/or HEF4053 could be used. You would need to build a daughterboard where you build the appropriate circuit to substitute the TA7784.
 

Offline poot36

  • Frequent Contributor
  • **
  • Posts: 434
  • Country: ca
Re: Hitachi trk-w540 boombox repair
« Reply #2 on: October 23, 2015, 04:33:00 pm »
Thanks for the info.  I don't need the switches because I do not have the tape function any more (I salvaged just the amp board and the power supply board out of the boombox it was going to the ecycle anyways).  In my testing I vaguely remember that when I touched where the tape head input was on the amp board I think I got sound but I may be mis remembering things.  If the above statement is true then just the switching in the chip is bad and I can just redirect the signal into the unused tape inputs if not I have a few op-amps that I can try but I have no clue if they are audio quality or not.  I assume that the datasheet would tell me that or would I be looking for specific values to meet or exceed?
 

Online Performa01

  • Frequent Contributor
  • **
  • Posts: 790
  • Country: at
Re: Hitachi trk-w540 boombox repair
« Reply #3 on: October 23, 2015, 06:26:57 pm »
Be aware that a tape head amplifier doesn't have a linear frequency response, neither for recording nor playback. So the original feedback network is not usable for a line input. Unfortunately, I'm in a hurry right now and from a quick look at page 17 of the service manual it appears that the normal/metal switch of the TA7784 is 'abused' to switch from tape equalisation to normal (linear responding) feedback network for the line input.

If so, then the gain in the line operating mode would be ~180 with linear frequency response, set by resistors R408 and R409. On the other hand, the line input is attenuated by ~450 by the divider network R401/402. That would result in a attenuation of ~2.5. No OpAmp needed for that...

I would try the following:

1) Remove the input attenuators R401/402 (100k/220).
2) Remove resistors R410, R411.
3) Remove the TA7784P.
4) Build the attached circuit twice and connect it to the line inputs and the TA7784 pins as shown in the diagram.

Just two transistors will do a better job than any Dual-OpAmp. As an European, I would certainly use low noise BC550C transistors,  but actually any general purpose small signal silicon npn transistor will do just fine (such as the 2N2222 shown in the diagram).
Capacitor C1 should be a non-polarized foil type, such as mylar or even polypropylene, but as this is not an audiophile amplifier anyway, an electrolytic will do as well, the positive side has to be connected to the base of the transistor.
Both circuits are powered by pin 1 and pin 8 of the previous TA7784. One circuit has its input from line left and output to pin 2, the other one input from line right and output to pin 16. Line common is now connected to circuit common instead the bias point of the TA7784, hence pins 8 and 9 have to be bridged.

Just a general remark regarding audio grade OpAmps. I have recommended the NE5532 as I initially thought you wanted a playback amplifier, where an excellent opamp is essential for good performance. But now we only need a line buffer, and in this particular case no OpAmp is required at all.
 

Offline poot36

  • Frequent Contributor
  • **
  • Posts: 434
  • Country: ca
Re: Hitachi trk-w540 boombox repair
« Reply #4 on: October 26, 2015, 08:35:03 am »
Well I just replaced the TA7784 chip and jumpered the two switched pins together and now it works.  I assume that the switcher was dead or the control signal wasn't reaching the switcher inside the chip (I had power to the switcher pin on the chip).  Thanks for the schematic if the chip totally dies on me though.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf