Author Topic: Agilent 54622D Dead after Battery replacement  (Read 4312 times)

0 Members and 1 Guest are viewing this topic.

Offline D-Jan

  • Newbie
  • Posts: 2
  • Country: de
Agilent 54622D Dead after Battery replacement
« on: April 05, 2016, 07:18:43 am »
Hi There!
My beloved Agilent 54622D Mixed Signal Scope recently complained about Low Battery when switching on. Since all settings were defaulted when switching on (Labels, etc...) I gave it a try to replace the battery.
I checked the net and found some posts that the battery can be replaced by a new one even without backing the unit up during replacement.
It's a Panasonic CR2354 that is soldered to the system board. For replacing you have to take out the complete system board. Also removing the heavy heat sink / Shielding  of the two analog frontends (Service manual: Caution: USE AN EXTERNAL FAN TO AVOID OVERHEATING COMPONENTS !
If you operate the oscilloscope with the cabinet removed, you must use an
external fan to blow air across the system board. This external air flow is
necessary to cool the heat sinks on the system board. Otherwise, damage to
the components can occur.
) until you can desolder the battery from the bottom surface. There also was a crusty 3M sticker underneath as well. Yuk! The 3V battery was dead down to about 0.4V.
Surely, I did the work on a proper ESD safe workbench with writst strap and proper grounding. After replacing and reassembly I switch on the unit and the device now is just running the fan and lighting up all LEDs on the front panel. No further booting.  :-BROKE  :palm: I checked all cables and marked voltages on the system board. They are ok.  :-\

Is there somebody out there that experienced similar issue? How is the support from Agilent / Keysight for such a vintage equipment? Any idea how to bootstrap that puppy?

Best regards from Germany
Jan
 

Offline JFJ

  • Regular Contributor
  • *
  • Posts: 231
  • Country: gb
Re: Agilent 54622D Dead after Battery replacement
« Reply #1 on: April 05, 2016, 07:50:49 am »
Have you tried resetting the oscilloscope?

From the service guide:

"To reset the entire oscilloscope, press and hold any softkey and switch the
oscilloscope power on. Release the softkey when the display appears".
« Last Edit: April 05, 2016, 07:59:52 am by JFJ »
 

Offline D-Jan

  • Newbie
  • Posts: 2
  • Country: de
Re: Agilent 54622D Dead after Battery replacement
« Reply #2 on: April 05, 2016, 08:09:13 am »
Dear JFJ,

You really SAVED MY DAY !!!!

It's back up and running! Yesterday I tried to push the Run/Stop, Single Btns. So big and handy, but did not try any others. After pressing the softkey we're back in business.

Great! I love it!
Million Thanks to you!

Best regards
Jan
 

Offline chihaxinh

  • Regular Contributor
  • *
  • Posts: 125
  • Country: vn
Re: Agilent 54622D Dead after Battery replacement
« Reply #3 on: April 08, 2016, 01:20:43 am »
After replace battery ,do we need calibration OSC ? I have 1 546xx like you but can't running calibration , have error fail in high frequency.

And in mod frequency mearsurement have offset like .

Signal from sig gen 1k - OSC display 1.5khz
Signal from sig gen 100Hz - OSC Dispaly 150Hz
Signal from sig gen 1Mhz - OSC Dispaly 1.5Mhz

 |O
 

Offline Astralix

  • Contributor
  • Posts: 16
  • Country: de
Re: Agilent 54622D Dead after Battery replacement
« Reply #4 on: June 07, 2016, 08:19:34 pm »
Hey D-Jan,

I probably haven't got the message... Can I replace the battery without having the system powered all the time and without backing everything up?
Cause for me external fans blowing across the board while dismounted from the case make only sense to me if the board is powered while the battery is exchanged.

And a second question, Do you know the second way, backing up all data, to replace the battery without having the puppy powered up all time?

I found the 564xx user and service manuals, but while the service manual lists the battery type and order number, it does not tell a single word where it is to be found and how to proceed while replacing it... I had disassembled the unit one time to clean it up completely and I ran several tests and user calibration and it worked fine for me the last 10 years.

I am aware of a lot of expensive old equipment that needs its battery to store calibration data that is not recoverable by normal users. But I am not sure, if my 54622D has this.
However it has a user calibration, so it is likely that it also has a hidden factory calibration...

May be we can exchange some knowledge and / or service information, cause exactly this evening my scope send me this battery message? Would be nice!

Best regards
Astralix
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf