EEVblog Electronics Community Forum

Electronics => Repair => Topic started by: Jeff L on March 16, 2021, 07:27:39 pm

Title: HP 3455A fails self test
Post by: Jeff L on March 16, 2021, 07:27:39 pm
Hi, My previously working 3455A now fails the self test and displays 12 , 11 ,10 --right down to 0.
I've re-seated every board and connector to no avail. The 5 and 12 volt test points on the digital side measure OK,
and there is approx. 100mV. noise on both.
 On the analog side , the 30v, 24v, +and- 15v, 9v and 5v rails measure OK with  approx. 50mV noise.
The fact that it is failing every test except 13 must mean there's something  in common with them all, right?
 Please help .
Title: Re: HP 34555A fails self test
Post by: precaud on March 17, 2021, 01:16:59 am
You have an extra "5" in your thread title...
Title: Re: HP 3455A fails self test
Post by: Jeff L on March 17, 2021, 01:48:06 am
It was a bonus no charge "5", since removed.
Title: Re: HP 3455A fails self test
Post by: bob91343 on March 17, 2021, 06:32:10 am
Do you have the manual?

I have a 3455A but it doesn't work.  I need help fixing it.
Title: Re: HP 3455A fails self test
Post by: Jeff L on March 17, 2021, 08:14:35 am
bama.edebris.com/manuals/hp/3455a/
Title: Re: HP 3455A fails self test
Post by: Jeff L on March 18, 2021, 02:04:51 am
I would also try    hp  Agilent keysight-- equipment@groups.io.
They seem to know the score.
Title: Re: HP 3455A fails self test
Post by: coppercone2 on March 18, 2021, 02:32:13 am
Always try to clean those sockets out with deoxit.

One of the best things I did recently is stopped screwing around and got a DIP extractor so I can drip deoxit into the sockets without bending the chips. Sprayable alcohol helps to flush them also.

The cleaning got rid of intermittent crashes on my dynamic signal analyzer when I pulled and treated the memory and cables.

I am not sure how effective just reseating them is, but many people likely never clean them out.

Also, 50mV of noise seems huge on an analog rail. A bog standard LM317 is rated at 1mVpp and it usually does ALOT better. I don't know how this changes with load but it seems like maybe too much.  The datasheet formula claims 0.0003 percent of the voltage rail, so for 15V it should be 450uV rms. So maybe the capacitors are bad?
Title: Re: HP 3455A fails self test
Post by: Jeff L on March 20, 2021, 04:30:33 pm
I did use Deoxit on all the connectors. Are you familiar with the 3455A? The analog board is jam packed with all
types of chips--50mv is quite reasonable.
This instrument has a history of failures of comparators ,I was hoping someone might show me where to look.
Title: Re: HP 3455A fails self test
Post by: coppercone2 on March 21, 2021, 07:24:53 am
Just a hunch, I am not sure what normal is there. I am actually kind of surprised that its that noisy normally.

I don't know if I ever probed a DMM voltage rail, I figured it would be whisper quiet.. but I suppose it does make sense with a simple resistive load of 1.5A this low noise lab supply is already at 3mVrms. *

actually no, its the current limit, I need to find a better resistor, I got curious about the load noise profile on my power supplies since you mentioned it. It only gets noisy when it gets into current limiting.

ok so it looks like it wont happen with load alone, it has to be the chips, up to 1.5A, so long I stay in CV mode, the ripple is still less then 1mV, Not sure how well a 317 does in comparison, but if its EMI its EMI.

Does that one even use a 317? i guess its too big for it
Title: Re: HP 3455A fails self test
Post by: Jeff L on April 03, 2021, 10:01:28 pm
I have  found that the +/- 10 vdc supply is low (.8 volts) Where does it originate? I understand that it goes to a number of FETs and that one or some could be at fault. How or where do I look?
Title: Re: HP 3455A fails self test
Post by: coppercone2 on April 03, 2021, 11:48:34 pm
10 to 0.8 = thermal camera business

Alternatively if you can stomach it, use a thermocouple to probe them all while its running after a bit to find the hot one. If its pulling a rail down all the way chances are its a bit warm or blazing hot

does the regualtor have a shut down?
Title: Re: HP 3455A fails self test
Post by: Jeff L on April 04, 2021, 12:10:29 am
Where is the regulator?
Title: Re: HP 3455A fails self test
Post by: coppercone2 on April 04, 2021, 12:13:29 am
no clue but thats the general idea to see what the voltage before after the 12v regulator is and to measure the AC voltage before that, then hope its 1 thing not a whole bunch of failed things
Title: Re: HP 3455A fails self test
Post by: Jeff L on April 04, 2021, 12:46:33 am
Further looking found that the reference A to D / precision resistor module has + 29.3 volts and +15 volts going in
 and +10 volts( adjustable to 5 zeroes) coming out. The + 10 volts is then fed into the inverting input of an op amp,
giving -10volts.
Will do more investigating tomorrow.
Title: Re: HP 3455A fails self test
Post by: bob91343 on April 04, 2021, 03:28:52 am
I watch this thread in hopes it will give me an answer to fix my 3455A.
Title: Re: HP 3455A fails self test
Post by: Jeff L on April 04, 2021, 07:27:25 am
Have you got similar problems?
Title: Re: HP 3455A fails self test
Post by: bob91343 on April 04, 2021, 04:38:14 pm
I am not sure I remember.  When I got it, it worked except for 4 terminal Ohms.  Then the display would no long respond.  I should put it back on the bench and see what it does.  I have a 3456A so there is no urgency but it's a nice meter and I'd like it to work.
Title: Re: HP 3455A fails self test
Post by: Jeff L on April 08, 2021, 07:32:02 am
Latest problem I've noticed is voltage reference is only .800 VDC, should be 10volts.
I suspect it is the reference module which has a couple of HP proprietary chips on it.
Title: Re: HP 3455A fails self test
Post by: alm on April 08, 2021, 10:56:31 am
The reference is a separate module, which should help troubleshooting: you can probably run it outside the DMM powering it from some bench supplies. And it could still be something simple like a bad connection or bad jellybean component like a cap.
Title: Re: HP 3455A fails self test
Post by: Jeff L on April 11, 2021, 07:15:12 pm
Bench wired the reference module-- getting 10.00 volts --yeah!!
Will let it run for an hour or two.
Title: Re: HP 3455A fails self test
Post by: Jeff L on April 12, 2021, 08:45:42 pm
Put the module back in and , not surprisingly , nothing changed.
Changed U7 but same problem--+/- 10volts is approx. .8volts.
Have ordered q 31,32,33  (FET transistors) and will see how that goes..........
Title: Re: HP 3455A fails self test
Post by: Jeff L on April 16, 2021, 07:34:35 pm
New problem-- noticed  A10U18 was getting hot (not warm, hot) and so was A10Q35. Then a bunch of relays started
clicking, and then the fuse blew. A10Q35 is listed as a  1855-368  which Digikey doesn't recognize.
Is there a substitute?