Electronics > Repair

HP 3458A - Fails Slave Test - Convergence

(1/16) > >>

Hi team,

I have an HP5458A that has started to fail the bootup self test - Fails Slave Test - Convergence.
The manual suggests this relates to A1 PCB DC Input. Ive had a probe around and I've noticed that Q106 is on which is fine but the source voltage slowey drifts from zero to above 10volts over time. I did remove Q106 which stopped the voltage rise so it was replaced just in case it was leaking. However the fault is still there so before changing any other parts I did wonder if any one else could recommend where to look.

Any support and advice would be most welcome.
Many thanks,

Is that thing trowing an error 202?
The 'internet' suggests several things:
Jumper PCBA on board A1 is missing or configured wrongly. It must be placed in position 'normal' over pin 2 and 5.
If that is check then proceed with an autocal.

The jumper is in the correct position, autocal fails. probing TP11 on A1 you can see the voltage jumping most times to 10V, then 1v, cant read the 0.1 on the scope in the time given but still then after it fails the test. After doing this a few times I now have a further error ACAL DCV, OHMS R. I dont know if its a temperature issue or something is failing the more I test it. I still get when checking the error code

Hi , I really need some help please.

I started with Fails Slave Test - Convergence

I now have this plus ACAL DVC, OHMS R error.

Dr David Partridge on xxx@groups.io suggested i try a Autocal ACAL DCV which i tried but still i have the above errors.

Monitoring TP11 on A1 I can see a signal jumping from zero to around 7 volts, the screen also shows its sampling, then it beeps and stops , or some times it will sample , a relay will click and TP11 will jump to 10V before failing again.

Ive checked the Convergence circuit with my very limited understanding of the circuit. FETs are on and off , ive cycled functions to see if the FET will change state just to see if its working.

As the test sometimes goes further than other times I took the decision to replace U7,8,9,20,17, 14,11 [I know some chips don't need changing but desperation cut in]

After powering the system back up I still have the same issues.

Has anyone seen these issues, can some one please direct me to where I maybe should be looking as obviously Im in the wrong area.

The unit was working fine several months ago, the was a bad connection between -20v (-21v) and the power supply but that was resolved by reseating P3.

All voltages recorded on the schematics have been checked and are close to the spec [maybe my old fluke meter needs calibrating as well]

Any advice and support will be most welcome or direction to any manuals explaining in detail how the circuit works would be very much appreciated.

This afternoons update.

Still shows Fails Slave Test - Convergence on power on

After finding -20v missing through P3 to PCB A1 i reset all the DIN cables , magically the system started to sample more when testing DCV.

Autocal DCV

Sample 10V OK
Sample 1V OK
Sample 0.1V random samples
Sample Zero DCV 100
Sample Zero DCV 1KV

Click of Relays
Screen shows VDC [ERR]

Sample ACAL OHMS 10K
Sample DCI 1/10u

Screen shows VDC [ERR]

Any thoughts what to check next please


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod