Author Topic: -hp- 438A with no display and unresponsive front panel  (Read 149 times)

0 Members and 1 Guest are viewing this topic.

Offline 0culus

  • Super Contributor
  • ***
  • Posts: 1827
  • Country: us
  • Electronics, RF, and TEA Hobbyist
-hp- 438A with no display and unresponsive front panel
« on: November 17, 2019, 09:03:47 pm »
Hi all,

Recent auction score. An otherwise nice condition 438A dual sensor power meter. Cal sealed when I received it so I don't think anyone did any funny business. Symptom is that the unit powers on, but the display is dark and the front panel is otherwise unresponsive. I've been working through the troubleshooting and service sheets from the manual. So far I've determined:

* Power rails are nominal
* +5V display enable clock is not present at A9TP1
* Test modes using the binary rocker switch on A3 seem fine. Kicker: display lights up and passes all the display test modes perfectly. Front panel responds to keypresses for the manual display test, but display enable clk still missing at A9TP1.
* Signature analysis with my 5006A shows that the signatures for U21 do not match the manual values for either type of A3 board. U21 may be dead.
* Signature analysis of U8 in free run mode is impossible, as the values are unstable. No idea what's up with that.
* RAM backup battery is probably dead....will get a few more in an upcoming DigiKey order.
* No GPIB communication seems to work.

Bottom line is that I'm getting stumped on where to go next. Anyone else have troubleshooting experience with these units? I have tried reseating connectors and boards, no dice. I suppose it should be easy enough to find a donor and rob the ICs from it. Just want to make sure I'm not missing something obvious.

Thanks!!
« Last Edit: November 17, 2019, 09:14:02 pm by 0culus »
 

Offline 0culus

  • Super Contributor
  • ***
  • Posts: 1827
  • Country: us
  • Electronics, RF, and TEA Hobbyist
Re: -hp- 438A with no display and unresponsive front panel
« Reply #1 on: November 18, 2019, 01:36:35 am »
Update: I dove into the signature checks for service sheets 1-4, and I believe I may have narrowed the problem down to U19, which is a Motorola MC68B09P (HP part number 1820-2624). Fortunately, it's socketed. Tried reseating but didn't have any effect.
 

Offline Tony_G

  • Frequent Contributor
  • **
  • Posts: 602
  • Country: us
  • Checkout my old test gear channel (link in sig)
    • TGSoapbox
Re: -hp- 438A with no display and unresponsive front panel
« Reply #2 on: November 18, 2019, 02:27:43 am »
Is that just a 6809 micro? Quick check on the bay shows a bunch available for US$7. There might also be something socket compatible that is still just a 6809.

https://www.ebay.com/itm/5pcs-MC68B09P-Motorola-DIP-40-/173280778698

TonyG
 
The following users thanked this post: 0culus


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf