Author Topic: HP34401A autorange not functioning with half wave rectifier ?  (Read 1706 times)

0 Members and 1 Guest are viewing this topic.

Offline eliantoTopic starter

  • Newbie
  • Posts: 6
  • Country: it
In our lab we have three HP34401A with the same strange behaviour:

- secondary of trasformer with full vawe rectifier, ohmic load, measuring the voltage on the load with the multimeter all ok, the multimeter does autorange and make the correct measure

- secondary of transformr with half vawe rectifier, ohmic load, measuring the voltage on the load with the multimeter the display stuck on 80-90 mV, the autorange does not function, I have to manually change the range to see the correct value of measure

all three 34401 make the same,
checked the wave voltage on load with oscilloscope, all ok

I have try others multimeter, like FLUKE175, are functioning ok in all condition

Does anyone know or have observed same beaviour on HP34401A?

 
The following users thanked this post: edavid

Offline Swake

  • Frequent Contributor
  • **
  • Posts: 562
  • Country: be
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #1 on: March 23, 2023, 07:51:42 am »
Hi, I'd like to reproduce. Please provide much more details.  What type of trans, what voltage? Single winding output? 50 or 60Hz mains (there might be a setting in the meter for this) ? What type of resistor and value? What rectifier diode's? Did it read in only one manual range or several?
When it fits stop using the hammer
 

Offline theHWcave

  • Regular Contributor
  • *
  • Posts: 158
  • Country: gb
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #2 on: March 23, 2023, 12:21:31 pm »
Just ran a test with my 34401A and can confirm that strange behaviour.
5Vpp (roughly) from signal gen, 100Hz, wave form "pos full rectified" shows 3.17V in DCV auto mode. Fluke 187 shows the same
same signal  as "pos half rectified" shows 91mV in DCV auto. Man up-range to 1V shows 0.754V, man up-range again to 10V shows 1.59V which is what the Fluke 187 shows.
the 34401A behaviour is consistent in that down-ranging shows again 0.754 and 91mV

The behaviour is the same with a positive rectangle wave (called CMOS in my FY6600 function gen). When set to 5Vpp and 50% duty cycle, the DC should be 2.5V (confirmed by the Fluke 187) but the 34401 shows only 99mV in auto range. Up-ranging shows the correct 2.5V.

I am wondering if the 34401A  range selection gets confused by the AC component of the signal. This is the first time I noticed that. I am normally using rectangular waves (going plus and minus) and varying duty cycle to create mixes of AC+DC and as far as I remember, the 34401A has always shown the correct values for AC and DC components in auto range mode.
The difference in the case where it misbehaves is that the input signal itself is always positive.
 

Offline theHWcave

  • Regular Contributor
  • *
  • Posts: 158
  • Country: gb
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #3 on: March 23, 2023, 12:34:15 pm »
To add:
1. behaviour is the same for negative half-wave rectified
2. HP3478A has the same problem
3. Solartron 7150+, TTI 1906 and TTI 1705, OWON XDM1041, Brymen BM869S, Fluke 187, Fluke 101, ANENG 870 all show the correct value
 

Offline chekhov

  • Regular Contributor
  • *
  • Posts: 121
  • Country: by
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #4 on: March 23, 2023, 01:11:55 pm »
Have you also tried to play with different NPLC ?
 

Offline theHWcave

  • Regular Contributor
  • *
  • Posts: 158
  • Country: gb
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #5 on: March 23, 2023, 02:29:11 pm »
Have you also tried to play with different NPLC ?
NPLC?
 

Offline chekhov

  • Regular Contributor
  • *
  • Posts: 121
  • Country: by
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #6 on: March 23, 2023, 03:26:42 pm »
Instead of my lame words, let's see what user guide tells us:
Quote
Integration Time
Integration time is the period during which the multimeter’s analog-to-
digital (A/D) converter samples the input signal for a measurement.
Integration time affects the measurement resolution (for better resolution,
use a longer integration time), and measurement speed (for faster
measurements, use a shorter integration time).
Applies to all measurement functions except ac voltage, ac current,
frequency, and period. The integration time for the math operations
(null, min-max, dB, dBm, limit test) is the same as the integration time
for the measurement function in use.

Integration time is specified in number of power line cycles ( NPLC s).
The choices are 0.02, 0.2, 1, 10, or 100 power line cycles. The default
is 10 PLCs.

The easiest way would be to try different number of digits.
 

Online Kleinstein

  • Super Contributor
  • ***
  • Posts: 14453
  • Country: de
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #7 on: March 23, 2023, 04:14:26 pm »
The 34401 seems to only use the result from the main ADC to decide which range to use. So it does not detect if the signal is clipped nearly half of the time. As long as the result is below 100 mV it sees need not to switch to a high range. This was also common in older low grade handheld DMMs.
Good meters have extra comparators or similar to detect clipping and thus switch ranges not just based on the average, but based on the peak voltages.
 
The following users thanked this post: edavid

Offline theHWcave

  • Regular Contributor
  • *
  • Posts: 158
  • Country: gb
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #8 on: March 23, 2023, 07:47:52 pm »
Some more results of testing:

1. The problem did not change with different integration times (NPLCs)

2. Using a 5V pos. rectangle signal (i.e. alternating between 0 and 5V) at 50% duty cycle, the error gets less the higher the frequency and is gone at >= 1800Hz

3. Using 1000Hz, the problem is gone if duty cycle greater than somewhere between 54% to 59% . It seems not quite the same every time I tested, but consistently, higher duty cycle than 50% makes it go away. Also reducing the duty cycle has no effect on error.

4. Using 60% duty cycle, the problem disappears if frequency >= 900Hz. Using 70% duty cycle, the problem disappears if frequency >=200Hz
 
The following users thanked this post: horo

Online Kleinstein

  • Super Contributor
  • ***
  • Posts: 14453
  • Country: de
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #9 on: March 23, 2023, 08:05:18 pm »
The duty cycle depends on the waveform. The relvant point should be the crest factor: the amplifier output can swing some +-16.5 to +-17 V  (OP27 with some +-18 V supply). So there will be clipping if the signal exceeds some 1.8 times the range at any moment. The 10 V range may clip even earlier due to the input side and the 1000 V should not be exceeded at any time.
It looks like the 34401 just has no means to detect this clipping and will switch to the next higher range only if measured result is too high.
With a 50% duty cycle signal and clipping at some 170% one would never get beyound 85% for the average and thus no switching to a high range. So the 80-90 mV reading in the 100 mV range make absolute sense.
I don't see the frequency making much difference, but the voltage level and waveform (e.g. triangle is worse than square wave) can make a difference.
 
The following users thanked this post: edavid

Offline eliantoTopic starter

  • Newbie
  • Posts: 6
  • Country: it
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #10 on: March 27, 2023, 03:08:19 pm »
It amazes me how such a aged and well-known instrument can reserve these surprises.
Thanks everyone for the feedback.
 

Offline J-R

  • Super Contributor
  • ***
  • Posts: 1043
  • Country: us
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #11 on: March 27, 2023, 05:44:09 pm »
What am I missing, why are we trying to measure a waveform via DCV?
 

Online inse

  • Frequent Contributor
  • **
  • Posts: 669
  • Country: de
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #12 on: March 27, 2023, 06:11:58 pm »
I think it’s more about getting an inconsistent measurement result on a not so uncommon waveform.
 

Online Kleinstein

  • Super Contributor
  • ***
  • Posts: 14453
  • Country: de
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #13 on: March 27, 2023, 07:37:32 pm »
The main point learned should be that in DC mode there is no reliable way to detect overload / clipping, when the input signal has a significant crest factor.
In this case also the auto-rannging may fail and one should use manual ranging an if in doubt use a higher range.
Many other meters may have a similar problem. A reliable / sensitive detection of clipping at the DC input seems to be rare.
Some meters can at least detect a bit stronger clipping at the input.
 

Offline eliantoTopic starter

  • Newbie
  • Posts: 6
  • Country: it
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #14 on: March 28, 2023, 10:33:13 am »
Technically any rectified voltage is a DCV, I'm expected the DMM give me the average value, as other instruments do.
 

Online Kleinstein

  • Super Contributor
  • ***
  • Posts: 14453
  • Country: de
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #15 on: March 28, 2023, 11:09:30 am »
Expecting to get the average voltage is OK and would consider the behavior of the 34401 as failure / bug. A good meter should read the average and also have the auto-ranging working.
Looking at the plans of other bench DMMs, it looks like most of them could behave similar: the amplifier could clamp and the meter may still read less than full scale and thus not change the range.
A few meters (e.g. HP3456) may detect the clipping (at least for phases that are long enough, like the half wave rectified mains frequency), but I am afraid this bug is rather wide spread.
 

Offline TizianoHV

  • Regular Contributor
  • *
  • Posts: 105
  • Country: it
    • My Website
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #16 on: March 28, 2023, 12:58:28 pm »
This "bug" caught me once with my 34970A (similar to the 34401A). I was measuring a 1mV DC signal with 160mVpk ac noise (mains hum), my Keithley 2790 autoranged correctly to the 1V range but the 34970A stayed in the 100mV range showing a wrong value (way off). Now I always check with manual ranging.

Offline coromonadalix

  • Super Contributor
  • ***
  • Posts: 6205
  • Country: ca
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #17 on: March 28, 2023, 01:19:49 pm »
It amazes me how such a aged and well-known instrument can reserve these surprises.
Thanks everyone for the feedback.

You seem to forget  that  this meter has already lot of years in the design ....  technology, ADC,  and many things have changed since ....
NPLC, crest factor  etc ... 

now you have the AC+DC  functions, some maths and many more possibilities on dmm's,   portable of bench ones ...
 

Online Kleinstein

  • Super Contributor
  • ***
  • Posts: 14453
  • Country: de
Re: HP34401A autorange not functioning with half wave rectifier ?
« Reply #18 on: March 28, 2023, 02:14:02 pm »
The problem with DC ranges and superimposed AC part is known, though it is rare that it is so bad that the auto-ranging fails torally. There are some other tests around also with handheld meters. AFAIR the results are quite mixed with quite some meters showing wrong results.

The 34401 had some updates, but the general design and especially the ADC did not change. Expect the same behavior to mixed AC and DC for the all versions. From what it looks the older 3457, 3478 and similar likely have a similar problem and chances are that the 3458 could also fail in this case. So it is a bit surprinsing that the problem still exists in the 34401 and also other brand meters may have a similar problem. I would consider failing to read a half wave recitified voltage in the autorange mode a serious failure. Showing one 90 mV for half wave rectified mains could have bad consequences. The half wave rectified waveform is not that unusual and when searching for a fault one may well encounter it where one is expecting DC. 
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf