Author Topic: Toshiba 55U5766DB LED TV switches off after approx 10 seconds  (Read 517 times)

0 Members and 1 Guest are viewing this topic.

Offline nevillet

  • Newbie
  • Posts: 2
  • Country: gb
Toshiba 55U5766DB LED TV switches off after approx 10 seconds
« on: August 04, 2019, 09:44:40 am »
Hi All,

I am trying to repair a friends TV which switches off after about 10 seconds.  I thought the problem might be the Vestel 17IPS72 PSU board and i've checked all the electrolytics and the diodes.  All are fine.

The Vestel logic board is a 17MB120.

Any pointers would be most welcome.

Thanks
 

Offline m3vuv

  • Frequent Contributor
  • **
  • Posts: 625
  • Country: gb
Re: Toshiba 55U5766DB LED TV switches off after approx 10 seconds
« Reply #1 on: August 05, 2019, 10:11:36 am »
i would start by checking the psu outputs firstly,ie see if they all vanish when it turns off.
 

Offline nevillet

  • Newbie
  • Posts: 2
  • Country: gb
Re: Toshiba 55U5766DB LED TV switches off after approx 10 seconds
« Reply #2 on: August 05, 2019, 05:41:46 pm »
Thanks M3VUV,

It turns out that the psu board is OK.

I've figured out a work around to make it work:  After switching on you select an external source, like a video file on a USB stick. Once it is playing you can return to the TV tuner and it continues to work fine.  You have to repeat the process after switching off/on.

A bug in the firmware perhaps?  No updates are available on the Tosh site.  From new in 2017 it was fine and has only developed the issue over the last few weeks.
 

Offline m3vuv

  • Frequent Contributor
  • **
  • Posts: 625
  • Country: gb
Re: Toshiba 55U5766DB LED TV switches off after approx 10 seconds
« Reply #3 on: August 13, 2019, 05:34:00 am »
certainly an odd ball fault!
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf