EEVblog Electronics Community Forum

Electronics => Repair => Topic started by: mr.nicholaus on April 29, 2019, 04:41:42 pm

Title: Keithley 2001 Calibration Failure Error #363 200uA Gain out of Spec
Post by: mr.nicholaus on April 29, 2019, 04:41:42 pm
Greetings,

I am searching here in an attempt to remedy a failure I get when performing the comprehensive low level calibration.

I have already replaced the Electrolytic Capacitors and the self test passes with no errors. I complete all of the steps of the calibrations once I enter the calibration due date. I get error +440 " Calibration not complete. Once I query the errors with SYST:ERR?

I get 200uA gain OOT +363. I have about 10 of these unit is house. I have only gotten 2 to pass the low level calibration successfully.

The one the passes has B17/A02. The two the fail so far have B16/A02. I think the issue is in the firmware.

I had planned to purchase blank AT27C040-90PU-ND, copy the firmware from my working unit and install in the other unit. BUT I think this will not w

We have a DATA man M-pro that will allow for copying the firmware, will I still need to perform the calibration after updating the firmware?

Any and all help would be appreciated
Title: Re: Keithley 2001 Calibration Failure Error #363 200uA Gain out of Spec
Post by: ddcc on May 02, 2019, 09:27:10 pm
Funny, I had the same problem with a 2001M: https://www.eevblog.com/forum/testgear/restoration-glory-of-keithley-2001-dmm/msg2189003/#msg2189003 (https://www.eevblog.com/forum/testgear/restoration-glory-of-keithley-2001-dmm/msg2189003/#msg2189003)

Don't think the problem is in firmware, I upgraded from B16 to B17 and it made no difference. But I wasn't performing low-level calibration, only the regular comprehensive calibration. What worked for me was replacing some of the analog switches, and then making sure to recalibrate in 4W mode.