Electronics > Repair

Keithley 2010 Freezes, Many errors


Hi Everyone

I have had a Keithley 2010 for a few years now. But a few weeks ago I went and turned it on, it shows   --------mv.   and nothing gets updated

if I try to change functions, it will change function, but then will be unresponsive after that and had to be rebooted

I ran the built in self test by turning on with the open button pressed, and I get Failed 100.1, 1001.2, 101.3, 200.1, 200.2, 301.1, 301.2, 301.3, 302.1, 302.2, 303.1, 303.2, 304.1, 400.2, 401.2, 402.3, 403.2, 600.1, 600.2

From what I have seen seems like the 100.1 is likely the main issue, which by the keithley 2000 service manual is NO A/D COMM.

Luckily I have 2 keithley 2010 and have been trying to do some comparisons. I have the scope screen shot comparing both. the top 5 Logic inputs are looking at U155(data from Analog section), U150 and AT1011(data from digital to analog section) of the good 2010, and the bottom 5 logic inputs are of the non working 2010. I can see some data is going back and forth between them, but the data is different. Currently the firmware is different, should be able to put both to the same firmware hopefully tommorow.

I have checked all the supply rails on both the analog and digital section from the keithley 2000 service manual (unable to find a 2010 service manual), and the test points seem to match up and the voltages seem to match as well. I have checked the TF-245 resistor network (R271) which seems to have gone bad for other people, but seems to look good. I have checked both the analog switches(U163, DG408 and U176, DG444) and they are good.

I ran the built-in self test, manual, test 100, and step mode. TP105 which is the A/D testpoint, on bad one is showing fluctuating from ~12.1-13.5vdc about every second. while the good unit is -10mv. when I press the shift button to show the results of test 100.1, the bad -419233497 and good is 0155483299. if I run a few times the bad is the exact same number every time, while the good fluctuates maybe 1000 counts. so it seems like the a/d converter is at full scale. if I press enter to run the next test, it shows 100.2 fault, but pressing shift does not show the value as it freezes at this point.

running test 101

running test 200 fault on 200.1, press the shift button and it shows 0.000000, but measuring TP105, I get 1.025vdc. and is should be 1.0v +- .1v. so this seems like good news, the process or is changing some ranges on the analog side, so there seems to be communication to the analog side, or at least partial communication.

test 201, and on 201.1, shift shows 0.000000, and voltage on TP105 but started at 5v on the start of 201.1 then fluctuating from 12.1-13.5vdc.

it seems like it is not getting any data back from the ADC to the processor. I have been looking thru the schematics I can find of the Keithley 2000 and Keithley 2010, as the 2010 is not complete. I have swapped the following components between the 2 meters and still no luck after spending lots of time trying to diagnose it. aware that I may have to calibrate both meters by doing this.

U146 (74HCT14 between optocouplers and processor)
U165 (2000-802A02 A/D converter)
U163 (DG408 analog switch)
U176 (DG444 analog switch)
U130 (4094 shift register)
U177 (MC34081 jfet opamp)
U153 (74HCT02)
U148 ( 74HCT02)
U149 (SD5400 analog switch)
U154 (74HCT175)
Odd and even firmware

I did a continuity check from the output of U146 to the Processor Pin 84 and I have 4.3k resistance (resistor in series) as I thought maybe a bad solder joint on the data line from the ADC to the processor. I can see the signals from the processor on the 3 data lines directly on the ADC chip, as well as the data from the ADC directly onto the Processor.

I am loosing idea on what might be the issue on this one. I found one thread that mentioned someone had a meter freeze up, but there was no replies to that thread. anyone else that seems to be having a 100.1 error, the meter does not seem to freeze up, so I think I have something unique.

Does anyone have any other ideas?

Keithley 2010 service manual

Keithley 2000 repair manual

partial Keithley 2010 schematics

partial keithley 2000 schematics

TP105 is the input to the ADC. So the problem is very likely not at the ADC itself, but more at the front end. As there is a 1 V signal in 1 case, the amplifier itself seem to still work.

For me the main suspects would be the the optocouplers itself and maybe the input switching.
Optocouplers tends to loose in CTR (gain) over time and there is a small chances that the signal is no longer good. Especially the direction from the ADC back to the output (U155 for the K2000) is suspect. Chances are signal could be boarderline in strength and may thus work for some time. So it can be worth having a look at the signal directly after U155.

The JFETs to the input are exposed to possible ESD and similar and thus have some chance to get damaged that way. There are also reports on LM339/LM393 used to control the JFETs going bad for no good reason in different meters.

Another possible, but rare point of failure could be the clock generator for the ADC.

Have you checked the problem electrolytics and checked they haven't leaked their contents all over your PCB?

Thiinking back over old posts I think the received wisdom is you need to look under the caps, even if all seems to be OK otherwise.

sudden problems overtime  must be  supply related for sure ???  tants  lytics  etc ...


Turned out that the problem was a OPA177 (U138). the output was stuck on the negative supply rail. having the noninverting input higher than the inverting pin and the output was at the negative rail. Swapping the opamp fixed the issue.

I have not seen anyone else with this specific op amp before. So might be another place for someone else having issues to look at.

During some of my previous troubleshooting, I had swapped one of the analog switches, and did not realize that one of the pins did not get soldered correctly. that is what was causing the sweeping of voltages on TP105. and just happened that when it was doing the 200 series test (reference), it had a steady voltage on TP105. But doing the other tests, did not have the correct feedback. When I fixed this solder joint, still had the same frozen display, but at least TP105 was now steady. Which following thru the schematics other members have created, brought me to U138.

Thanks for everyone help.


[0] Message Index

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod