Electronics > Repair

Kenwood CS-4125 oscilloscope focus & intensity

(1/4) > >>

Jarvik7:
Over the weekend I just rescued a Kenwood CS-4125 20MHz scope that had been thrown out and sitting in the rain.
After drying it out and powering it up, it works perfectly aside from the focus and intensity controls.

Focus works to a point, but at its sharpest the trace is still about 2-3mm thick.
Intensity doesn't affect the trace brightness at all, but will worsen the focus somewhat when adjusted.

I checked the control pots with my dmm and getting expected readings throughout their travel.
I'm guessing that either an internal adjustment pot for focus needs adjustment, or a resistor etc has gone out of spec/died.
Popping the case reveals no obviously burnt components.

Unfortunately I only have an owners manual with zero useful information, no service manual.

Anyone have any experience with one of these units, or maybe the service manual or schematic?

Jarvik7:
Found this snippet in a catalog:


--- Quote ---Auto-focusing
The auto-focusing function corrects the focusing error
automatically even when the intensity is varied.
--- End quote ---

Which implies that the focus control is fine, but just the intensity control is broken and is throwing off the focus.

tautech:
Start with downloading this document to help you with scope problems and repairs.

http://www.sphere.bc.ca/test/tek-parts/troubleshooting-scopes.pdf

Jarvik7:
After a couple hours of Googling I've only managed to find some sites where you can pay for the manual, but I did find a CS-4025 service manual. While it's not the same model and some controls are in different locations, the theory behind the power supply unit should be similar I hope. I've emailed Texio and am waiting for a response...

The only hint I found in that troubleshooting file for intensity/focus problems is that being unable to reduce the intensity (exactly my problem) may be due to a "weak DC restorer diode" in the control grid supply. Unfortunately I don't have a schematic but I suppose I can test all the diodes on the power supply unit board. In the CS4025 schematic there are 9 in circuit with the intensity control input.

I'm guessing here, but would a failed restorer diode cause blanking to not function altogether?
I cannot see the beam return so that's not an issue I have...

mij59:
Are sure all the parts are dry ?
Any sings of residues from the rain ?
Please post some photo's

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version