Author Topic: Kenwood TS-700A  (Read 487 times)

0 Members and 1 Guest are viewing this topic.

Offline bob91343

  • Super Contributor
  • ***
  • Posts: 1612
  • Country: us
Kenwood TS-700A
« on: April 22, 2019, 10:27:25 pm »
I have one of these to repair.  The problem appears to be in the power supply.  Has anyone worked on one of these?

This unit runs either from 120V line or 13.8 VDC with automatic switching.  Some of the radio runs from a 21 Volt supply which is generated by, I think, an oscillator and voltage doubler.  So far I have discovered a diode that never got soldered properly and corrected it, but still no operation.

The 21V supply runs at about 13V.  There is a fuse in its output and when I remove the fuse the 13V is unchanged.  There is also a 9V supply that is okay, and adjusts fine, but the 21V is insensitive to adjustment.

Looking at what I think is the output of the oscillator, it seems not to be oscillating.  I will continue to test parts and inspect soldering but wonder if anyone has worked on one of these old radios.
 

Offline CoopedUp

  • Regular Contributor
  • *
  • Posts: 99
Re: Kenwood TS-700A
« Reply #1 on: April 22, 2019, 10:30:52 pm »
I'm no expert but I have worked on many tube radios and I know that if it's old it needs new electrolytic capacitors... that could definitely mess the power supply up. unless you knew that and have already done that...
 

Offline bob91343

  • Super Contributor
  • ***
  • Posts: 1612
  • Country: us
Re: Kenwood TS-700A
« Reply #2 on: April 22, 2019, 11:01:17 pm »
I do know that, but for the most part won't replace a capacitor that tests good.  If it doesn't look good, I may replace, but if it still has its marked capacitance, low leakage and ESR, I leave well enough alone.

It's not working, and I can't blame any of the capacitors I have tested so far.  There are others, and therein may lie the cause of the problem, but it's dicey to climb in there and measure.

At the point where I think I should see an oscillation wave, I see clean dc.  Well, a few millovolts power line ripple is all.  The oscillator looks at first like a phase shift oscillator but there is an inductor as well.  Before I get heavy handed with this unit I want to understand how it's supposed to work.

I also have worked on many a tube unit and am comfortable with their issues.  This radio does appear to be unique in the power supply at least.  I may pull the fuse and see if it works with 21V from an external supply.  If so, that tells me it's a power problem.  If not, it tells me almost nothing.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf