Author Topic: lappy noisy psu  (Read 219 times)

0 Members and 1 Guest are viewing this topic.

Offline m3vuv

  • Frequent Contributor
  • **
  • Posts: 705
  • Country: gb
lappy noisy psu
« on: December 15, 2019, 09:27:21 pm »
hi all,ive a dell inspiron lappy,it works fine exept the power adapter wipes out most of 80+40m ham bands out with hash at s9,any idea how i can cure this?,ive tried ferrites on the cable but made zero differance,cheers m3vuv.
 

Offline Kleinstein

  • Super Contributor
  • ***
  • Posts: 7891
  • Country: de
Re: lappy noisy psu
« Reply #1 on: December 15, 2019, 10:08:26 pm »
The best chance is probably to get a new supply.  Ferrite beads can help a little, but it is better to have a SMPS that does not produce the EMI from the start. There is chance there is either a defect causing the trouble or the given model was a poor design to start with.
 

Offline TheMG

  • Frequent Contributor
  • **
  • Posts: 430
  • Country: ca
Re: lappy noisy psu
« Reply #2 on: December 16, 2019, 12:34:43 am »
Is it the original OEM power supply, or a replacement? Normally the OEM power supplies are pretty good noise wise but I've encountered more than a few aftermarket replacement power supplies that have basically no EMI filtering and are noisy as heck.

Also, is the laptop in question connected to your radio equipment in any way? With certain antenna types, especially if it's not well matched (at the feedpoint) and/or does not have a good RF ground, it's easy to get conducted RFI into the radio. How close is your antenna (and its feedpoint) to the laptop?
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf