Electronics > Repair

Micromotor (used for jewellery) failed - can't work it out

(1/3) > >>

Cykar:
Hi all,

I have STRONG (that's the brand name lol) 207A micromotor. It's used in jewellery production, but can also be found for sale as dental equipment.

It no longer works. The circuit didn't look too complex so thought I'd try to fix it, but have completely failed.
Any help greatly appreciated.

What is it?
It consists of a handpiece in which you fit various tools and within which there is a motor. The speed of the motor is controlled by the main unit, a small box which sits on the workbench. On the front there is a speed control which works only when in "hand" mode, an on/off switch, a switch to change the direction, an "over-voltage" led, and the socket to connect the handpiece. On the back there is the cable to plug it into the mains, a switch to choose between "hand" or "foot" control, and a socket to connect the foot pedal. I do not use it in "foot" mode, the pedal is disconnected as the slide pot in the unit has worn out.

Symptoms:
Initially the hand piece would start when the unit is turned on at MAX speed or possibly higher since a simple sanding roll would bend out with the forces involved. The speed control on the unit would make no difference to the speed, and after a few seconds the over-voltage led would come on and the whole thing stop.
After testing it a few times, it now doesn't work at all and the over-voltage led has blown, but the led in the on/off switch still lights.

I have previously changed the speed control pot on the front since when we were given it it was stuck at a single speed (although not over fast as was the more recent symptom) and it worked well for a few months until these new problems occurred.

What I've tried:
I have tried changing the voltage regulator (LM317T), but this made no difference. I have made an attempt at reverse engineering the circuit which I've attached - please forgive the hand drawing, haven't had time to put it in a program, this was just quicker and easier. It's of course possible i've made some mistakes despite my checking and re-checking, so if there seems anything obviously wrong or that you need clarifying, please let me know.

The ac mains voltage comes through a fuse into a transformer which outputs about 34V into the circuit, going into a bridge rectifier outputting about 44V.
Measuring the voltage output from the LM317 I am constantly getting around 44.5V regardless of what speed is set. The speed pot itself measures fine.

I have measured and tested all the passive components, the diodes, caps and resistors - all fine.
Other components are a BDW93C darlington transistor, the LM317T variable voltage regulator, a CRO8M SCR, and a transistor (i presume) marked ALY, which with a bit of googling appears to be a KTC3875 NPN transistor, and there is the bridge rectifier which measures good.

The motor itself measures about 11ohms between the two pins that are connected to the control unit, so the windings are not open, or shorted. I'm assuming they are ok.

I am really at a loss as to what could be wrong.

I could just blindly change all the active components, and hope for the best, but would rather understand what is going wrong. All the resistors are SMD, as is the transistor and the SCR. Thinking about it now, measuring the resistors in circuit probably isn't going to work, so maybe one o them has shorted?

I hope someone can point me in the right direction as to what to do. The unit costs about £400 so really can't afford to replace it.

Thanks for your help.






Intitially the motor in the handpiece

Andy Watson:
It appears from your circuit diagram that you have a variable-voltage power supply with a little added fault-protection. The voltage reference - i.e. speed control - is derived from the LM317. You should be able to measure the voltage on its pins and confirm that it is regulating. In particular, the output should follow the "adj" terminal plus about 1.23V

With regard to your tracing of the circuit: D3 is definitely the wrong-way around. Something odd is happening around the fault-detection circuit: The bottom end of VR1 should not be planted in the ground. I'm guesing that R9 should connect with the base of KTC3875 rather than its collector?

james_s:
Is this just a brushed DC motor? If so then a motor fault is the first thing I would suspect. I have had to fix a few cordless tools where carbon dust from the brushes fouled the commutator causing the motor to draw excessive current. Try powering the motor from a bench supply or try using a similar motor or incandescent lamp load connected to the controller to isolate the fault.

Cykar:
@Andy Watson, You are right about D3, I have got it the wrong way round on the schematic. VR1 though, which is a trimmer, is definitely connected to ground as far as i can tell. I have attached photos of the board itself after removing the heatsink for the BDW93C, hoping that might help.

As to the KTC3875 transistor, there seem to be different numbers on the pins in different datasheets, tho what those pins are remains the same if you see what i mean. But given what you have said I looked again and have gone through, buzzing things out, and have redrawn those parts of the schematic. There is a difference, but R9 does seem to be connected to the collector, and only to the base via a 10k resistor (R4).

Testing the voltages on the LM317 with the motor/handpiece connected, (and the foot pedal disconnected), initially i get about 17V from the output pin 2. After a second or so it leaps up to 43, and the over-volatage LED comes on.

Wondering if @james_s is right and there's a problem with the motor itself. Seems to make no difference as to what the initial speed is set at. How can I test the motor?

james_s:
Testing the motor is easy, just supply it with a DC voltage and measure the current it draws, or do like I suggested and use a lamp or other load to test the controller.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod