Author Topic: METEX M-3650B need help  (Read 1263 times)

0 Members and 1 Guest are viewing this topic.

Online YU7C

  • Regular Contributor
  • *
  • Posts: 51
  • Country: cs
METEX M-3650B need help
« on: August 06, 2017, 05:04:30 pm »
Hi,

After few years collecting dust, I decided to repair my old METEX M-3650B from 1993.

It seems that 7106 is broken, because it doesn't react on voltage which comes from divider. We will know a result after the chip is replaced.

Also I didn't find voltage reference, despite it exist on the schematic (ICL8069)?

Actually my main problem that i was a bit careless and during testing broke two wires between main and auxiliary boards which menage LCD for bargraph,...

Does anybody know how to right way to connect two boards?

 

Offline coromonadalix

  • Super Contributor
  • ***
  • Posts: 2085
  • Country: ca
Re: METEX M-3650B need help
« Reply #1 on: August 07, 2017, 11:09:52 am »
you have to sniff  where thoses 2 pins goes on each boards ...  the schematic is available, and find where they link
 

Online YU7C

  • Regular Contributor
  • *
  • Posts: 51
  • Country: cs
Re: METEX M-3650B need help
« Reply #2 on: August 07, 2017, 01:31:35 pm »
Unfortunately, I didn't find schematic of auxiliary board with M-8850.
 

Offline ModemHead

  • Frequent Contributor
  • **
  • Posts: 730
  • Country: us
  • No user-serviceable parts inside.
    • Mr. ModemHead
Re: METEX M-3650B need help
« Reply #3 on: August 07, 2017, 04:13:04 pm »
 
The following users thanked this post: YU7C

Online YU7C

  • Regular Contributor
  • *
  • Posts: 51
  • Country: cs
Re: METEX M-3650B need help
« Reply #4 on: August 07, 2017, 04:35:39 pm »
Yes, that helps! Thanks.

Now waiting for 7106 chip.
 

Online YU7C

  • Regular Contributor
  • *
  • Posts: 51
  • Country: cs
Re: METEX M-3650B need help
« Reply #5 on: August 10, 2017, 05:21:48 pm »
First, I had put UMC UM7106 which apparently should be compatible with ICL7106 but multimeter didn't work at all.

Then I found original Intersil ICL7106 and it's live again. After short calibrating process with help of 8840A it's in function.

Puzzle with UMC UM7106 remains. I found info that UM7106 has totally different function?
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf