Author Topic: Need full firmware (full dump flash) oscilloscope Atten ADS 1062CML  (Read 4257 times)

0 Members and 1 Guest are viewing this topic.

Offline shutto

  • Newbie
  • Posts: 3
  • Country: ru
Need full firmware (full dump flash) oscilloscope Atten ADS 1062CML and similar oscilloscopes Aten, Siglent.
Failure firmware. Photos board
Thank you.
« Last Edit: March 01, 2016, 06:23:26 pm by shutto »
 

Offline shutto

  • Newbie
  • Posts: 3
  • Country: ru
Re: Need full firmware (full dump flash) oscilloscope Atten ADS 1062CML
« Reply #1 on: March 01, 2016, 04:23:01 pm »
Manifestation of a fault in the photo  :(
So after Lecroy WaveAce1xxx firmware  :-[
What is the reason?  |O
Programmed through the JTAG dump different.
Problem still exists.
On firmware for Atten ADS 1102CAl writes - Load Fpga fail.
« Last Edit: March 01, 2016, 04:30:53 pm by shutto »
 

Online Monkeh

  • Super Contributor
  • ***
  • Posts: 6093
  • Country: gb
Re: Need full firmware (full dump flash) oscilloscope Atten ADS 1062CML
« Reply #2 on: March 01, 2016, 04:29:28 pm »
What makes you think that's a firmware problem?
 

Offline shutto

  • Newbie
  • Posts: 3
  • Country: ru
Re: Need full firmware (full dump flash) oscilloscope Atten ADS 1062CML
« Reply #3 on: March 01, 2016, 04:34:10 pm »
The problem appeared immediately after the firmware upgrade via USB on Lecroy waveace1xxx_5.01.02.27.ads
On the firmware Siglent worked but slow sweep.  What was the reason for the replacement.
Possible damage CPLD Lattice or Altera?
Thank you for attention.
« Last Edit: March 01, 2016, 04:42:57 pm by shutto »
 

Offline rg58

  • Contributor
  • Posts: 38
  • Country: de
Re: Need full firmware (full dump flash) oscilloscope Atten ADS 1062CML
« Reply #4 on: December 09, 2016, 11:19:01 am »
Hi shutto,

Did you make any progress with your repair? Have you managed to find the problem?

I'm facing exactly the same problem with an ATTEN ADS 1102 CAL which should be identical to Siglent SDS 1102 CNL. Upon bootup it shows the error "Load FPGA Failed!".

I bough the scope from someone second hand, so I don't know its history and what has caused the issue. I have tried several firmware versions including a version sent to me from ATTEN.EU on my support enquiry. The flashing went OK, but the problem always remained the same.

I was tearing the thing apart as well but found nothing obvious. Attached you photos.

How can we go about troubleshooting the device? Via JTAG interface? I have identified 2 headers on the board. One of them is JTAG, I'm not sure about the other one.

Anyone else here having the same problem? This thread attracted quite a bit of attention as it was read 491 times, so I assume there could be more people out there with the same issue.

Thanks everyone!
« Last Edit: June 29, 2017, 04:51:37 pm by rg58 »
 

Offline ManMan

  • Contributor
  • Posts: 9
  • Country: ru
Re: Need full firmware (full dump flash) oscilloscope Atten ADS 1062CML
« Reply #5 on: June 07, 2017, 09:32:59 am »
Try this flash dump ADS1102CAL
https://yadi.sk/d/0Bf97ZYq3JuBpp

->- I also need Atten ADS1022..ADS1042..ADS1062 or Siglent SDS1022C  Flash dump.. and Siglent SDS1022C latest Firmware -<-
->- Please Help !!! -<-
« Last Edit: June 07, 2017, 09:47:01 am by ManMan »
 
The following users thanked this post: rg58

Offline rg58

  • Contributor
  • Posts: 38
  • Country: de
Re: Need full firmware (full dump flash) oscilloscope Atten ADS 1062CML
« Reply #6 on: June 24, 2017, 03:26:40 pm »
Thanks for that, ManMan! Very much appreciate it!

Now the question is: How do I get it in there? Is it safe and possible to do the firmware update via menu? I think as this a dump it might not be possible. I assume this the content of the 'S29GL064N90TFI04' (Spansion) flash memory? I'm afraid I need to take that out for flashing... which I have only limited possibilities for. Or can I do it via JTAG, programming the flash memory 'through' the controller? Sorry, I'm quite new to this digital stuff although into electronics for over 25 years.

Please help! Thanks!

P.S. Can't help with the Flash dumps, but the latest firmware should be here: http://siglent.com/ENs/gjjrj.aspx?id=15 
Not sure if the CML version is compatible with your scope.
« Last Edit: June 24, 2017, 06:32:57 pm by rg58 »
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 17075
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Need full firmware (full dump flash) oscilloscope Atten ADS 1062CML
« Reply #7 on: June 25, 2017, 12:52:06 am »
Please be aware any FW for *DS1***C*L is only for 7" display models, models without L are 5" display and use different/older FW versions.
There are also versions 3 and 5 of HW, the coding in the FW version gives some clues as to which they suit.
Avid Rabid Hobbyist
 


Offline rg58

  • Contributor
  • Posts: 38
  • Country: de
Re: Need full firmware (full dump flash) oscilloscope Atten ADS 1062CML
« Reply #9 on: December 24, 2017, 12:22:22 pm »
Thanks for that! This was very helpful!

So, I just wanted to let everyone know the outcome.

Firstly, following 'ManMan's instructions, I managed to upload a new firmware via the 'Wiggler' JTAG interface that I built ("In-Air-Technology"). It was horribly SLOW, literally taking me DAYS to complete (in sections), with very unstable clock & data signals on the output of the LPT (jitter), and the software utilizing 100% of my CPU on every computer that I tried. Probably an issue with this 'TopJTAG Flash Programmer' software (which is great otherwise). So I can't recommend the simple Wiggler interface, it was a real pain. Later I tried with a cheap 'Altera' USB Blaster interface from China, but that wouldn't work either as it lost connection to the JTAG everytime after a few seconds. Blame it on this chinese interface as it did the same on another device's JTAG.

So I first dumped the orignal FLASH content of 8MB. Did that a few times and run MD5 hashes until I had enough files that had the same hash, so I could be confident that what I dumped has actually been read successfully several times (I did produce many dumps with errors). The reading from Flash took 1174min (19.5 hours !!!) for 8MB each time (see screenshot), although later I noticed that only the first 2.5MB were occupied with data, so I limited to address range for subsequent reading/writing. Next, the FLASH needs to be erased. The software doesn't allow you to erase the first sector (which fails otherwise), so you need to untick it (screenshot). Then, after writing ManMan's dump to the FLASH and by reading it back again, I confirmed it to be 100% identical to the input file (by MD5 hash) - so the writing was confirmed to be successful. However, the problem REMAINED the same :-BROKE 

I had then tried flashing various other (suitable) Firmware versions via JTAG, but with all of them the problem didn't go away. This whole process took me a few WEEKS to complete as of the slow speed of the wiggler interface and this software. The highest possible clock speed meassured on the LPT was only 22 kHz, no matter the setting in the software (limited by CPU power?).

So I went back troubleshooting the hardware again. I confirmed earlier that the power supply was ok, output voltages were all correct, stable and ripple-free. Then I went on to take several other measurements with another scope and multimeter. Here's what I found out: The 3 AD-Converter ICs on top (and 2 on the bottom) with their writing removed were identified to be most likely AD9288 - at least the pinout matches everything on this PCB. So, probing those ones, I noticed that there are no CLOCK signals on ENCA (Pin 47) and ENCB (Pin 14) - no matter the Time/Div setting. It was hard to follow the copper trails, but I believe the one clock signal (fed into the 5 ADCs via 5x2 1kOhm resistors) comes from the big CYCLONE IV FPGA  :palm:  At this point I gave up. Maybe the FPGA got fried when someone flashed the wrong firmware onto this device? It is however still possible that NONE of the Firmware versions that I tried matched this scope's hardware, who knows.

Hope this helps some of you guys out there who would like to troubleshoot further. I have given up. You can't always win.

MERRY CHRISTMAS !
« Last Edit: December 26, 2017, 02:43:01 pm by rg58 »
 



Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf