EEVblog Electronics Community Forum

Electronics => Repair => Topic started by: justin55162000 on February 22, 2017, 10:42:41 am

Title: Need help Gw instek 1850d psu weird display
Post by: justin55162000 on February 22, 2017, 10:42:41 am
I am a newbie of electronic, sorry for my poor knowledge.
I recently pick up a Gw instek gps-1850d psu, but the display read "1." as the photo, when nothing is plugged in.
And when start the machine, it have some noise, I wonder if that's normal.
Is that possible to be fixed?

Title: Re: Need help Gw instek 1850d psu weird display
Post by: JFJ on February 22, 2017, 01:29:22 pm
Might the power supply be in slave mode? For normal operation, the rear panel slider switch should be set in the 'MASTER' position.
Title: Re: Need help Gw instek 1850d psu weird display
Post by: justin55162000 on February 22, 2017, 01:55:18 pm
Thanks for your reply, but I have doubled check that I have chosen the master mode.
Title: Re: Need help Gw instek 1850d psu weird display
Post by: singapol on February 25, 2017, 09:50:28 am
GW Instek service mauals are hard to come by...At leat there is the user manual:

Instruction manual:
http://assets.tequipment.net/assets/1/26/Documents/GPS-Small-series_manual.pdf (http://assets.tequipment.net/assets/1/26/Documents/GPS-Small-series_manual.pdf)

Not the actual service manual but at least you can have an idea of how a similar power supply is constructed
with schematics. BTW there is a block diagram of GPS1850D in the user manual which is similar to GPD3303S.

GDP3303 service manual:
http://www.eltest.hu/pdf/GPD3303SM.pdf (http://www.eltest.hu/pdf/GPD3303SM.pdf)

Good luck. You need to open up the box to investigate. :)