Author Topic: Need help Gw instek 1850d psu weird display  (Read 1385 times)

0 Members and 1 Guest are viewing this topic.

Offline justin55162000

  • Newbie
  • Posts: 2
  • Country: hk
Need help Gw instek 1850d psu weird display
« on: February 22, 2017, 10:42:41 am »
I am a newbie of electronic, sorry for my poor knowledge.
I recently pick up a Gw instek gps-1850d psu, but the display read "1." as the photo, when nothing is plugged in.
And when start the machine, it have some noise, I wonder if that's normal.
Is that possible to be fixed?

 

Offline JFJ

  • Regular Contributor
  • *
  • Posts: 234
  • Country: gb
Re: Need help Gw instek 1850d psu weird display
« Reply #1 on: February 22, 2017, 01:29:22 pm »
Might the power supply be in slave mode? For normal operation, the rear panel slider switch should be set in the 'MASTER' position.
 

Offline justin55162000

  • Newbie
  • Posts: 2
  • Country: hk
Re: Need help Gw instek 1850d psu weird display
« Reply #2 on: February 22, 2017, 01:55:18 pm »
Thanks for your reply, but I have doubled check that I have chosen the master mode.
 

Offline singapol

  • Frequent Contributor
  • **
  • Posts: 420
  • Country: sg
Re: Need help Gw instek 1850d psu weird display
« Reply #3 on: February 25, 2017, 09:50:28 am »
GW Instek service mauals are hard to come by...At leat there is the user manual:

Instruction manual:
http://assets.tequipment.net/assets/1/26/Documents/GPS-Small-series_manual.pdf

Not the actual service manual but at least you can have an idea of how a similar power supply is constructed
with schematics. BTW there is a block diagram of GPS1850D in the user manual which is similar to GPD3303S.

GDP3303 service manual:
http://www.eltest.hu/pdf/GPD3303SM.pdf

Good luck. You need to open up the box to investigate. :)
« Last Edit: February 25, 2017, 09:52:21 am by singapol »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf