Electronics > Repair

[fixed] Need help: GwInstek GPS-4303 "parallel" not working properly


Hi there,

I have a GwInstek GPS-4303. I switched CH1 and CH2 to be in series and attached a load with 3 amps at ~57V.

During fine-adjustment of the current by turning the current-know, I slightly "touched" the right tracking switch. slightly touching it was enough for the supply to switch from series to parallel and *bam*, output went down to 0. It sounded like a blown fuse or part and smelled a bit.

I checked all the internal obvioous fuses: They are all fine. No visible damage to any part. Looks just fine.

Current behavior of the power supply: All works fine, except the series connection of CH1+CH2:

It still gives me just above 30V, and up to 3Amps, but no longer up to 60V.

I found the self-drawn schematic for the Tenma 72-6905 whis is a rebranded GwInstek GPS-4303, but I'm not able to track down the issue.

Is there an expert who can guide me a bit? I'm not that familar with finding root-causes of non visible damages/problems.

Tools available:

30V regulated power supply

best regards,

I think I fixed it:

Desoldered three relais that switch between independant, series and parallel. Tested them outside the PCB... All worked fine. Found out, that for one of the relais, the contacts measured a short circuit. Found the diode for the relais measured almost 0 Ohms. Diode test failed. desoldered it, measured again, still failed.

Replaced it with a 1N4148 THT diode, shorted the leads, looks almost a MELV diode :-)
Inserted the new diode, resoldered the relays, tested: Works as before.

Simple fix, but still can't believe that there is no mechanism that prevents this problem...


[0] Message Index

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod