Author Topic: Wavetek 9100  (Read 1185 times)

0 Members and 1 Guest are viewing this topic.

Offline jsolomonsc@gmail.comTopic starter

  • Contributor
  • Posts: 10
  • Country: us
Wavetek 9100
« on: September 02, 2022, 11:25:22 pm »
I have a 9100 that is acting funny (yeah... big surprise) and I am trying to work though the logic before I start probing around. If I let the unit sit overnight unplugged, when I turn it on and let it do its POST, it will fail and the buttons and keys are locked. I am not able to do anything. I would then cycle power and the unit will then properly boot. (no error messages). full self test passes.

So here are my questions:
1. Is there a way to get the errors (I guess through the ports in the back) via the serial, GPIB, printer?
2. With the above description, any ideas that will point me in the right direct?
3. I first thought maybe an eeprom battery issue, but I cannot find any battery's except the one that is in the RTC (Dallas 1287)?

I have not done anything to this unit except replace the front bezel and reseat some of the chips that are on risers. it was in a car accident before I got it and it was showing this error right after that.
 

Offline ebclr

  • Super Contributor
  • ***
  • Posts: 2329
  • Country: 00
Re: Wavetek 9100
« Reply #1 on: September 03, 2022, 07:20:32 am »
Appear to be  a Capacitors problem, check all capacitors,specially those one involved on reset of the unit
 


Offline jsolomonsc@gmail.comTopic starter

  • Contributor
  • Posts: 10
  • Country: us
Re: Wavetek 9100
« Reply #3 on: September 05, 2022, 06:23:41 pm »
Thanks for the response. I have to replace the RTC (or do the modification that puts a battery on it). While I have the board out for unit Ill probe the caps.
 

Offline jsolomonsc@gmail.comTopic starter

  • Contributor
  • Posts: 10
  • Country: us
Re: Wavetek 9100
« Reply #4 on: September 05, 2022, 06:46:39 pm »
Thank you.  I have now 3 users manuals, 4 service manuals and 4 sets of schematics now. I have been combing over them trying to find the RTC and the epproms... i must be blind...LOL

 

Offline jsolomonsc@gmail.comTopic starter

  • Contributor
  • Posts: 10
  • Country: us
Re: Wavetek 9100
« Reply #5 on: September 20, 2022, 10:53:11 pm »
Well, after some body work and some dealing with the messed up front bezel and the booting issue, I have the unit sorted out. Turns out the errors I was getting was being caused but a dead RTC and having the top panel off (light sensitive components). The good old DS1287 that has been discontinued for about 10-15 years now. Luckily someone on Youtube has a work around that works. Now the unit will boot properly each time and all functions seem to work. Time for more in depth testing. I can't do a full calibration. I don't have a capacitance meter nor a good enough O'scope.

I have a 9100 with scope option for sale!!

 
The following users thanked this post: coromonadalix, Ugur

Offline Testtech

  • Regular Contributor
  • *
  • Posts: 121
  • Country: us
Re: Wavetek 9100
« Reply #6 on: September 21, 2022, 10:39:24 pm »
The currently available DS12887 is a direct replacement.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf