Author Topic: OWON SDS8302 repair help needed  (Read 468 times)

0 Members and 1 Guest are viewing this topic.

Offline Tester3000

  • Newbie
  • Posts: 2
  • Country: us
OWON SDS8302 repair help needed
« on: February 16, 2019, 11:27:04 am »
Hello guys, I have a OWON SDS8302 Oscilloscope with a weird issue and I was wondering if somebody can help me troubleshoot the fault. The scope turns on normally, makes some relay clicks on initial startup screen then boots into the main scope screen but for some reason none of the controls respond. There is no trace signal and the screen seems to be frozen or locked up. I took a look inside and found nothing obvious, all power rails seem ok, and the main board looks clean under the microscope. I decided to do a firmware update thinking it may resolve the issue as OWON has released a firmware update for this model. I was able to connect the scope to my PC and install the USB drivers normally but when I run the patch software and click start to do a firmware update, for some reason it says "unable to read SN, make sure USB is connected". The weird thing is that the USB drivers install normally but it still doesn't communicate with the scope. I even tried the PC software to see if it would make a USB connection, it doesn't. I was wondering if it would be a good idea to do the firmware update using the JTAG header on the mainboard, if so, will someone please help me with the hardware and program needed to dump and rewrite the S3C2416+K9F1G08 NAND Flash. I do have a backup of the firmware which I downloaded from OWON. I know the NAND Flash may be security locked but there is a file called Public.key in the Patch installation folder which I believe is for unlocking the flash but I'm not sure. I want to do a firmware update to know if the issue is hardware related or not .. Any help will be greatly appreciated! Paul  :-BROKE
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf