Author Topic: Please help me repair a SMPS  (Read 2300 times)

0 Members and 1 Guest are viewing this topic.

Offline zape

  • Contributor
  • Posts: 26
  • Country: us
Please help me repair a SMPS
« on: November 10, 2017, 07:50:58 am »
I'm trying to repair this SMPS
It shorts when I plug it in with a bulb in series.
I replaced Mosfet and switching transistors, and also sense resistor because they were blown. also replaced a few zener diodes and shorted zener diode on the secondary side.
I even bought a scope and found out that the switching frequency is 20k and the MOSFET is almost always closed, the PWM pulses on the gate are almost 100% duty cycle. What could be the reason?
Attaching a schematic in the PDF
 

Offline capt bullshot

  • Super Contributor
  • ***
  • Posts: 1773
  • Country: de
    • Mostly useless stuff, but nice to have: wunderkis.de
Re: Please help me repair a SMPS
« Reply #1 on: November 10, 2017, 08:25:05 am »
 Missing feedback or shorted/overloaded output
Check the circuitry around D660 and the optocouplers.
Safety devices hinder evolution
 

Offline zape

  • Contributor
  • Posts: 26
  • Country: us
Re: Please help me repair a SMPS
« Reply #2 on: November 10, 2017, 04:06:59 pm »
I checked and actually replaced D660 it works fine.
Will check the optocoupler
The output voltage seem to be correct +21V but voltages on the optocoupler (on the secondary side) are 1.2-3.2v so it looks like D660 is pulling it to the ground.

« Last Edit: November 10, 2017, 04:24:24 pm by zape »
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Please help me repair a SMPS
« Reply #3 on: November 10, 2017, 04:36:08 pm »
Hi,

You should check the ohms of R654 and R655 with power off.

 ;D
 

Offline zape

  • Contributor
  • Posts: 26
  • Country: us
Re: Please help me repair a SMPS
« Reply #4 on: November 10, 2017, 04:39:53 pm »
R654 and R655 are good. I think I checked every single resistor on the primary side and around feedback area on the secondary
 

Offline zape

  • Contributor
  • Posts: 26
  • Country: us
Re: Please help me repair a SMPS
« Reply #5 on: November 10, 2017, 05:08:54 pm »
I now checked the optocoupler (it was bad) and replaced it.
The same result.
Checked the optocoupler and it still works.
Any ideas?
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Please help me repair a SMPS
« Reply #6 on: November 10, 2017, 05:19:06 pm »
R654 and R655 are good. I think I checked every single resistor on the primary side and around feedback area on the secondary

Yeap, the secondary side should be In order, 50mA flowing across the resistors is well within the capability of SL431A.

Edit: You sure you checked D605? How did you check it?

Is the output voltage correct?
« Last Edit: November 10, 2017, 05:24:22 pm by Armadillo »
 

Offline zape

  • Contributor
  • Posts: 26
  • Country: us
Re: Please help me repair a SMPS
« Reply #7 on: November 10, 2017, 05:29:58 pm »
I checked it in-circuit with multimiter like a normal diode. It conducts one way. I did not check the Zener voltage.
The output voltage is +21V and it is correct.
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Please help me repair a SMPS
« Reply #8 on: November 10, 2017, 06:05:24 pm »
I checked it in-circuit with multimiter like a normal diode. It conducts one way. I did not check the Zener voltage.
The output voltage is +21V and it is correct.

So your question is actually on the PWM, Why it's on 100% duty as you purported by measuring the voltage of 4.9volts. The gate is always power "ON" by the resistors divider and zener diode at the gate. You can see for yourself. So voltage measurement at the Gate is surely incorrect.  It will be pulsed "OFF" by the transistor.

No it is not 100% duty, You should actually see it on a oscilloscope probe it onto R611 [with isolating transformer].

The wave is actually by number of pulses. As you load it more, more pulses rises to appear. As you load it less, less pulses will appear.

This power supply is BAD, at most 55% efficient and will fail horribly.

Edit: To put it simply, this is not a PWM switching power supply, it is a PFM switching power supply.    ;D
« Last Edit: November 10, 2017, 06:24:45 pm by Armadillo »
 

Offline zape

  • Contributor
  • Posts: 26
  • Country: us
Re: Please help me repair a SMPS
« Reply #9 on: November 10, 2017, 06:36:55 pm »
Here are some photos:
I used X10 probe (and I use Backup UPS instead of isolation transformer, because I don't have one)
« Last Edit: November 10, 2017, 06:39:37 pm by zape »
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Please help me repair a SMPS
« Reply #10 on: November 10, 2017, 06:48:21 pm »
Load up the power supply say 0.5A, 1,A, 2A [check whether it is able] and probe across R611.
Then you see the PFM properly.

Edit: I am not sure, no knowledge about backup UPS or whether it's isolated. ???  :-//  :-// .
« Last Edit: November 10, 2017, 07:00:44 pm by Armadillo »
 

Offline zape

  • Contributor
  • Posts: 26
  • Country: us
Re: Please help me repair a SMPS
« Reply #11 on: November 10, 2017, 07:11:29 pm »
Ok the only load I was able to find around was electric boiler which measures around 10Ohm
The output voltage drops from 21 to around 3v when I connect it.
Attached scope photos:
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Please help me repair a SMPS
« Reply #12 on: November 10, 2017, 07:21:39 pm »
Ok the only load I was able to find around was electric boiler which measures around 10Ohm

"Electric Boilder" and its 100 ohm ???????
How did you measure the ohm? By multimeter?

Edit: Measure the voltage at the opto-coupler, whether the SL431 releases the current.? or same as before?
« Last Edit: November 10, 2017, 07:25:57 pm by Armadillo »
 

Offline zape

  • Contributor
  • Posts: 26
  • Country: us
Re: Please help me repair a SMPS
« Reply #13 on: November 10, 2017, 07:23:48 pm »
10, not 100
Yes used multimiter
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Please help me repair a SMPS
« Reply #14 on: November 10, 2017, 07:26:14 pm »
10, not 100
Yes used multimiter

Measure the voltage at the opto-coupler, whether the SL431 releases the current.? or same as before?

BTW: what is the Max current of this power supply?
« Last Edit: November 10, 2017, 07:27:56 pm by Armadillo »
 

Offline zape

  • Contributor
  • Posts: 26
  • Country: us
Re: Please help me repair a SMPS
« Reply #15 on: November 10, 2017, 07:38:58 pm »
Yes it does.
With load connected the opto-coupler is off. No voltage drop on it, and all voltages are equal to ~3v output.
The TV is rated at 90W so I guess the max current is about 2-3A x 21v

 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Please help me repair a SMPS
« Reply #16 on: November 10, 2017, 07:46:04 pm »
Yes it does.
With load connected the opto-coupler is off. No voltage drop on it, and all voltages are equal to ~3v output.
The TV is rated at 90W so I guess the max current is about 2-3A x 21v


So is a TV power supply... There are the command On signal from the TV. I suggest you plug this power supply back into the TV to test it.
There are also the 3.3v, 13v etc...
 

Offline zape

  • Contributor
  • Posts: 26
  • Country: us
Re: Please help me repair a SMPS
« Reply #17 on: November 10, 2017, 07:50:44 pm »
I forced the PSU to turn on.
I don't think it should drain so much power when powered so the bulb lights up

 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Please help me repair a SMPS
« Reply #18 on: November 10, 2017, 07:54:43 pm »
you should measure all the secondary power whether is OK, e.g 13V, 3.3 V, 21 V etc.....
Anyone shorted.?

Edit: What bulb lights UP? What is so much power? 

Edit: I know this type of power supply is 50% efficient. From your scope trace, I deduced 19W is expended somewhere, don't know if you have connected something consuming 19W or secondary voltage of one of them is shorted.
« Last Edit: November 10, 2017, 08:04:38 pm by Armadillo »
 

Offline zape

  • Contributor
  • Posts: 26
  • Country: us
Re: Please help me repair a SMPS
« Reply #19 on: November 10, 2017, 08:03:40 pm »
Nothing shorted on the secondary side. all voltages are fine
I learned this "bulb trick" here: you connect your device not directly to mains but through a 100W light bulb in series that acts as protection in case the power supply is draining too much power (as in my case)
If I connect it directly to the mains the fuse will blow up and probably mosfet and others (I learned this the hard way lol)
« Last Edit: November 10, 2017, 08:08:15 pm by zape »
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Please help me repair a SMPS
« Reply #20 on: November 10, 2017, 08:06:27 pm »
Nothing shorted on the secondary side. all voltages are fine
I learn this "bulb trick" here: you connect your device not directly to mains but through a 100W light bulb in series that acts as protection in case the power supply is draining too much power (as in my case)

The trick is for initial testing of power supply incase short circuit. If is not short circuit anymore, you should take the series light bulb out.
 

Offline zape

  • Contributor
  • Posts: 26
  • Country: us
Re: Please help me repair a SMPS
« Reply #21 on: November 10, 2017, 08:09:18 pm »
but it is shorted - the bulb is very bright
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Please help me repair a SMPS
« Reply #22 on: November 10, 2017, 08:09:28 pm »
Nothing shorted on the secondary side. all voltages are fine
I learned this "bulb trick" here: you connect your device not directly to mains but through a 100W light bulb in series that acts as protection in case the power supply is draining too much power (as in my case)
If I connect it directly to the mains the fuse will blow up and probably mosfet and others (I learned this the hard way lol)

If all the voltages are fine, just plug it back to the TV.    ;D
WITHOUT THE SERIES LIGHT BULB...... hahahahahah LOL.
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Please help me repair a SMPS
« Reply #23 on: November 10, 2017, 08:12:28 pm »
but it is shorted - the bulb is very bright

Hello, how many watts is the series light bulb you used.? What bulb is that? Is it incandescent bulb?

The mosfet is only firing at 0.25A. [from your scope].

What is the AC current flowing through, can your backup power supply show the current, if not, measure the AC current.

Don't let the bulb trick you.

« Last Edit: November 10, 2017, 08:15:55 pm by Armadillo »
 

Offline Armadillo

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: 00
Re: Please help me repair a SMPS
« Reply #24 on: November 10, 2017, 08:19:52 pm »
Man!..... to think that you want to do a load test with a series light bulb dragging the voltage in circuit......  |O
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf