Author Topic: Tektronix 7704a Won't turn on and flashes the neon starters  (Read 6842 times)

0 Members and 1 Guest are viewing this topic.

Online tautech

  • Super Contributor
  • ***
  • Posts: 19115
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Tektronix 7704a Won't turn on and flashes the neon starters
« Reply #25 on: October 14, 2015, 12:20:11 am »
More than likely PSU, it should always be checked first to see if it is to spec.
Study the service manual PSU section carefully.

Another handy link:
http://www.sphere.bc.ca/test/tek-parts/troubleshooting-scopes.pdf
Avid Rabid Hobbyist
 

Offline tedybear315

  • Contributor
  • Posts: 16
  • Country: us
Re: Tektronix 7704a Won't turn on and flashes the neon starters
« Reply #26 on: October 14, 2015, 12:41:25 am »
I'll meander down to the PSU in a bit.  I've got the other one that seems to be functional and I'm giving it a bit of work.  (larger screen)  The only downfall of the older military one would be one of the knobs on the control board got smacked clean off.   Not sure if I should attempt to repair it or just leave it alone.  The main knob for the voltage is fine, it's the center built in knob that got snapped clean off.

I'm back to work tomorrow, so I'll be calling it a night pretty soon anyway.  Thanks again for the help!! I'll start to watch the video on scope basics once I get the bugs worked out.

S-
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 19115
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Tektronix 7704a Won't turn on and flashes the neon starters
« Reply #27 on: October 14, 2015, 12:46:56 am »
I'll meander down to the PSU in a bit.  I've got the other one that seems to be functional and I'm giving it a bit of work.  (larger screen)  The only downfall of the older military one would be one of the knobs on the control board got smacked clean off.   Not sure if I should attempt to repair it or just leave it alone.  The main knob for the voltage is fine, it's the center built in knob that got snapped clean off.

I'm back to work tomorrow, so I'll be calling it a night pretty soon anyway.  Thanks again for the help!! I'll start to watch the video on scope basics once I get the bugs worked out.

S-
Sphere have many of the knobs.
Avid Rabid Hobbyist
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf